[PATCH] gnu: Add ladspa-bs2b

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Frederickson
  • Leo Famulari
Owner
unassigned
Submitted by
Jonathan Frederickson
Severity
normal

Debbugs page

Jonathan Frederickson wrote 5 years ago
(address . guix-patches@gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
20200501005801.28771-1-jonathan@terracrypt.net
* gnu/packages/audio.scm (ladspa-bs2b): New variable.
---
gnu/packages/audio.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e2e276723b..5252704722 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1855,6 +1855,31 @@ for headphone prolonged listening to disable superstereo fatigue without
essential distortions.")
(license license:expat)))
+(define-public ladspa-bs2b
+ (package
+ (name "ladspa-bs2b")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/bs2b/plugins/LADSPA%20plugin/"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b4aipbj1ba5k99gbc7gmgy14sywyrjd8rpyqj5l905j0mjv8jg2"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("ladspa" ,ladspa)
+ ("libbs2b" ,libbs2b)))
+ (home-page "https://sourceforge.net/projects/bs2b/")
+ (synopsis "Bauer stereophonic-to-binaural DSP - LADSPA plugin")
+ (description "The Bauer stereophonic-to-binaural DSP (bs2b) library and
+plugins is designed to improve headphone listening of stereo audio records.
+Recommended for headphone prolonged listening to disable superstereo fatigue
+without essential distortions. This package contains a LADSPA plugin for use
+with applications that support them (e.g. PulseAudio).")
+ (license license:gpl2)))
+
(define-public liblo
(package
(name "liblo")
--
2.26.2
Leo Famulari wrote 5 years ago
(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)(address . 40991-done@debbugs.gnu.org)
20200501213850.GA24439@jasmine.lan
On Thu, Apr 30, 2020 at 08:58:01PM -0400, Jonathan Frederickson wrote:
Toggle quote (2 lines)
> * gnu/packages/audio.scm (ladspa-bs2b): New variable.

Thanks! I pushed as ecd56cd1b223733c3ec04043fec245acf4c1cdb8 after
adding a copyright line for you and changing the license field to gpl2+,
since the license header of 'src/plugin.c' includes the "or any later
version" bit.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40991@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40991
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help