Rene wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
hello,
this is a patch to update balsa to 2.6.0.
Rene
From b648b4a7116f2098ab3e16d018aa0278b7398875 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <pacoon@protonmail.com>
Date: Mon, 27 Apr 2020 23:59:18 -0500
Subject: [PATCH] gnu: balsa: Update to 2.6.0.
* gnu/packages/mail.scm (balsa): Update to 2.6.0.
[inputs]: Replace gmime-2.6 with gmime; add libical and libsecret.
---
gnu/packages/mail.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
Toggle diff (51 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index cb5e23bcea..2a6286fb16 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
+;;; Copyright © 2017, 2018, 2020 Rene Saavedra <pacoon@protonmail.com>
;;; Copyright © 2018, 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
@@ -2755,14 +2755,14 @@ tools and applications:
(define-public balsa
(package
(name "balsa")
- (version "2.5.7")
+ (version "2.6.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://pawsa.fedorapeople.org/balsa/"
name "-" version ".tar.bz2"))
(sha256
- (base32 "0yfqhfpwm1qnwmbpr6dfn2f5w8a8xxq51pn8ypgg0fw973l1c1nx"))))
+ (base32 "0ycidvgy9npd6avxk88sf2ca609m7zb0hzrk1yajrgwb1rfqx68a"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2780,7 +2780,7 @@ tools and applications:
`(("cyrus-sasl" ,cyrus-sasl)
("enchant" ,enchant)
("gdk-pixbuf" ,gdk-pixbuf)
- ("gmime" ,gmime-2.6)
+ ("gmime" ,gmime)
("gnutls" ,gnutls)
("gpgme" ,gpgme)
("gtk+" ,gtk+)
@@ -2788,7 +2788,9 @@ tools and applications:
("gtkspell3" ,gtkspell3)
("libcanberra" ,libcanberra)
("libesmtp" ,libesmtp)
+ ("libical" ,libical)
("libnotify" ,libnotify)
+ ("libsecret" ,libsecret)
("openldap" ,openldap)
("sqlite" ,sqlite)
("webkitgtk" ,webkitgtk)))
--
2.21.0