GNU FreeFont silent build failure

  • Open
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal

Debbugs page

Leo Famulari wrote 5 years ago
(address . bug-guix@gnu.org)
20200422215126.GA1669@jasmine.lan
The GNU FreeFont package is still using system* instead of invoke in its
install phase, and this is failing silently:

------
mkdir /gnu/store/1nfp73g3s15dhpqjrbfsihk7jrcbbl1p-font-gnu-freefont-20120503/share/doc/font-gnu-freefont-20120503
cp -a README AUTHORS CREDITS COPYING ChangeLog INSTALL /gnu/store/1nfp73g3s15dhpqjrbfsihk7jrcbbl1p-font-gnu-freefont-20120503/share/doc/font-gnu-freefont-20120503
cp -a notes/usage.txt /gnu/store/1nfp73g3s15dhpqjrbfsihk7jrcbbl1p-font-gnu-freefont-20120503/share/doc/font-gnu-freefont-20120503/USAGE
cp -a notes/troubleshooting.txt /gnu/store/1nfp73g3s15dhpqjrbfsihk7jrcbbl1p-font-gnu-freefont-20120503/share/doc/font-gnu-freefont-20120503/TROUBLESHOOTING
tar czvf freefont-ttf-20200422.tar.gz freefont-20200422/
tar: freefont-20200422: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
make: *** [Makefile:64: ttftar] Error 2
phase `install' succeeded after 0.2 seconds
------

Notice that it is using the current date. It doesn't work to use the
Unix epoch or the version of the package: 20120503 (see attached).

We should figure out what this is trying to accomplish, fix it, and
switch to invoke.

The fonts are getting installed AFAICT.
`(#:modules ((srfi srfi-19) ; make-time, et cetera
(guix build utils)
(guix build gnu-build-system))
#:phases
(modify-phases %standard-phases
;; The FreeFont build scripts try to use the current time and date as
;; names for generated files.
(add-after 'unpack 'source-date-epoch
(lambda _
(substitute* "Makefile"
(("\\$\\(shell date \\+\\\"%Y%m%d\\\"\\)")
(date->string
(time-utc->date
(make-time time-utc 0
(string->number (getenv "SOURCE_DATE_EPOCH"))))
"~4")))
#t))
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 40783@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40783
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help