New package: VisiData

  • Done
  • quality assurance status badge
Details
3 participants
  • Jack Hill
  • Ricardo Wurmus
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 22 Apr 2020 02:51
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
RoiyMULUjGVOW3uPsdNHBfZqzTyiHm9dNBj8afqAl9_u2qg5u3biqdqlHbKYgjIq33NPdMcFO1jxE-5DK0dJjLet2xcW_DAjuKnV9zFc7lI=@protonmail.com
Hi Guix! This patch adds a package for VisiData.

VisiData is an interactive multitool for tabular data. It combines the clarity of a spreadsheet, the efficiency of the terminal, and the power of Python, into a lightweight utility which can handle millions of rows with ease. https://www.visidata.org/,GPLv3

Tests are disabled because they are not packaged with the source tarball.
Upstream suggests tests will be packaged with their source tarball around their 2.0 release.

Cheers,
Ryan Prior
Attachment: file
From a86e002cd133371eafbd1adbf1354afd3796c9eb Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Tue, 21 Apr 2020 16:56:42 -0500
Subject: [PATCH] gnu: Add visidata.

* gnu/packages/visidata.scm (visidata): New variable.
---
gnu/packages/visidata.scm | 61 +++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)
create mode 100644 gnu/packages/visidata.scm

Toggle diff (69 lines)
diff --git a/gnu/packages/visidata.scm b/gnu/packages/visidata.scm
new file mode 100644
index 0000000000..d9df94dc9b
--- /dev/null
+++ b/gnu/packages/visidata.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (visidata)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages python-science)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages time)
+ #:use-module (gnu packages xml)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages))
+
+(define-public visidata
+ (package
+ (name "visidata")
+ (version "1.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/saulpw/visidata/archive/v" version ".tar.gz"))
+ (sha256 (base32 "0h7hq6bnc8svkcc9995kkmgcb9n5qgm85rsshzzdicmg9rg3ymhi"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f))
+ ;; Tests disabled because they are not packaged with the source tarball.
+ ;; View test status here: https://circleci.com/gh/saulpw/visidata/tree/stable
+ ;; Upstream suggests tests will be packaged with tarball around 2.0 release.
+ (native-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-fonttools" ,python-fonttools)
+ ("python-h5py" ,python-h5py)
+ ("python-lxml" ,python-lxml)
+ ("python-openpyxl" ,python-openpyxl)
+ ("python-psycopg2" ,python-psycopg2)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-xlrd" ,python-xlrd)
+ ("python-pandas" ,python-pandas)))
+ (synopsis "Visidata: A terminal spreadsheet multitool for discovering and arranging data")
+ (description
+ "VisiData is an interactive multitool for tabular data. It combines the
+clarity of a spreadsheet, the efficiency of the terminal, and the power of
+Python, into a lightweight utility which can handle millions of rows with ease.")
+ (home-page "https://www.visidata.org/")
+ (license gpl3)))
--
2.17.1
J
J
Jack Hill wrote on 22 Apr 2020 17:53
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 40757@debbugs.gnu.org)
alpine.DEB.2.20.2004221104500.5735@marsh.hcoop.net
Ryan,

On Wed, 22 Apr 2020, Ryan Prior via Guix-patches via wrote:

Toggle quote (7 lines)
> Hi Guix! This patch adds a package for VisiData.
>
> VisiData is an interactive multitool for tabular data. It combines the clarity of a
> spreadsheet, the efficiency of the terminal, and the power of Python, into a
> lightweight utility which can handle millions of rows with ease.
> https://www.visidata.org/, GPLv3

Thanks for the patch! This looks like some cool software.

I'm not an expert reviewer, but I'd like to try to help by offering the
following suggestions for improvement.

Toggle quote (6 lines)
>diff --git a/gnu/packages/visidata.scm b/gnu/packages/visidata.scm
>new file mode 100644
>index 0000000000..d9df94dc9b
>--- /dev/null
>+++ b/gnu/packages/visidata.scm

When adding new modules, please also add the file to gnu/local.mk

Toggle quote (2 lines)
>+(define-module (visidata)

The module name should be (gnu packages visidata) to match the filesystem
path.

It might be helpful to catch problems like this to try to apply your patch
apply your patch to a guix source checkout, and try building your package
from there. The manual has some documentation about that,
can answer questions as well.

Toggle quote (8 lines)
>+(define-public visidata
>+ (package
>+ (name "visidata")
>+ (version "1.5.2")
>+ (source (origin
>+ (method url-fetch)
>+ (uri (string-append "https://github.com/saulpw/visidata/archive/v" version ".tar.gz"))

The GitHub archive URIs are not stable and could result in a different
hash in the future. Often in these cases we use git-fetch, but since
visidata is available on pypi, I would recommend

(uri (pypi-uri "visidata" version))

Toggle quote (7 lines)
>+ (sha256 (base32 "0h7hq6bnc8svkcc9995kkmgcb9n5qgm85rsshzzdicmg9rg3ymhi"))))
>+ (build-system python-build-system)
>+ (arguments '(#:tests? #f))
>+ ;; Tests disabled because they are not packaged with the source tarball.
>+ ;; View test status here: https://circleci.com/gh/saulpw/visidata/tree/stable
>+ ;; Upstream suggests tests will be packaged with tarball around 2.0 release.

Nitpick: I would prefer to have the comment before the code. I think the
line about circleci could be removed, but the other two seem good.

Toggle quote (12 lines)
>+ (native-inputs
>+ `(("python-dateutil" ,python-dateutil)
>+ ("python-fonttools" ,python-fonttools)
>+ ("python-h5py" ,python-h5py)
>+ ("python-lxml" ,python-lxml)
>+ ("python-openpyxl" ,python-openpyxl)
>+ ("python-psycopg2" ,python-psycopg2)
>+ ("python-pyyaml" ,python-pyyaml)
>+ ("python-requests" ,python-requests)
>+ ("python-xlrd" ,python-xlrd)
>+ ("python-pandas" ,python-pandas)))

Are these all native inputs (required to make the build system run)? I
expect that some of them could be moved to inputs (run-tine dependencies).

Toggle quote (2 lines)
>+ (synopsis "Visidata: A terminal spreadsheet multitool for discovering and arranging data")

guix lint reports that the synopsis should not start with the package
name. In this case, I think it could be changed to, "Terminal spreadsheet
for discovering and arranging data".

Toggle quote (3 lines)
>+ (description
>+ "VisiData is an interactive multitool for tabular data. It combines the

Please use two spaces between sentences in the description.

Toggle quote (3 lines)
>+clarity of a spreadsheet, the efficiency of the terminal, and the power of
>+Python, into a lightweight utility which can handle millions of rows with ease.")

Nitpick: "with ease" sounds like a marketing term, and I believe we can
leave it out here.

Toggle quote (3 lines)
>+ (license gpl3)))

In other modules, we import licenses with the license: prefix, so we can
refer to licenses as like license:gpl3. It might be nice to do that
here for consistency as well.

The vdtui.py file is under the expat license, so we should record that
here. With these changes the license field would become something like:

(license (list license:gpl3
license:expat)) ; visidata/vdtui.py

Thanks and all the best,
Jack
R
R
Ryan Prior wrote on 22 Apr 2020 22:24
(name . Jack Hill)(address . jackhill@jackhill.us)(name . 40757@debbugs.gnu.org)(address . 40757@debbugs.gnu.org)
NE_-mIBWQF-dqC5Te0zY6czGH4EZEpTtaiazpp6nx5DX1gFzpgn3vdwWNHnF2YxTj3VbxuhGFji-k9rD6n3TMvb4C73EeJ51hRJJHb-ph08=@protonmail.com
Hi Jack,

??????? Original Message ???????
On Wednesday, April 22, 2020 3:53 PM, Jack Hill <jackhill@jackhill.us> wrote:


Toggle quote (3 lines)
> I'm not an expert reviewer, but I'd like to try to help by offering the
> following suggestions for improvement.

Thank you for these suggestions! I've attached an updated version of the patch.

Ryan
From 5649ec22097278193426474b9a2f460cc3a931e0 Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Tue, 21 Apr 2020 16:56:42 -0500
Subject: [PATCH] gnu: Add visidata.

* gnu/packages/visidata.scm (visidata): New variable.
---
gnu/local.mk | 2 ++
gnu/packages/visidata.scm | 61 +++++++++++++++++++++++++++++++++++++++
2 files changed, 63 insertions(+)
create mode 100644 gnu/packages/visidata.scm

Toggle diff (89 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index e70715000a..0cf64063c8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -31,6 +31,7 @@
# Copyright © 2020 R Veera Kumar <vkor@vkten.in>
# Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
# Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+# Copyright © 2020 Ryan Prior <rprior@protonmail.com>
#
# This file is part of GNU Guix.
#
@@ -521,6 +522,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/video.scm \
%D%/packages/vim.scm \
%D%/packages/virtualization.scm \
+ %D%/packages/visidata.scm \
%D%/packages/vnc.scm \
%D%/packages/vpn.scm \
%D%/packages/vulkan.scm \
diff --git a/gnu/packages/visidata.scm b/gnu/packages/visidata.scm
new file mode 100644
index 0000000000..9647b49289
--- /dev/null
+++ b/gnu/packages/visidata.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages visidata)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages python-science)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages time)
+ #:use-module (gnu packages xml)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public visidata
+ (package
+ (name "visidata")
+ (version "1.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "visidata" version))
+ (sha256 (base32 "10adfyn4gkisvciqawgh2lakkhhnjjxiyp7mzbgcwkq1b3sigpf1"))))
+ (build-system python-build-system)
+ ;; Tests disabled because they are not packaged with the source tarball.
+ ;; Upstream suggests tests will be packaged with tarball around 2.0 release.
+ (arguments '(#:tests? #f))
+ (inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-fonttools" ,python-fonttools)
+ ("python-h5py" ,python-h5py)
+ ("python-lxml" ,python-lxml)
+ ("python-openpyxl" ,python-openpyxl)
+ ("python-psycopg2" ,python-psycopg2)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-xlrd" ,python-xlrd)
+ ("python-pandas" ,python-pandas)))
+ (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
+ (description
+ "VisiData is an interactive multitool for tabular data. It combines the
+clarity of a spreadsheet, the efficiency of the terminal, and the power of
+Python, into a lightweight utility which can handle millions of rows.")
+ (home-page "https://www.visidata.org/")
+ (license (list license:gpl3
+ license:expat)))) ;; visidata/vdtui.py
--
2.17.1
J
J
Jack Hill wrote on 22 Apr 2020 23:03
(name . Ryan Prior)(address . rprior@protonmail.com)(name . 40757@debbugs.gnu.org)(address . 40757@debbugs.gnu.org)
alpine.DEB.2.20.2004221701280.5735@marsh.hcoop.net
On Wed, 22 Apr 2020, Ryan Prior via Guix-patches via wrote:

Toggle quote (11 lines)
> Hi Jack,
>
> ??????? Original Message ???????
> On Wednesday, April 22, 2020 3:53 PM, Jack Hill <jackhill@jackhill.us> wrote:
>
>
>> I'm not an expert reviewer, but I'd like to try to help by offering the
>> following suggestions for improvement.
>
> Thank you for these suggestions! I've attached an updated version of the patch.

You're welcome, and thanks for sending the updated patch.

I think now we're waiting on a more experienced reviewer to see if I
missed anything, and if it looks good a committer to push your patch.

Best,
Jack
R
R
Ricardo Wurmus wrote on 23 Apr 2020 07:24
(address . 40757-done@debbugs.gnu.org)
878simlqq5.fsf@elephly.net
Hi Ryan,

I’ve adjusted the patch to gnu/local.mk which no longer applied, changed
spaces to tabs in gnu/local.mk, fixed the indentation of visidata.scm,
ran “guix lint”, built it and tested it (didn’t know how to exit, so I
just did ^Zkill %1) … and pushed it to the master branch with commit
c47f48d972.

Thank you for your patch!

--
Ricardo
R
R
Ricardo Wurmus wrote on 23 Apr 2020 07:25
(name . Jack Hill)(address . jackhill@jackhill.us)
877dy6lqnn.fsf@elephly.net
Hey Jack,

thanks to your review and Ryan’s response to it I only had to perform
minimal changes to apply the patch. Thank you very much!

--
Ricardo
J
J
Jack Hill wrote on 23 Apr 2020 17:29
(name . Ricardo Wurmus)(address . rekado@elephly.net)
alpine.DEB.2.20.2004231126560.5735@marsh.hcoop.net
On Thu, 23 Apr 2020, Ricardo Wurmus wrote:

Toggle quote (6 lines)
>
> Hey Jack,
>
> thanks to your review and Ryan’s response to it I only had to perform
> minimal changes to apply the patch. Thank you very much!

You're welcome. It makes me happy to help where I can.

I ? Guix
?