gnu: font-gnu-unifont: Unify outputs for fonts.

  • Open
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 19 Apr 2020 07:24
(address . guix-patches@gnu.org)
20200419012441.62891acb.raghavgururajan@disroot.org

From dff7acc350ba6f2e8d6ba3b561fb58acdc1a9c00 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 19 Apr 2020 01:18:41 -0400
Subject: [PATCH 2/2] gnu: font-gnu-unifont: Unify outputs for fonts.

* gnu/package/fonts.scm (font-gnu-unifont): Unify outputs for fonts.

Let us not over-do multiple outputs. Separating fonts and binaries is
sane enough. Also, GNU Unifont only have very few fonts in each format.
---
gnu/packages/fonts.scm | 14 ++++++--------
1 file changed, 6 insertions(+), 8 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 0356d50c7c..77103bdd39 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -681,9 +681,7 @@ for use at smaller text sizes")))
(sha256
(base32 "1svzm3xahb2m8r79ha9gb1z3zlckykx9d87cghswj7dxn9868j4b"))))
(build-system gnu-build-system)
- (outputs '("out" ; TrueType version
- "pcf" ; PCF (bitmap) version
- "psf" ; PSF (console) version
+ (outputs '("out" ; Fonts
"bin")) ; Utilities to manipulate '.hex' format
(arguments
'(#:tests? #f ; no check target
@@ -696,11 +694,11 @@ for use at smaller text sizes")))
'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((ttf (string-append (assoc-ref outputs "out")
- "/share/fonts/truetype"))
- (pcf (string-append (assoc-ref outputs "pcf")
- "/share/fonts/misc"))
- (psf (string-append (assoc-ref outputs "psf")
- "/share/consolefonts"))
+ "/share/fonts/ttf"))
+ (pcf (string-append (assoc-ref outputs "out")
+ "/share/fonts/pcf"))
+ (psf (string-append (assoc-ref outputs "out")
+ "/share/fonts/psf"))
(bin (assoc-ref outputs "bin")))
(invoke "make"
(string-append "PREFIX=" bin)
--
2.26.1
L
L
Leo Famulari wrote on 23 Apr 2020 04:30
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40708@debbugs.gnu.org)
20200423023022.GA10882@jasmine.lan
On Sun, Apr 19, 2020 at 01:24:41AM -0400, Raghav Gururajan wrote:

Toggle quote (10 lines)
> From dff7acc350ba6f2e8d6ba3b561fb58acdc1a9c00 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sun, 19 Apr 2020 01:18:41 -0400
> Subject: [PATCH 2/2] gnu: font-gnu-unifont: Unify outputs for fonts.
>
> * gnu/package/fonts.scm (font-gnu-unifont): Unify outputs for fonts.
>
> Let us not over-do multiple outputs. Separating fonts and binaries is
> sane enough. Also, GNU Unifont only have very few fonts in each format.

There is a significant size difference between these outputs. Is there
any prior discussion about what they are used for? Is there something to
gain by combining them?
R
R
Raghav Gururajan wrote on 23 Apr 2020 04:44
(name . Leo Famulari)(address . leo@famulari.name)(address . 40708@debbugs.gnu.org)
20200422224409.22805bb0.raghavgururajan@disroot.org
Hi Leo!

Toggle quote (4 lines)
> There is a significant size difference between these outputs. Is there
> any prior discussion about what they are used for? Is there something to
> gain by combining them?

Not sure about discussion, but it is better to combine fonts and keep just
binaries separate. Because if a user install unifont to use in their
applications, not all of them gonna use ttf. Some apps gonna look for otf
formats. It would be confusing to install three different outputs for get all
formats.

Regards,
RG.
L
L
Leo Famulari wrote on 23 Apr 2020 18:05
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40708@debbugs.gnu.org)
20200423160538.GA29046@jasmine.lan
On Wed, Apr 22, 2020 at 10:44:09PM -0400, Raghav Gururajan wrote:
Toggle quote (6 lines)
> Not sure about discussion, but it is better to combine fonts and keep just
> binaries separate. Because if a user install unifont to use in their
> applications, not all of them gonna use ttf. Some apps gonna look for otf
> formats. It would be confusing to install three different outputs for get all
> formats.

Unifont provides TrueType, PCF, and PSF. It does not have OTF fonts.

Currently, if a user installs 'font-gnu-unifont' they get TrueType
fonts.

On the other hand, the PSF fonts can be used in the bootloader and the
Linux console, and they are only 68 kilobytes, rather than ~22 megabytes
if you combine all the font outputs. I don't see a compelling reason for
that increase.

If the problem is that packages with multiple outputs are confusing, we
should try to improve the UI, and we shouldn't use multiple outputs if
there isn't a good reason. But this is a case where I think it makes
sense.
R
R
Raghav Gururajan wrote on 11 May 2020 06:54
(name . Leo Famulari)(address . leo@famulari.name)(address . 40708@debbugs.gnu.org)
4f1c21b4-b3f2-b8e0-a434-26a5c1b8d0de@disroot.org
Hi Leo!

Sorry for the delayed response.

Toggle quote (2 lines)
> Unifont provides TrueType, PCF, and PSF. It does not have OTF fonts.

That's correct. I was suggesting a scenario of using more than one type. :-)

Toggle quote (8 lines)
> Currently, if a user installs 'font-gnu-unifont' they get TrueType
> fonts.
>
> On the other hand, the PSF fonts can be used in the bootloader and the
> Linux console, and they are only 68 kilobytes, rather than ~22 megabytes
> if you combine all the font outputs. I don't see a compelling reason for
> that increase.

OK. I think of two reasons: 1) If one installs this package with
suggested patch, the user can use unifont for any purpose as they wish.
It may be application (ttf), console/grub (psf) and/or display server
(pcf). 2) The setup will be consistent with other font packages, where
the package installs fonts with all the types it can provide.

Toggle quote (5 lines)
> If the problem is that packages with multiple outputs are confusing, we
> should try to improve the UI, and we shouldn't use multiple outputs if
> there isn't a good reason. But this is a case where I think it makes
> sense.

Improving UI would be good too. Regarding multiple outputs, I think it
is good enough to separate libs, bins and docs. In this packages, we
already separated bin and fonts. I suggest that we shall not separate
fonts further into it's subtypes. That is all I ask. :-)

Regards,
RG.
Attachment: signature.asc
R
R
Raghav Gururajan wrote on 11 May 2020 07:32
(name . Leo Famulari)(address . leo@famulari.name)(address . 40708@debbugs.gnu.org)
a76e371a-8f59-482d-1e11-6e4aaaf87ff7@disroot.org
Hi Leo!

Toggle quote (30 lines)
> Sorry for the delayed response.
>
>> Unifont provides TrueType, PCF, and PSF. It does not have OTF fonts.
>
> That's correct. I was suggesting a scenario of using more than one type. :-)
>
>> Currently, if a user installs 'font-gnu-unifont' they get TrueType
>> fonts.
>>
>> On the other hand, the PSF fonts can be used in the bootloader and the
>> Linux console, and they are only 68 kilobytes, rather than ~22 megabytes
>> if you combine all the font outputs. I don't see a compelling reason for
>> that increase.
>
> OK. I think of two reasons: 1) If one installs this package with
> suggested patch, the user can use unifont for any purpose as they wish.
> It may be application (ttf), console/grub (psf) and/or display server
> (pcf). 2) The setup will be consistent with other font packages, where
> the package installs fonts with all the types it can provide.
>
>> If the problem is that packages with multiple outputs are confusing, we
>> should try to improve the UI, and we shouldn't use multiple outputs if
>> there isn't a good reason. But this is a case where I think it makes
>> sense.
>
> Improving UI would be good too. Regarding multiple outputs, I think it
> is good enough to separate libs, bins and docs. In this packages, we
> already separated bin and fonts. I suggest that we shall not separate
> fonts further into it's subtypes. That is all I ask. :-)

I have attached revised patch with this email. :-)

Regards,
RG.
From 70037b0f0f640c64aa2323a0bc8ba85a17c5559e Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 11 May 2020 01:26:43 -0400
Subject: [PATCH] gnu: font-gnu-unifont: Unify outputs for fonts.

* gnu/package/fonts.scm (font-gnu-unifont): Combine font types.
[arguments]<'install>: Change outputs for pcf and psf to "out".
---
gnu/packages/fonts.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 6e9b080299..a79bdf72a6 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -689,9 +689,7 @@ for use at smaller text sizes")))
(sha256
(base32 "1svzm3xahb2m8r79ha9gb1z3zlckykx9d87cghswj7dxn9868j4b"))))
(build-system gnu-build-system)
- (outputs '("out" ; TrueType version
- "pcf" ; PCF (bitmap) version
- "psf" ; PSF (console) version
+ (outputs '("out" ; Fonts
"bin")) ; Utilities to manipulate '.hex' format
(arguments
'(#:tests? #f ; no check target
@@ -705,10 +703,10 @@ for use at smaller text sizes")))
(lambda* (#:key outputs #:allow-other-keys)
(let* ((ttf (string-append (assoc-ref outputs "out")
"/share/fonts/truetype"))
- (pcf (string-append (assoc-ref outputs "pcf")
- "/share/fonts/misc"))
- (psf (string-append (assoc-ref outputs "psf")
- "/share/consolefonts"))
+ (pcf (string-append (assoc-ref outputs "out")
+ "/share/fonts/portablecompiled"))
+ (psf (string-append (assoc-ref outputs "out")
+ "/share/fonts/pcscreen"))
(bin (assoc-ref outputs "bin")))
(invoke "make"
(string-append "PREFIX=" bin)
--
2.26.2
Attachment: signature.asc
?