gnu: transmission: Fix icons for GUI.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 16 Apr 2020 15:00
(address . guix-patches@gnu.org)
20200416090023.33a422bd.raghavgururajan@disroot.org
Hello Guix!

Please find the attached patch to fix icons for transmission's graphical user
interface.

Regards,
RG.
From 9ab623acb7f70a49f965202c475e18d70e9f8933 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 16 Apr 2020 08:57:46 -0400
Subject: [PATCH] gnu: transmission: Fix icons for GUI.

* gnu/packages/bittorrent.scm (transmission): Fix icons for GUI.
---
gnu/packages/bittorrent.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 03c7fe4515..f71e3be383 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -114,6 +114,8 @@
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme))) ; Required for GUI.
(home-page "https://transmissionbt.com/")
(synopsis "Fast and easy BitTorrent client")
(description
--
2.26.0
L
L
Leo Famulari wrote on 16 Apr 2020 18:21
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40659@debbugs.gnu.org)
20200416162105.GA17065@jasmine.lan
Toggle quote (7 lines)
> From 9ab623acb7f70a49f965202c475e18d70e9f8933 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Thu, 16 Apr 2020 08:57:46 -0400
> Subject: [PATCH] gnu: transmission: Fix icons for GUI.
>
> * gnu/packages/bittorrent.scm (transmission): Fix icons for GUI.

In general, we let users install the icons into their profiles rather
than propagating them.

Does Transmission work for you if you do that?
R
R
Raghav Gururajan wrote on 16 Apr 2020 18:35
Re: [bug#40659] gnu: transmission: Fix icons for GUI. (v2)
(name . Leo Famulari)(address . leo@famulari.name)(address . 40659@debbugs.gnu.org)
20200416123523.09b46bbe.raghavgururajan@disroot.org
Hi Leo!

Toggle quote (5 lines)
> In general, we let users install the icons into their profiles rather
> than propagating them.
>
> Does Transmission work for you if you do that?

Yes, it works.

Anyway, propagation is not reuired. Just as inputs works. Looks like missing
input. I have attached revised patch with this email.

Regards,
RG.
R
R
Raghav Gururajan wrote on 16 Apr 2020 18:37
(name . Leo Famulari)(address . leo@famulari.name)(address . 40659@debbugs.gnu.org)
20200416123746.0643f54f.raghavgururajan@disroot.org
Attached file here.
From 5c04a4ae3ae951ac643c346ab035cdde17e1eca7 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 16 Apr 2020 12:31:07 -0400
Subject: [PATCH] gnu: transmission: Fix icons for GUI.

* gnu/packages/bittorrent.scm (transmission): Fix icons for GUI.
---
gnu/packages/bittorrent.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 03c7fe4515..40b35b005a 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -103,7 +103,8 @@
'("applications" "icons" "pixmaps")))
#t)))))
(inputs
- `(("inotify-tools" ,inotify-tools)
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("inotify-tools" ,inotify-tools)
("libevent" ,libevent)
("curl" ,curl)
("cyrus-sasl" ,cyrus-sasl)
--
2.26.0
L
L
Leo Famulari wrote on 16 Apr 2020 19:36
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40659@debbugs.gnu.org)
20200416173631.GA16843@jasmine.lan
On Thu, Apr 16, 2020 at 12:35:23PM -0400, Raghav Gururajan wrote:
Toggle quote (9 lines)
> Hi Leo!
>
> > In general, we let users install the icons into their profiles rather
> > than propagating them.
> >
> > Does Transmission work for you if you do that?
>
> Yes, it works.

Okay, then I think we should stick with the status quo. We should only
add the icons as dependencies when necessary. Icons are something where
it's better to avoid a static binding, like the time zone database and
fonts.
R
R
Raghav Gururajan wrote on 16 Apr 2020 20:24
(name . Leo Famulari)(address . leo@famulari.name)(address . 40659@debbugs.gnu.org)
20200416142419.21a0d521.raghavgururajan@disroot.org
Hi Leo!

Toggle quote (5 lines)
> Okay, then I think we should stick with the status quo. We should only
> add the icons as dependencies when necessary. Icons are something where
> it's better to avoid a static binding, like the time zone database and
> fonts.

I understand. I think icons should be added as dependencies, when the program
is looking for a 'specific' icon theme. If the situation is like, the program
accepts any user-chosen/user-installed icon theme, then I think icons should
not be added as dependency. But here, transmission is hard-coded to use adwaita
icons. So it is a required dependecy and not optional dependency. :-)

Regards,
RG.
R
R
Raghav Gururajan wrote on 24 Apr 2020 23:08
gnu: transmission: Fix icons for GUI. (v3)
(address . 40659@debbugs.gnu.org)
20200424170821.11df200d.raghavgururajan@disroot.org

From 952cb241751727246d3a09ce36f479be8db20544 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 24 Apr 2020 17:02:26 -0400
Subject: [PATCH] gnu: transmission: Fix icons for GUI.

* gnu/packages/bittorrent.scm (transmission): Fix icons for GUI.

Since the adwaita icon theme is hard-coded in the application, there is
no choice for the user anyway. So let's add adwaita-icon-theme to inputs.
---
gnu/packages/bittorrent.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 03c7fe4515..e403b7b83b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -103,7 +103,8 @@
'("applications" "icons" "pixmaps")))
#t)))))
(inputs
- `(("inotify-tools" ,inotify-tools)
+ `(("adwaita-icon-theme" ,adwaita-icon-theme) ; Hard-coded theme
+ ("inotify-tools" ,inotify-tools)
("libevent" ,libevent)
("curl" ,curl)
("cyrus-sasl" ,cyrus-sasl)
--
2.26.1
L
L
Leo Famulari wrote on 27 Apr 2020 02:32
Re: [bug#40659] gnu: transmission: Fix icons for GUI. (v2)
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40659@debbugs.gnu.org)
20200427003224.GA1614@jasmine.lan
On Thu, Apr 16, 2020 at 02:24:19PM -0400, Raghav Gururajan wrote:
Toggle quote (6 lines)
> I understand. I think icons should be added as dependencies, when the program
> is looking for a 'specific' icon theme. If the situation is like, the program
> accepts any user-chosen/user-installed icon theme, then I think icons should
> not be added as dependency. But here, transmission is hard-coded to use adwaita
> icons. So it is a required dependecy and not optional dependency. :-)

I don't think that non-functional data (such as icons and fonts) should
be made dependencies of other packages unless necessary. Instead, they
should be installed alongside packages by users or system-level services
as on Guix System.
R
R
Raghav Gururajan wrote on 27 Apr 2020 07:33
(no subject)
(address . control@debbugs.gnu.org)
20200427013324.0bd6013f.raghavgururajan@disroot.org
close 40659
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40659@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40659
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch