[PATCH] gnu: Add gtkd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • guy fleury iteriteka
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal

Debbugs page

guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
20200415105034.8862-1-gfleury@disroot.org
* gnu/packages/dlang.scm(gtkd): New variable.
---
gnu/packages/dlang.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 3b0c799..c098b81 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 Frederick Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (gnu packages gdb)
#:use-module (gnu packages libedit)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages textutils))
@@ -348,3 +350,52 @@ The design emphasis is on maximum simplicity for simple projects,
while providing the opportunity to customize things when
needed.")
(license license:expat)))
+
+(define-public gtkd
+ (package
+ (name "gtkd")
+ (version "3.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gtkd.org/Downloads/sources/GtkD-"
+ version ".zip"))
+ (sha256
+ (base32 "0qv8qlpwwb1d078pnrf0a59vpbkziyf53cf9p6m8ms542wbcxllp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("ldc" ,ldc)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:make-flags '("DC=ldc2")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (let ((dir (string-append ,name "-" ,version)))
+ (invoke "unzip" "-d" dir source)
+ (chdir dir)
+ #t)))
+ (add-before 'build 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bindir (string-append out "/lib")))
+ (substitute* "GNUmakefile"
+ ;;remove test target due to path resolution in build env
+ ;;when compile tests and test can't succed gui launch
+ (("default-goal: libs test") "default-goal: libs")
+ (("all: libs shared-libs test") "all: libs shared-libs")
+ (("/usr/local") out)
+ (("libdir\\?\\=.*") (string-append "libdir?=" bindir "\n"))
+ (("\\$\\(prefix\\)\\/\\$\\(libdir\\)") "$(libdir)")))
+ #t)))))
+ (home-page "https://gtkd.org/")
+ (synopsis "D binding and OO wrapper of GTK+")
+ (description
+ "GTK+ is a highly usable, feature rich toolkit for creating graphical
+user interfaces which boasts cross platform compatibility and an easy to use
+API.")
+ (license license:lgpl2.1)))
--
2.25.1
Danny Milosavljevic wrote 5 years ago
(name . guy fleury iteriteka)(address . gfleury@disroot.org)(address . 40640-done@debbugs.gnu.org)
20200415153051.3e55b0d0@scratchpost.org
Hi,

thanks!

Pushed your patch with some simplifications to guix master as commit
141262f266ab702c856f634889d4130ae661e79f.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl6XDJIACgkQ5xo1VCww
uqX2HAf/RtSqcdfUxeGMbErBt4wuzQkLY7Un+bO/kRec+CjgDKjiXH6ERoqgWmp1
bjjMZoNRCZBmOJBJ0CXG3snHOUiEwO2o79Ohy1fbsUALAQ5+YVInNgNwp2eaLuu2
Izk1mFxT7ESngsU3xdkyVpo9LlQrThAXajotPLhWY6pKHFx4h2nJhrJ8oNgA2K6x
Tu8hir2WvLO/X8Q7sPkzSuNCppfJRgXmgpi5lXtQOai5TU/ny0RD3Ed3/GKX96le
JFSBRnzhqBv/rE9vf3JmiczEOQeP1lnxvlgyxvb3X1iHr50zsFjQjJNsAKuHMySR
ZzafSVLz2nl/nwI8C/yIaYBTu2I7Ew==
=DTkl
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40640@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40640
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help