[PATCH] gnu: Add emacs-typit.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alberto Eleuterio Flores Guerrero
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Alberto Eleuterio Flores Guerrero
Severity
normal

Debbugs page

Alberto Eleuterio Flores Guerrero wrote 5 years ago
(address . guix-patches@gnu.org)
20200414035236.22556-1-barbanegra+guix@posteo.mx
* gnu/packages/emacs-xyz.scm (emacs-typit): New variable.
---
gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a974d885e3..ea87802723 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -596,6 +596,44 @@ Gitea, Gogs and Bitbucket. It abstracts access to API resources using only a
handful of functions that are not resource-specific.")
(license license:gpl3+))))
+(define-public emacs-typit
+ (package
+ (name "emacs-typit")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/typit.git")
+ (commit "a4e3147dedac5535bdc8b06aca00f34f14f26e35")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hbnwrhxj9wwjvxsk372ffgjqfkb3ljxhgi5h7wps2r15dxfvf3w"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-dictionaries
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (site-lisp
+ (string-append
+ out "/share/emacs/site-lisp/dict")))
+ (mkdir-p site-lisp)
+ (copy-recursively "dict" site-lisp)
+ #t))))))
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-mmt" ,emacs-mmt)))
+ (home-page "https://github.com/mrkkrp/typit")
+ (synopsis "Typing game for Emacs with two difficulties")
+ (description "@code{emacs-typit} is a typing game
+for Emacs. Words that are picked randomly from the most
+frequent words in language you're practicing, until time
+is up.")
+ (license license:gpl3)))
+
(define-public emacs-scribble-mode
(let ((commit "217945d54de5e4bb207033f2116baa28f5c5ecf2")
(revision "2"))
--
2.26.0
Nicolas Goaziou wrote 5 years ago
(name . Alberto Eleuterio Flores Guerrero)(address . barbanegra+guix@posteo.mx)(address . 40619-done@debbugs.gnu.org)
87y2qyv35x.fsf@nicolasgoaziou.fr
Hello,

Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-typit): New variable.

Thank you. I applied your patch with the changes below.

Toggle quote (5 lines)
> +(define-public emacs-typit
> + (package
> + (name "emacs-typit")
> + (version "0.2.1")

This release is somewhat old (2017), and newer commits include
additional dictionaries, so I added the latest commit instead, with
a comment.

The line above became:

(version (git-version "0.2.1" revision commit))

Toggle quote (7 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mrkkrp/typit.git")
> + (commit "a4e3147dedac5535bdc8b06aca00f34f14f26e35")))

The line above became

(commit commit)

Toggle quote (2 lines)
> + (license license:gpl3)))

I fixed the license, which is gpl3+.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40619@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40619
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help