Alberto Eleuterio Flores Guerrero wrote 5 years ago
(address . bug-guix@gnu.org)
* gnu/packages/emacs-xyz.scm (emacs-mmt): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd1ce3a298..a974d885e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2122,6 +2122,28 @@ window).")
single buffer.")
(license license:gpl3+)))
+(define-public emacs-mmt
+ (package
+ (name "emacs-mmt")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/mmt.git")
+ (commit "f7db836a10720ee50217012e7e2597ebcf624f90")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13vbfc5597v0gd87qyhn10f93nb477vjpg3jlpphbax9fvkf4gav"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mrkkrp/mmt")
+ (synopsis "Classic tools to write Emacs Lisp macros")
+ (description "@code{emacs-mmt} is a package that
+contains classic tools for Emacs Lisp developers who want
+to write macros with convenience.")
+ (license license:gpl3)))
+
(define-public emacs-tablist
(package
(name "emacs-tablist")
--
2.26.0