[PATCH] gnu: Add emacs-mmt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alberto Eleuterio Flores Guerrero
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Alberto Eleuterio Flores Guerrero
Severity
normal

Debbugs page

Alberto Eleuterio Flores Guerrero wrote 5 years ago
(address . bug-guix@gnu.org)
20200414031651.18108-1-barbanegra+guix@posteo.mx
* gnu/packages/emacs-xyz.scm (emacs-mmt): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd1ce3a298..a974d885e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2122,6 +2122,28 @@ window).")
single buffer.")
(license license:gpl3+)))
+(define-public emacs-mmt
+ (package
+ (name "emacs-mmt")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/mmt.git")
+ (commit "f7db836a10720ee50217012e7e2597ebcf624f90")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13vbfc5597v0gd87qyhn10f93nb477vjpg3jlpphbax9fvkf4gav"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mrkkrp/mmt")
+ (synopsis "Classic tools to write Emacs Lisp macros")
+ (description "@code{emacs-mmt} is a package that
+contains classic tools for Emacs Lisp developers who want
+to write macros with convenience.")
+ (license license:gpl3)))
+
(define-public emacs-tablist
(package
(name "emacs-tablist")
--
2.26.0
Nicolas Goaziou wrote 5 years ago
(name . Alberto Eleuterio Flores Guerrero)(address . barbanegra+guix@posteo.mx)(address . 40618-done@debbugs.gnu.org)
87tv1mv33g.fsf@nicolasgoaziou.fr
Hello,

Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mmt): New variable.

Thank you. I applied it with the changes explained before: use version
tag instead of commit string, fix license.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40618@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40618
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help