Add emacs-4clojure

  • Done
  • quality assurance status badge
Details
3 participants
  • Alberto EFG
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Alberto EFG
Severity
normal

Debbugs page

Alberto EFG wrote 5 years ago
(address . guix-patches@gnu.org)
acda1dd84c0396cb5d6702cedf25a2ac@posteo.net
Add emacs-4clojure
From 510a71b4e17e8588f3e93f8735fe27b45b3e5827 Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Mon, 13 Apr 2020 02:06:27 -0500
Subject: [PATCH] gnu: Add emacs-4clojure.

* gnu/packages/emacs-xyz.scm (emacs-4clojure): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0fdc509038..1223eedb0c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22354,4 +22354,27 @@ and created quickly. Org-roam should also work as a plug-and-play
makes it easy to build ascii UML sequence diagrams in Emacs,
which can be embedded in source code, comments or emails.")
(license license:gpl3)))
+
+(define-public emacs-4clojure
+ (package
+ (name "emacs-4clojure")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsorphanage/4clojure.git")
+ (commit "4eccf8c7d4341a36c269451838114b27836699f9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19x653lzc1dxil4ix257hciidbdmbhaxhs6qhlkwi9ygjrlrgvnk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/emacsorphanage/4clojure")
+ (synopsis "Emacs mode to open and evaluate 4clojure.com questions")
+ (description "@code{emacs-4clojure} allows you to interact with
+@code{4clojure.com} problems, you can open an specific question and move
+to the next or previous. You can also verify you answers.")
+ (license license:gpl3)))
--
2.26.0
Tobias Geerinckx-Rice wrote 5 years ago
(no subject)
87eesqnaxl.fsf@nckx
For the record (and any reviewers), these patches should be
applied in order:

#40591 emacs-org-roam
#40593 emacs-uml-mode
#40616 emacs-4clojure
#40613 emacs-typing

They're not interdependent, just patch-context-dependent.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl6VCeYACgkQ2Imw8BjF
STzvPRAAmz3Ip8iGI7j9TmNef1IJMKkLervFzK8TW0OXbHgnLI4O2Ux6ChUXRsZ5
VkFk4jwsiZTe5q0tJNMynOz1rI3NIifYIY+n/zxUxHeoGGlSlOdSUHxjYGiSn1mC
/Qpr0WHmCdRGAxYghqOlcfdmwQ1wPC/EQydD011sfLhOMpHearifZjWkVJ9lYcj3
l8QOzcuAu+z1bwNgSw0JqJSTsj8u2D6eIs+1YM3xFZ2xRa72omTMDaVZt1ebclm8
oKniR2j1QKUZgBBPIERBwGNiRUZRwUQ22arfaissF7yA8gmLSQN5qobzwriWORqI
tBiSundwKe2AfT31Lk4vMTwm4Jdvne+t6r5ujbt4jEZfRbp0grKlJH9kdAlOE7Wi
tYB+fCrBolpUkmWiUrDiOJ1Q93FnGi8nHY/zS/EYn1Aa71QHQ1E0gvxJiPA+w+LB
f99YXOmzk22erTONQvhVcm/UNKB0hPdND+w2VnL2hXqXPw4pu8WcNynoTWsnbpDF
FMbc+UzOtPZ3FnNztK12Y+we9jsUE+JHBAYldqBTBAwPv26u/qI8tHasmv5sHA4A
Aw2Ip4roMOXFer3tBLQ3tw26u4IjqvmUMu9WzxuzEmanPOuVYB3rbT9OiSfWFS3F
sQWkCDmvRsoFV4rISCed1pp5wyWq0Mf59jxCsIOIkkJz9lCzth8=
=prpp
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 5 years ago
Re: [bug#40616] Add emacs-4clojure
(name . Alberto EFG)(address . albertoefg@posteo.mx)(address . 40616-done@debbugs.gnu.org)
87o8rjkw2y.fsf@nicolasgoaziou.fr
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

Toggle quote (9 lines)
> Add emacs-4clojure
>
> From 510a71b4e17e8588f3e93f8735fe27b45b3e5827 Mon Sep 17 00:00:00 2001
> From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
> Date: Mon, 13 Apr 2020 02:06:27 -0500
> Subject: [PATCH] gnu: Add emacs-4clojure.
>
> * gnu/packages/emacs-xyz.scm (emacs-4clojure): New variable.

Thank you. I pushed this, as 4e74cef97a49d06c53903786bac95f510212f949.

Note that I had to fix indentation. I also added outer let-bindings for
commit and revision since there is no proper release.

Toggle quote (4 lines)
> + (description "@code{emacs-4clojure} allows you to interact with
> +@code{4clojure.com} problems, you can open an specific question and move
> +to the next or previous. You can also verify you answers.")

I wrote instead:

Emacs 4clojure interacts with @url{http://www.4clojure.com, 4clojure}
problems. You can open a specific question and move to the next or
previous one. You can also verify your answers.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40616@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40616
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help