Alberto Eleuterio Flores Guerrero wrote 5 years ago
(address . bug-guix@gnu.org)
* gnu/packages/emacs-xyz.scm (emacs-typing): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d3631535da..6acbee00d3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22499,3 +22499,25 @@ which can be embedded in source code, comments or emails.")
@code{4clojure.com} problems, you can open an specific question and move
the next or previos. You can also check you answers.")
(license license:gpl3)))
+
+(define-public emacs-typing
+ (package
+ (name "emacs-typing")
+ (version "1.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kensanata/typing.git")
+ (commit "a2ef25dde2d8eb91bd9c0c6164cb5208208647fa")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dbh0srbf54lgd60ia79y9cfnq3kxlgw01qzdjs9mk3nfazzpgnv"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/kensanata/typing/")
+ (synopsis "Emacs game where you have to type fast")
+ (description "@code{emacs-typing} is a game for Emacs that
+forces you to type words correctly as fast as possible, otherwise
+you will die. The game builds the list of words from the active buffer")
+ (license license:gpl2)))
--
2.26.0