Added emacs-uml-mode

  • Done
  • quality assurance status badge
Details
3 participants
  • Alberto EFG
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Alberto EFG
Severity
normal

Debbugs page

Alberto EFG wrote 5 years ago
(address . guix-patches@gnu.org)
87wo6j7vxu.fsf@posteo.mx
Added emacs-uml-mode. I used the same branch where I wrote
emacs-org-roam (bug#40591) hope it is ok.

guix size is 0.1 MB

The package is just an emacs file, there should not be much problem.
From 0289b51837ea2edfe610deb2e91ee329601f1234 Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Mon, 13 Apr 2020 01:07:04 -0500
Subject: [PATCH] gnu: Add emacs-uml-mode.

* gnu/packages/emacs-xyz.scm (emacs-uml-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f1c48be2e..0fdc509038 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22332,3 +22332,25 @@ without hierarchy and are connected by tags. Notes can be found
and created quickly. Org-roam should also work as a plug-and-play
solution for anyone already using Org-mode for their personal wiki.")
(license license:gpl3)))
+
+(define-public emacs-uml-mode
+ (package
+ (name "emacs-uml-mode")
+ (version "0.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ianxm/emacs-uml.git")
+ (commit "4c37ac1c4424b2313cd8f16ba48a98a4cc214200")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "145i4srnfvd1vyibri2a1l6p9mbjvkkwlrpi41134pbarqffcnka"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ianxm/emacs-uml")
+ (synopsis "Minor mode for editing ascii UML sequence diagrams")
+ (description "@code{emacs-uml-mode} is a minor mode that
+ makes it easy to build ascii UML sequence diagrams in Emacs,
+which can be embedded in source code, comments or emails.")
+ (license license:gpl3)))
--
2.26.0
Tobias Geerinckx-Rice wrote 5 years ago
(no subject)
87eesqnaxl.fsf@nckx
For the record (and any reviewers), these patches should be
applied in order:

#40591 emacs-org-roam
#40593 emacs-uml-mode
#40616 emacs-4clojure
#40613 emacs-typing

They're not interdependent, just patch-context-dependent.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl6VCeYACgkQ2Imw8BjF
STzvPRAAmz3Ip8iGI7j9TmNef1IJMKkLervFzK8TW0OXbHgnLI4O2Ux6ChUXRsZ5
VkFk4jwsiZTe5q0tJNMynOz1rI3NIifYIY+n/zxUxHeoGGlSlOdSUHxjYGiSn1mC
/Qpr0WHmCdRGAxYghqOlcfdmwQ1wPC/EQydD011sfLhOMpHearifZjWkVJ9lYcj3
l8QOzcuAu+z1bwNgSw0JqJSTsj8u2D6eIs+1YM3xFZ2xRa72omTMDaVZt1ebclm8
oKniR2j1QKUZgBBPIERBwGNiRUZRwUQ22arfaissF7yA8gmLSQN5qobzwriWORqI
tBiSundwKe2AfT31Lk4vMTwm4Jdvne+t6r5ujbt4jEZfRbp0grKlJH9kdAlOE7Wi
tYB+fCrBolpUkmWiUrDiOJ1Q93FnGi8nHY/zS/EYn1Aa71QHQ1E0gvxJiPA+w+LB
f99YXOmzk22erTONQvhVcm/UNKB0hPdND+w2VnL2hXqXPw4pu8WcNynoTWsnbpDF
FMbc+UzOtPZ3FnNztK12Y+we9jsUE+JHBAYldqBTBAwPv26u/qI8tHasmv5sHA4A
Aw2Ip4roMOXFer3tBLQ3tw26u4IjqvmUMu9WzxuzEmanPOuVYB3rbT9OiSfWFS3F
sQWkCDmvRsoFV4rISCed1pp5wyWq0Mf59jxCsIOIkkJz9lCzth8=
=prpp
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 5 years ago
Re: [bug#40593] Added emacs-uml-mode
(name . Alberto EFG)(address . albertoefg@posteo.mx)(address . 40593-done@debbugs.gnu.org)
873696whvi.fsf@nicolasgoaziou.fr
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

Toggle quote (3 lines)
> Added emacs-uml-mode. I used the same branch where I wrote
> emacs-org-roam (bug#40591) hope it is ok.

Thank you.

Note that adding all new packages at the end of the file is likely to
create merge conflicts. If they are tied, send them in the same bug
report.

Toggle quote (5 lines)
> +(define-public emacs-uml-mode
> + (package
> + (name "emacs-uml-mode")
> + (version "0.0.4")

This is not an official release. So I added a commit, a revision, and
a comment. Therefore, the line became:

(version (git-version "0.0.4" revision commit))

Toggle quote (7 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ianxm/emacs-uml.git")
> + (commit "4c37ac1c4424b2313cd8f16ba48a98a4cc214200")))

As a consequence of the "no revision" situation, the line above became:

(commit commit)

Toggle quote (12 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "145i4srnfvd1vyibri2a1l6p9mbjvkkwlrpi41134pbarqffcnka"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/ianxm/emacs-uml")
> + (synopsis "Minor mode for editing ascii UML sequence diagrams")
> + (description "@code{emacs-uml-mode} is a minor mode that
> + makes it easy to build ascii UML sequence diagrams in Emacs,
> +which can be embedded in source code, comments or emails.")
> + (license license:gpl3)))

Please also see my comments about "emacs-org-roam" (indentation, commit,
license).

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40593@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40593
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help