Add emacs-org-roam

  • Done
  • quality assurance status badge
Details
3 participants
  • Alberto EFG
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Alberto EFG
Severity
normal

Debbugs page

Alberto EFG wrote 5 years ago
(address . guix-patches@gnu.org)
87h7xovxys.fsf@posteo.mx
Hello.

Added emacs-org-roam. I used it all day, seems like everything works.
guix size is around 0.2 MB
From a112e0b9f57125ecc1ae0418734521722d87e27e Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Sun, 12 Apr 2020 14:01:24 -0500
Subject: [PATCH] gnu: Add emacs-org-roam.

* gnu/packages/emacs-xyz.scm (emacs-org-roam): New variable.
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f55d1a5bf4..0f1c48be2e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22300,3 +22301,34 @@ conventions.")
(description "Haskell-Snippets is a collection of YASnippet Haskell
snippets for Emacs.")
(license license:expat))))
+
+(define-public emacs-org-roam
+ (package
+ (name "emacs-org-roam")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jethrokuan/org-roam.git")
+ (commit "1433dbc31602c412914c71ecc81aa5dcf6b03daf")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08pfa63k194dpk0y2gfa0nzn5lig81q0l9axkq5j4ibj6ifaap4a"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-emacsql-sqlite" ,emacs-emacsql)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("emacs-org-ref" ,emacs-org-ref)))
+ (home-page "https://github.com/jethrokuan/org-roam")
+ (synopsis "Org-mode non-hierarchical notes")
+ (description "@code{emacs-org-roam} is a solution for taking
+non-hierarchical notes with @code{org-mode}. Notes are captured
+without hierarchy and are connected by tags. Notes can be found
+and created quickly. Org-roam should also work as a plug-and-play
+ solution for anyone already using Org-mode for their personal wiki.")
+ (license license:gpl3)))
--
2.26.0
Tobias Geerinckx-Rice wrote 5 years ago
(no subject)
87eesqnaxl.fsf@nckx
For the record (and any reviewers), these patches should be
applied in order:

#40591 emacs-org-roam
#40593 emacs-uml-mode
#40616 emacs-4clojure
#40613 emacs-typing

They're not interdependent, just patch-context-dependent.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl6VCeYACgkQ2Imw8BjF
STzvPRAAmz3Ip8iGI7j9TmNef1IJMKkLervFzK8TW0OXbHgnLI4O2Ux6ChUXRsZ5
VkFk4jwsiZTe5q0tJNMynOz1rI3NIifYIY+n/zxUxHeoGGlSlOdSUHxjYGiSn1mC
/Qpr0WHmCdRGAxYghqOlcfdmwQ1wPC/EQydD011sfLhOMpHearifZjWkVJ9lYcj3
l8QOzcuAu+z1bwNgSw0JqJSTsj8u2D6eIs+1YM3xFZ2xRa72omTMDaVZt1ebclm8
oKniR2j1QKUZgBBPIERBwGNiRUZRwUQ22arfaissF7yA8gmLSQN5qobzwriWORqI
tBiSundwKe2AfT31Lk4vMTwm4Jdvne+t6r5ujbt4jEZfRbp0grKlJH9kdAlOE7Wi
tYB+fCrBolpUkmWiUrDiOJ1Q93FnGi8nHY/zS/EYn1Aa71QHQ1E0gvxJiPA+w+LB
f99YXOmzk22erTONQvhVcm/UNKB0hPdND+w2VnL2hXqXPw4pu8WcNynoTWsnbpDF
FMbc+UzOtPZ3FnNztK12Y+we9jsUE+JHBAYldqBTBAwPv26u/qI8tHasmv5sHA4A
Aw2Ip4roMOXFer3tBLQ3tw26u4IjqvmUMu9WzxuzEmanPOuVYB3rbT9OiSfWFS3F
sQWkCDmvRsoFV4rISCed1pp5wyWq0Mf59jxCsIOIkkJz9lCzth8=
=prpp
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 5 years ago
Re: [bug#40591] Add emacs-org-roam
(name . Alberto EFG)(address . albertoefg@posteo.mx)(address . 40591-done@debbugs.gnu.org)
878siywi1n.fsf@nicolasgoaziou.fr
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

Toggle quote (2 lines)
> Added emacs-org-roam. I used it all day, seems like everything works.

Thank you.

I applied your patch with the following changes.
Toggle quote (4 lines)
> +(define-public emacs-org-roam
> + (package
> + (name "emacs-org-roam")

The indentation is off. If you use Emacs, you can press M-q, otherwise,
you may call the etc/indent.el script in Guix source tree.

Toggle quote (8 lines)
> + (version "1.0.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/jethrokuan/org-roam.git")
> + (commit "1433dbc31602c412914c71ecc81aa5dcf6b03daf")))

When there is an official release, we use the tag. Therefore, I changed
the line above to:

(commit (string-append "v" version))

Toggle quote (5 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "08pfa63k194dpk0y2gfa0nzn5lig81q0l9axkq5j4ibj6ifaap4a"))))

Nitpick: I put the string on the line above.

Toggle quote (9 lines)
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-company" ,emacs-company)
> + ("emacs-emacsql-sqlite" ,emacs-emacsql)
> + ("emacs-dash" ,emacs-dash)
> + ("emacs-f" ,emacs-f)
> + ("emacs-s" ,emacs-s)
> + ("emacs-org-ref" ,emacs-org-ref)))

I re-ordered the inputs alphabetically.

Toggle quote (2 lines)
> + (license license:gpl3)))

The license is actually gpl3+, as written in the source code.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40591@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40591
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help