Alberto EFG wrote 5 years ago
(address . guix-patches@gnu.org)
Hello.
Added emacs-org-roam. I used it all day, seems like everything works.
guix size is around 0.2 MB
From a112e0b9f57125ecc1ae0418734521722d87e27e Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Sun, 12 Apr 2020 14:01:24 -0500
Subject: [PATCH] gnu: Add emacs-org-roam.
* gnu/packages/emacs-xyz.scm (emacs-org-roam): New variable.
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f55d1a5bf4..0f1c48be2e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22300,3 +22301,34 @@ conventions.")
(description "Haskell-Snippets is a collection of YASnippet Haskell
snippets for Emacs.")
(license license:expat))))
+
+(define-public emacs-org-roam
+ (package
+ (name "emacs-org-roam")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jethrokuan/org-roam.git")
+ (commit "1433dbc31602c412914c71ecc81aa5dcf6b03daf")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08pfa63k194dpk0y2gfa0nzn5lig81q0l9axkq5j4ibj6ifaap4a"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-emacsql-sqlite" ,emacs-emacsql)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("emacs-org-ref" ,emacs-org-ref)))
+ (home-page "https://github.com/jethrokuan/org-roam")
+ (synopsis "Org-mode non-hierarchical notes")
+ (description "@code{emacs-org-roam} is a solution for taking
+non-hierarchical notes with @code{org-mode}. Notes are captured
+without hierarchy and are connected by tags. Notes can be found
+and created quickly. Org-roam should also work as a plug-and-play
+ solution for anyone already using Org-mode for their personal wiki.")
+ (license license:gpl3)))
--
2.26.0