[PATCH] gnu: fish: Upgrade to 3.1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
871rosjndp.fsf@asu.edu
Hi Guix,

Fish shell had a large minor release a couple months ago. Here are the
patches to use the updated version.

It features a cmake build system, an extensive test suite and a lot of
new features and bug fixes.

I also include what I think might be a patch to export some variables
that should be exposed all the time but I am not sure. That patch might
not be desirable to have on master yet, as it is mostly my research into
issue #30265.

Thanks!

John
From 2277db5acc05cea916f96c9c7d6d417bd92eff5f Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 12 Apr 2020 15:53:35 -0700
Subject: [PATCH 1/2] gnu: fish: export extra directories.

* gnu/packages/shells.scm (fish): [arguments] export extra directories when
patching __fish_build_paths.fish.
---
gnu/packages/shells.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8708b703ef..6b03b6bc0f 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -161,15 +161,15 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
" variables.\n"
"set -l __guix_profile_paths ~/.guix-profile"
" /run/current-system/profile\n"
- "set __extra_completionsdir"
+ "set -xg __extra_completionsdir"
" $__guix_profile_paths\"/etc/fish/completions\""
" $__guix_profile_paths\"/share/fish/vendor_completions.d\""
" $__extra_completionsdir\n"
- "set __extra_functionsdir"
+ "set -xg __extra_functionsdir"
" $__guix_profile_paths\"/etc/fish/functions\""
" $__guix_profile_paths\"/share/fish/vendor_functions.d\""
" $__extra_functionsdir\n"
- "set __extra_confdir"
+ "set -xg __extra_confdir"
" $__guix_profile_paths\"/etc/fish/conf.d\""
" $__guix_profile_paths\"/share/fish/vendor_conf.d\""
" $__extra_confdir\n")
--
2.26.0
Ludovic Courtès wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40588-done@debbugs.gnu.org)
87r1vucxp1.fsf@gnu.org
Hi John,

Looks like this had fallen through the cracks…

John Soo <jsoo1@asu.edu> skribis:

Toggle quote (9 lines)
>>From f3e813e2374b0bf38391488442a1bded1c4016b2 Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Sun, 12 Apr 2020 14:18:30 -0700
> Subject: [PATCH 2/2] gnu: fish: Upgrade to 3.1.0.
>
> * gnu/packages/shells (fish):[version] Update to 3.1.0. [arguments] Enable
> tests, patch test files, and avoid patches that no longer apply. [inputs]
> Make groff a native-input.

Applied!

For the other patch, can you please let us know separately when you
think it’s ready for inclusion?

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40588@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40588
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help