[wip-hurd-vm] uptime from coreutils looks for /bin/w

  • Open
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Jan Nieuwenhuizen
  • Ludovic Courtès
  • Rene
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 12 Apr 2020 20:30
(address . bug-guix@gnu.org)
20200412183058.GD31526@E5400
I fired up the hurd VM and ran 'uptime' and it complained that it
couldn't find /bin/w. 'w' was in the path.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6TXl4ACgkQQarn3Mo9
g1E+uA/7BhLl6y9e0/ZxsaQW0kjOwVMyGds1eVBfK1iWQQKYPmdvs1N3qQypHQnk
mKts0MggQZCgjFDrY+jHLzHT9gYVYvSgGYbkMXj1X9/EGZ1yGWCt6rEHZCpTuTMy
7NEk/weTo15ZyqfvhYzKZwZSArCjJx2N6LS/w8fibV28zyXq9neFHnFxvXePeSbm
Am7l6qiOlxpaWoLR4UdZ71WL4msJs9yeMlJkaFk4WsUoX+LXibh0EMHdAStchsVE
bFTrhETrg4WcdCOzsQwYRejtY32K27pk9Osx+k3P4nvuVPRyBAuGUmV7wrzartiU
gCin9EjH2SsySirOMWWop3V0Rh7dcu/NykLQIwmV8njg8B1yQCEsedXdB4kMfQ2u
OkYPx+wRkTheRHfsheb3da6J2oqy/lLVrlzaC/iubf9PzGvISNDs5uZ5Itz9ORij
4PKWXM4Q5vr8SMIB22dgCFvL0SxwFZzNxy4jUXatsmLtqwuaIzsK7jhPI1jbpsiz
8JuEcWdnRmy/nHOzUeriwPh776adgXLlPyj4g7y/Juk6VaUzYRStMptp2xbgC/dT
DAvd5q2RMEOzxlIg/R/bNNiG/pjIkqcAZibhnmsWNa0fFoEL1kxkDekL5IeQK09v
oESEI0SH6qgAW6JwQ+bIWzXeLCDgEXSJD8prGyDUzJ9P5vJFmmA=
=7Iie
-----END PGP SIGNATURE-----


R
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)(name . janneke@gnu.org)(address . janneke@gnu.org)
YG2k-XaHEc1owIwmZTVa_sp5hkzFw3pr6QLPXu8gdxNwv10ObNIP_03IHoNhphLbnkXZ65mPkxncRlkn7_DO4xM5EaSCnuEO0BLAqsy7uUE=@protonmail.com
Hello,


Debian project currently uses `/bin/w` from the hurd package, so I propose the attached patch.


Rene
From 456f05894e08961b1f20fe2ff8a6731abe9d96f0 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <pacoon@protonmail.com>
Date: Sun, 12 Apr 2020 22:33:08 -0500
Subject: [PATCH] gnu: hurd: Fix references to /bin/w.

* gnu/packages/hurd.scm (hurd): Use '/bin/w' from hurd package.
---
gnu/packages/hurd.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 88af75c48e..fcbbaad10c 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Rene Saavedra <pacoon@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -398,6 +399,9 @@ boot, since this cannot be done from GNU/Linux."
(substitute* '("startup/startup.c" "init/init.c" "config/ttys")
(("/libexec/")
(string-append out "/libexec/")))
+ (substitute* '("utils/uptime.sh")
+ (("/bin/w")
+ (string-append out "/bin/w")))
(substitute* "daemons/console-run.c"
(("/hurd/")
(string-append out "/hurd/")))
--
2.21.0
J
J
Jan Nieuwenhuizen wrote on 13 Apr 2020 09:11
(name . Rene)(address . pacoon@protonmail.com)(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
87tv1nc11n.fsf@gnu.org
Rene writes:

Hello Rene, Efraim,

Toggle quote (3 lines)
> Debian project currently uses `/bin/w` from the hurd package, so I
> propose the attached patch.

LGTM!

Toggle quote (11 lines)
> @@ -398,6 +399,9 @@ boot, since this cannot be done from GNU/Linux."
> (substitute* '("startup/startup.c" "init/init.c" "config/ttys")
> (("/libexec/")
> (string-append out "/libexec/")))
> + (substitute* '("utils/uptime.sh")
> + (("/bin/w")
> + (string-append out "/bin/w")))
> (substitute* "daemons/console-run.c"
> (("/hurd/")
> (string-append out "/hurd/")))

Looking at this again it looks fine; following the pattern we created.
This now makes me wonder whether upstream Hurd could use a patch for
${bindir} and ${libexecdir}. Possibly even for `/hurd'.

What do you all think?

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
L
L
Ludovic Courtès wrote on 13 Apr 2020 12:44
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)
877dyjmzqk.fsf@gnu.org
Hey ho!

Jan Nieuwenhuizen <janneke@gnu.org> skribis:

Toggle quote (22 lines)
> Rene writes:
>
> Hello Rene, Efraim,
>
>> Debian project currently uses `/bin/w` from the hurd package, so I
>> propose the attached patch.
>
> LGTM!
>
>> @@ -398,6 +399,9 @@ boot, since this cannot be done from GNU/Linux."
>> (substitute* '("startup/startup.c" "init/init.c" "config/ttys")
>> (("/libexec/")
>> (string-append out "/libexec/")))
>> + (substitute* '("utils/uptime.sh")
>> + (("/bin/w")
>> + (string-append out "/bin/w")))
>> (substitute* "daemons/console-run.c"
>> (("/hurd/")
>> (string-append out "/hurd/")))
>
> Looking at this again it looks fine; following the pattern we created.

Yup, LGTM!

Toggle quote (5 lines)
> This now makes me wonder whether upstream Hurd could use a patch for
> ${bindir} and ${libexecdir}. Possibly even for `/hurd'.
>
> What do you all think?

Yes, I think this prefix issue should be fixed upstream.

Ludo’.
?