[core-updates]: Updating `guix' makes package-transitive-supported-systems test fail

  • Done
  • quality assurance status badge
Details
2 participants
  • Jan Nieuwenhuizen
  • Marius Bakke
Owner
unassigned
Submitted by
Jan Nieuwenhuizen
Severity
normal
Merged with
J
J
Jan Nieuwenhuizen wrote on 10 Apr 2020 14:05
(address . bug-guix@gnu.org)
87imi7eeaz.fsf@gnu.org
Hi,

On current core-updates

d523eb5c9c gnu: python-cython: The i686 python2 workaround is needed for 32-bit ARM too.

updating the guix package like so

make update-guix-package

leads to a test failure of package-transitive-supported-systems

make check TESTS=tests/packages

=>

test-name: package-transitive-supported-systems, implicit inputs
location: /home/janneke/src/guix/core-updates/tests/packages.scm:397
source:
+ (test-equal
+ "package-transitive-supported-systems, implicit inputs"
+ %supported-systems
+ (let ((p (dummy-package
+ "foo"
+ (build-system gnu-build-system)
+ (supported-systems
+ `("does-not-exist" "foobar" ,@%supported-systems)))))
+ (parameterize
+ ((%current-system "armhf-linux"))
+ (package-transitive-supported-systems p))))
expected-value: ("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "mips64el-linux" "i586-gnu")
actual-value: ("x86_64-linux" "i686-linux")
result: FAIL

Last week, when core-updates was at

1808e64de0 gnu: coreutils: Typo: Use libcap only when supported.

it worked correctly.

This is unfortunate, as wip-hurd-vm (freshly rebased) depends on a guix
update.

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
M
M
Marius Bakke wrote on 10 Apr 2020 14:17
87blnzk00u.fsf@devup.no
merge 40535 40482
thanks

Jan Nieuwenhuizen <janneke@gnu.org> writes:

Toggle quote (40 lines)
> Hi,
>
> On current core-updates
>
> d523eb5c9c gnu: python-cython: The i686 python2 workaround is needed for 32-bit ARM too.
>
> updating the guix package like so
>
> make update-guix-package
>
> leads to a test failure of package-transitive-supported-systems
>
> make check TESTS=tests/packages
>
> =>
>
> test-name: package-transitive-supported-systems, implicit inputs
> location: /home/janneke/src/guix/core-updates/tests/packages.scm:397
> source:
> + (test-equal
> + "package-transitive-supported-systems, implicit inputs"
> + %supported-systems
> + (let ((p (dummy-package
> + "foo"
> + (build-system gnu-build-system)
> + (supported-systems
> + `("does-not-exist" "foobar" ,@%supported-systems)))))
> + (parameterize
> + ((%current-system "armhf-linux"))
> + (package-transitive-supported-systems p))))
> expected-value: ("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "mips64el-linux" "i586-gnu")
> actual-value: ("x86_64-linux" "i686-linux")
> result: FAIL
>
> Last week, when core-updates was at
>
> 1808e64de0 gnu: coreutils: Typo: Use libcap only when supported.
>
> it worked correctly.

This is a known problem: https://bugs.gnu.org/40482. I've merged the
reports. We decided on #guix to ignore it for now, you can try one of
the workarounds described in #40482 in the mean time.

Sorry for the inconvenience!
M
M
Marius Bakke wrote on 10 Apr 2020 14:35
(address . control@debbugs.gnu.org)
878sj3jz7k.fsf@devup.no
merge 40535 40482
thanks
?