[PATCH] services/web: Fix ordering of default-nginx-config.

  • Done
  • quality assurance status badge
Details
One participant
  • Florian Pelz
Owner
unassigned
Submitted by
Florian Pelz
Severity
normal

Debbugs page

Florian Pelz wrote 5 years ago
(address . guix-patches@gnu.org)(name . Florian Pelz)(address . pelzflorian@pelzflorian.de)
20200408212346.11665-1-pelzflorian@pelzflorian.de
Fixes an error message '"load_module" directive is specified too late'.

* gnu/services/web.scm (default-nginx-config): Emit load_module before
global directives.
---
gnu/services/web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index 9ae84ddbc4..dcbe6ee16f 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2017, 2018, 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019, 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -652,8 +652,8 @@ of index files."
"user nginx nginx;\n"
"pid " run-directory "/pid;\n"
"error_log " log-directory "/error.log info;\n"
- (map emit-global-directive global-directives)
(map emit-load-module modules)
+ (map emit-global-directive global-directives)
"http {\n"
" client_body_temp_path " run-directory "/client_body_temp;\n"
" proxy_temp_path " run-directory "/proxy_temp;\n"
--
2.26.0
pelzflorian (Florian Pelz) wrote 5 years ago
(address . 40515-done@debbugs.gnu.org)
20200408231646.lbdfugnkinpkujo4@pelzflorian.localdomain
On Wed, Apr 08, 2020 at 11:23:45PM +0200, Florian Pelz wrote:
Toggle quote (2 lines)
> Fixes an error message '"load_module" directive is specified too late'.

Actually I tested and am confident enough, so I pushed as
543516ed0040df28eb15ea9b15ce905c038671c5.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40515@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40515
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help