[PATCH] gnu: Add emacs-diredfl.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
877dyqu4gg.fsf@asu.edu
Hi Guix,

diredfl provides more font locking in dired buffers. It is a more
minimal version of dired-hacks.

I linted this and the formatting should be up to snuff this
time. Thanks a lot!

- John
From 05d17a17986e2ec8c662b923e7ac5e556103e683 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 7 Apr 2020 01:06:18 -0700
Subject: [PATCH] gnu: Add emacs-diredfl.

* gnu/packages/emacs-xyz.scm (emacs-diredfl): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab7f9b8a18..6c4536df79 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9224,6 +9224,28 @@ information inside the dired buffer.")
@code{sudo} privileges.")
(license license:wtfpl2)))
+(define-public emacs-diredfl
+ (package
+ (name "emacs-diredfl")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/purcell/diredfl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zb2lz7rp58zqvpniqcsmqabi7nqg2d8bfd0hgmq68bn2hd25b5z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/diredfl")
+ (synopsis "Extra Emacs font lock rules for a more colourful dired")
+ (description "This is adapted from the extra font lock rules provided by
+Drew Adams' dired+ package, but published via a modern means, and with support
+for older Emacsen removed.")
+ (license license:gpl3+)))
+
(define-public emacs-memoize
(package
(name "emacs-memoize")
--
2.26.0
Nicolas Goaziou wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40501-done@debbugs.gnu.org)
87blnz487t.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-diredfl.
>
> * gnu/packages/emacs-xyz.scm (emacs-diredfl): New variable.

Applied as d09337cbf48b26d28909e784a66a13987266feb1. Thank you.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40501@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40501
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help