Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
This commit adjusts the upgrade-services system test to not build anything
when computing the derivation for the system test. I came across this when
looking at issues computing the system test derivations to store in the Guix
Data Service.
* gnu/tests/reconfigure.scm (run-upgrade-services-test): Remove the use of,
and definition for ensure-service-file.
---
gnu/tests/reconfigure.scm | 16 +++++-----------
1 file changed, 5 insertions(+), 11 deletions(-)
Toggle diff (37 lines)
diff --git a/gnu/tests/reconfigure.scm b/gnu/tests/reconfigure.scm
index 8b85920979..928a210a94 100644
--- a/gnu/tests/reconfigure.scm
+++ b/gnu/tests/reconfigure.scm
@@ -136,14 +136,6 @@ Shepherd (PID 1) by unloading obsolete services and loading new services."
(stop #~(const #t))
(respawn? #f)))
- ;; Return the Shepherd service file for SERVICE, after ensuring that it
- ;; exists in the store.
- (define (ensure-service-file service)
- (let ((file (shepherd-service-file service)))
- (mlet* %store-monad ((store-object (lower-object file))
- (_ (built-derivations (list store-object))))
- (return file))))
-
(define (test enable-dummy disable-dummy)
(with-imported-modules '((gnu build marionette))
#~(begin
@@ -187,10 +179,12 @@ Shepherd (PID 1) by unloading obsolete services and loading new services."
(test-end)
(exit (= (test-runner-fail-count (test-runner-current)) 0)))))
- (mlet* %store-monad ((file (ensure-service-file dummy-service)))
- (let ((enable (upgrade-services-program (list file) '(dummy) '() '()))
+ (gexp->derivation
+ "upgrade-services"
+ (let* ((file (shepherd-service-file dummy-service))
+ (enable (upgrade-services-program (list file) '(dummy) '() '()))
(disable (upgrade-services-program '() '() '(dummy) '())))
- (gexp->derivation "upgrade-services" (test enable disable)))))
+ (test enable disable))))
(define* (run-install-bootloader-test)
"Run a test of an OS running INSTALL-BOOTLOADER-PROGRAM, which installs a
--
2.26.0