Sergey Trofimov wrote 5 years ago
* gnu/packages/android (fdroidcl): New variable.
---
gnu/packages/android.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (70 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 17f5f41fcb..4d1a591686 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system android-ndk)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module ((guix licenses) #:prefix license:)
@@ -41,6 +43,7 @@
#:use-module (gnu packages docker)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
@@ -946,6 +949,39 @@ publishing, or to assist in creating, testing and submitting metadata to the
main repository.")
(license license:agpl3+)))
+(define-public fdroidcl
+ (package
+ (name "fdroidcl")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mvdan/fdroidcl/archive/"
+ "v" version ".tar.gz"))
+ (sha256
+ (base32 "0ybqxklhrp23xm89l4g6ms5qxm08db00kx4g6w9vyv11jd68qajk"))))
+ (build-system go-build-system)
+
+ (inputs
+ `(("go-github-com-kr-pretty"
+ ,go-github-com-kr-pretty)
+ ;; used in tests
+ ;; ("go-github-com-rogpeppe-go-internal-testscript"
+ ;; ,go-github-com-rogpeppe-go-internal-testscript)
+ ("go-gopkg.in-check.v1"
+ ,go-gopkg.in-check.v1)))
+ (arguments
+ `(#:import-path "mvdan.cc/fdroidcl"
+ #:tests? #f ; TODO.
+ #:install-source? #f))
+ (synopsis "F-Droid desktop client")
+ (description
+ "While the Android client integrates with the system with regular update
+checks and notifications, this is a simple command line client that talks to
+connected devicesvia ADB.")
+ (home-page "https://github.com/mvdan/fdroidcl")
+ (license license:bsd-3)))
+
(define-public enjarify
(package
(name "enjarify")
--
2.25.1