[PATCH] gnu: fossil: Update to 2.10.

  • Done
  • quality assurance status badge
Details
2 participants
  • John D. Boy
  • Leo Famulari
Owner
unassigned
Submitted by
John D. Boy
Severity
normal

Debbugs page

John D. Boy wrote 5 years ago
(address . guix-patches@gnu.org)(name . John D . Boy)(address . jboy@bius.moe)
20200406141456.29600-1-jboy@bius.moe
* gnu/packages/version-control.scm (fossil): Update to 2.10.
---
gnu/packages/version-control.scm | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8af54c6e35..8dc59d0439 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2105,21 +2105,16 @@ by rclone usable with git-annex.")
(define-public fossil
(package
(name "fossil")
- (version "2.8")
+ (version "2.10")
(source
(origin
(method url-fetch)
- ;; Older downloads are moved to another URL.
- (uri (list
- (string-append
- "https://www.fossil-scm.org/index.html/uv/download/"
- "fossil-src-" version ".tar.gz")
- (string-append
+ (uri (string-append
"https://www.fossil-scm.org/index.html/uv/"
- "fossil-src-" version ".tar.gz")))
+ "fossil-src-" version ".tar.gz"))
(sha256
(base32
- "0pbinf8d2kj1j7niblhzjd2l2khg6r2pn2xvig6gavz27p3vwcka"))
+ "041bs4fgk52fw58p7s084pxk9d9vs5v2f2pjbznqawz75inpg8yq"))
(modules '((guix build utils)))
(snippet
'(begin
--
2.20.1
Leo Famulari wrote 5 years ago
(name . John D. Boy)(address . jboy@bius.moe)(address . 40473@debbugs.gnu.org)
20200406161301.GA16386@jasmine.lan
On Mon, Apr 06, 2020 at 04:14:56PM +0200, John D. Boy wrote:
Toggle quote (2 lines)
> * gnu/packages/version-control.scm (fossil): Update to 2.10.

Thanks! I'm testing the build now.

Toggle quote (11 lines)
> - ;; Older downloads are moved to another URL.
> - (uri (list
> - (string-append
> - "https://www.fossil-scm.org/index.html/uv/download/"
> - "fossil-src-" version ".tar.gz")
> - (string-append
> + (uri (string-append
> "https://www.fossil-scm.org/index.html/uv/"
> - "fossil-src-" version ".tar.gz")))
> + "fossil-src-" version ".tar.gz"))

Did they stop using this scheme of serving old tarballs to another
directory?
John D. Boy wrote 5 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 40473@debbugs.gnu.org)
f796d181-c1c7-47f3-94c4-f0cd652b73ed@www.fastmail.com
Toggle quote (2 lines)
> Thanks! I'm testing the build now.

Great, thanks!

Toggle quote (14 lines)
> > - ;; Older downloads are moved to another URL.
> > - (uri (list
> > - (string-append
> > - "https://www.fossil-scm.org/index.html/uv/download/"
> > - "fossil-src-" version ".tar.gz")
> > - (string-append
> > + (uri (string-append
> > "https://www.fossil-scm.org/index.html/uv/"
> > - "fossil-src-" version ".tar.gz")))
> > + "fossil-src-" version ".tar.gz"))
>
> Did they stop using this scheme of serving old tarballs to another
> directory?

Yes, as far as I could tell they are now all in the same hierarchy under /uv.
Leo Famulari wrote 5 years ago
(name . John D. Boy)(address . jboy@bius.moe)(address . 40473-done@debbugs.gnu.org)
20200406163541.GA31626@jasmine.lan
On Mon, Apr 06, 2020 at 04:18:07PM +0000, John D. Boy wrote:
Toggle quote (5 lines)
> > Did they stop using this scheme of serving old tarballs to another
> > directory?
>
> Yes, as far as I could tell they are now all in the same hierarchy under /uv.

Okay, pushed as 8a4608b4bf4f13766b4e3d11577c61f398034544
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40473@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40473
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help