[PATCH 1/3] gnu: Add libuv-static.

  • Open
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 4 Apr 2020 23:08
(name . Guix patches)(address . guix-patches@gnu.org)
c509e6f1020750b3fe632ebe7a0e45f96b240a3b.camel@zrythm.org
Hi,

This patch adds a static version of libuv (build with -fPIC) needed by
zynfusion.

Feel free to edit it as appropriate, I am not sure if this method of
doing it is acceptable.

Thanks,
Alex
From d6c584eeb80e3b4170d917d67a970cf640f7112c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 4 Apr 2020 21:50:22 +0100
Subject: [PATCH 1/3] gnu: Add libuv-static.

* gnu/packages/libevent.scm (libuv-static): New variable.
---
gnu/packages/libevent.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 3754a5c427..a0534a97d5 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -178,6 +178,14 @@ and Prima). It also comes with a very fast Pure Perl event loop that does
not rely on XS.")
(license perl-license)))
+(define-public libuv-static
+ (package/inherit libuv
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list "CFLAGS=-fPIC")))
+ ;; This version is needed by zynfusion
+ (version "1.9.1")))
+
(define-public perl-ev
(package
(name "perl-ev")
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6I92YACgkQAi6uQjE9
cPP+vwf+NnVNCRaTgxModll+gBsCLhQTo2S7Ii0DCimq2lgOd+b3FXO9v+JNqRIl
ON93ewhZPDcHE9LBmI/ieVgC6vaXb42mxqkuoZoAnFizxAJXGbyk2S/zlO1zgeO3
/fPoEGnp8ai/XL4fykOHjYoSzmXSQqykTNeggN85NcSxNBHt+qIiwT2bsqBloYiv
XguiuJXZOvXGhgjeENDL03hYBeA0RJYaG5wSA8/f+z9WMmeG5eDcqZ332Ndr2+t7
mBeToqljI08U8P017QQDkpVmzGu7PB0a8QefcGZ7G/ttBo95prFQO21I/B41Bqsh
JuwE1ItiDyQ0i96QkltKTW1IxtHFWA==
=5lHT
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 28 Sep 2022 22:33
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40439@debbugs.gnu.org)
878rm3s0gm.fsf@gmail.com
Hi,

Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (8 lines)
> Hi,
>
> This patch adds a static version of libuv (build with -fPIC) needed by
> zynfusion.
>
> Feel free to edit it as appropriate, I am not sure if this method of
> doing it is acceptable.

It's possible to link static archives from shared objects built with
-fPIC; so I'd suggest doing:

Toggle snippet (34 lines)
gnu: Add libuv-next.

* gnu/packages/libevent.scm (libuv-next): New variable.

1 file changed, 17 insertions(+)
gnu/packages/libevent.scm | 17 +++++++++++++++++

modified gnu/packages/libevent.scm
@@ -133,6 +133,23 @@ (define-public libuv
;; details. Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
(license (list expat cc-by4.0))))
+(define-public libuv-next
+ (package
+ (inherit libuv)
+ (name "libuv")
+ (version "1.44.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.libuv.org/dist/v" version
+ "/libuv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d1wy1061cf2mfygr2j6jbm0da2mhsf0l9yq4rjkqrsmijbdrz6c"))))
+ (arguments
+ '(#:configure-flags '("--disable-static" "CFLAGS=-fPIC")
+ ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
+ #:tests? #f))))
+
(define-public libuv-for-node
;; When upgrading Node, also upgrade this. Get the version from
;; https://github.com/nodejs/node/blob/master/deps/uv/include/uv/version.h

and using that, if it's really necessary.

Thanks,

Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 40439@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40439
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch