Christopher Lemmer Webber wrote 5 years ago
(address . guix-patches@gnu.org)
From e566b6434b8696be3d12cd37f3362752c30433e8 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Fri, 3 Apr 2020 15:28:46 -0400
Subject: [PATCH] gnu: Add python-titlecase.
* gnu/packages/python-xyz.scm (python-titlecase): New variable.
---
gnu/packages/python-xyz.scm | 27 ++++++++++++++++++++++++++-
1 file changed, 26 insertions(+), 1 deletion(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5bf2f5a3d..cf4ef40895 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
@@ -18726,3 +18726,28 @@ HTML-containing files.")
usable as a configuration language. This Python package implements parsing and
dumping of JSON5 data structures.")
(license license:asl2.0)))
+
+(define-public python-titlecase
+ (package
+ (name "python-titlecase")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "titlecase" version))
+ (sha256
+ (base32
+ "0486i99wf8ssa7sgn81fn6fv6i4rhhq6n751bc740b3hzfbpmpl4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page
+ "https://github.com/ppannuto/python-titlecase")
+ (synopsis
+ "Python library to capitalize strings similar to book titles")
+ (description
+ "Python-Titlecase is a Python Port of John Gruber's titlecase.pl.
+It capitalizes (predominantly English) strings in a way that is similar to
+book titles, using the New York Times Manual of Style to leave certain words
+lowercase.")
+ (license license:expat)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAl6Hj1EACgkQS8Alkl/4
9NO0eBAAvA+9fMDNeNTIkU7EM3hAGxj4EXtvPt6XNiH43IIrO4JAq1cSupaFpcfQ
QPiFgqPFNuFidX1RGBfg4xo6lBG0lzGK3BDCirExnDRv0whR7hNfzt7qns6qR8Qa
VFIbXZehBL/4RsDi+wawhdrhbxXviANzoL4MWhiRvm7p8ZnoEb1NXv4t/Ci6NaJj
tnrDxeQBaTnRNbRfttSNXf1gq5O0GfeWEqAStOxh5NiJvdx2lRxbIWUoRXU7gUPr
w2A+f45uOQDFAZfF++wvEaUXoT+KOO3MLDljk54WT4vhZmG1sElfpe7UVrTfucp+
m7BqF697wTxa4TgA2D+pxLgXzsfWW4GnC1YolsUUvTvFlIuaBemRSeH3Eq8gOKD1
MS5vWiNhhhgXbX0PmNgTaTRIukL5pToc/u5Hyqh2WRi3FHYDHBfqpmsThGVgbH11
WUyqQV/ATrB/y6aIPlhFG5WXfOz7LbFJNh/bKmD3N2SmMJONLonM4JtO4tJ+Z/gB
o0gzg3g9PxEVoI/upFvs5B2DQnA7rFmuBMNdy6BSt2oNySFvyN0jL3A12iMfWulZ
qHUpIYpFMFjvI7rbJ16z4pcjQ/SLbR3WS8oFbZdw9ILodi/SCUqXeDKB+yc8709t
C7idxMUAnJeXxJeoglJwb9w1+VLX+Od+KrHZ1+vF+/XhLOCqi6k=
=0kMc
-----END PGP SIGNATURE-----