Add python-titlecase.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Efraim Flashner
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 5 years ago
(address . guix-patches@gnu.org)
877dywcqlq.fsf@dustycloud.org
From e566b6434b8696be3d12cd37f3362752c30433e8 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Fri, 3 Apr 2020 15:28:46 -0400
Subject: [PATCH] gnu: Add python-titlecase.

* gnu/packages/python-xyz.scm (python-titlecase): New variable.
---
gnu/packages/python-xyz.scm | 27 ++++++++++++++++++++++++++-
1 file changed, 26 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5bf2f5a3d..cf4ef40895 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
@@ -18726,3 +18726,28 @@ HTML-containing files.")
usable as a configuration language. This Python package implements parsing and
dumping of JSON5 data structures.")
(license license:asl2.0)))
+
+(define-public python-titlecase
+ (package
+ (name "python-titlecase")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "titlecase" version))
+ (sha256
+ (base32
+ "0486i99wf8ssa7sgn81fn6fv6i4rhhq6n751bc740b3hzfbpmpl4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page
+ "https://github.com/ppannuto/python-titlecase")
+ (synopsis
+ "Python library to capitalize strings similar to book titles")
+ (description
+ "Python-Titlecase is a Python Port of John Gruber's titlecase.pl.
+It capitalizes (predominantly English) strings in a way that is similar to
+book titles, using the New York Times Manual of Style to leave certain words
+lowercase.")
+ (license license:expat)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAl6Hj1EACgkQS8Alkl/4
9NO0eBAAvA+9fMDNeNTIkU7EM3hAGxj4EXtvPt6XNiH43IIrO4JAq1cSupaFpcfQ
QPiFgqPFNuFidX1RGBfg4xo6lBG0lzGK3BDCirExnDRv0whR7hNfzt7qns6qR8Qa
VFIbXZehBL/4RsDi+wawhdrhbxXviANzoL4MWhiRvm7p8ZnoEb1NXv4t/Ci6NaJj
tnrDxeQBaTnRNbRfttSNXf1gq5O0GfeWEqAStOxh5NiJvdx2lRxbIWUoRXU7gUPr
w2A+f45uOQDFAZfF++wvEaUXoT+KOO3MLDljk54WT4vhZmG1sElfpe7UVrTfucp+
m7BqF697wTxa4TgA2D+pxLgXzsfWW4GnC1YolsUUvTvFlIuaBemRSeH3Eq8gOKD1
MS5vWiNhhhgXbX0PmNgTaTRIukL5pToc/u5Hyqh2WRi3FHYDHBfqpmsThGVgbH11
WUyqQV/ATrB/y6aIPlhFG5WXfOz7LbFJNh/bKmD3N2SmMJONLonM4JtO4tJ+Z/gB
o0gzg3g9PxEVoI/upFvs5B2DQnA7rFmuBMNdy6BSt2oNySFvyN0jL3A12iMfWulZ
qHUpIYpFMFjvI7rbJ16z4pcjQ/SLbR3WS8oFbZdw9ILodi/SCUqXeDKB+yc8709t
C7idxMUAnJeXxJeoglJwb9w1+VLX+Od+KrHZ1+vF+/XhLOCqi6k=
=0kMc
-----END PGP SIGNATURE-----

Efraim Flashner wrote 5 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 40416-done@debbugs.gnu.org)
20200409210856.GV1518@E5400
Thanks. Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6PjugACgkQQarn3Mo9
g1H+1w/+LPCppole4lJxRlBE0qfIo0GqMwIHtyN2lSORrSoyNxmwR5U9c2IT36lj
Ihj4wyQR+3Cb4Sl7H2zHVVOBTRqci2AAEkNmsSCRuSd3gyyjAgjMzPgC1AjUQmsW
w0YhKpAC2Y/igXJ4TTeNcQdjCiSCWDM9uRlBKo7gmy+gMibtNlQVsygB/n+SCxYr
3BvPowj2Zh3An1xT6K0elFnaCOOEWfH1yypnofNPRG+SBy6Pc7W4F94Goj9FExMA
0WIgAI2jfG87fGCP7MJrrkFrC+79xy0dpoYtB+OP/cmCWlqXCs9NcIqqu/jip1NZ
qJw3ULokoqj6NFd5tYT9gOWM7+EQAVtpZ6kteYsxIZKQPQlkQR0l0t3Mym3jTm25
f3xC2wsMWXY94Ln4WI+DXGTKk/42orP8RvBmqx6mypfDkM3xa9PfUxfAgLVjOtRa
v80RBwimFsRzYo9MbSDsmjNmPyt/t2UmuN+Cepc74fUYulRY3zVa9uV0vaIvuwn7
uyApmfVA3Rt4tKwwbvCpp52g3iUBucouAZhuTiF2oyAYGzAZxu1Zbn3S/X+IoN+v
8TVRb010BjLvFxHa/JOzf5lrUyp5yulX+rrE+SSna4Yabjm2lyGIQAXIlg6KhWmS
9xn3QA5ut4badLmNMUilgNfPqRT4pGPI7+sYf7jrhTxINYUjGTg=
=ikjA
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40416@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40416
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help