(address . guix-patches@gnu.org)
* gnu/packages/java.scm (icedtea-6, icedtea-7, openjdk9)[native-search-paths]:
Set JAVA_HOME to "jre".
This fixes issues for which the Java tooling could not find Jars,
e.g. tools.jar.
---
gnu/packages/java.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 4d305aac49..ca6c64fc1e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1078,6 +1078,10 @@ machine.")))
(sha256
(base32
"0835lkw8vib1xhp8lxnybhlvzdh699hbi4mclxanydjk63zbpxk0"))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "JAVA_HOME")
+ (files '("jre")))))
(home-page "http://icedtea.classpath.org")
(synopsis "Java development kit")
(description
@@ -1620,6 +1624,10 @@ bootstrapping purposes.")
("lcms" ,lcms)
("zlib" ,zlib)
("gtk" ,gtk+-2)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "JAVA_HOME")
+ (files '("jre")))))
(home-page "http://icedtea.classpath.org")
(synopsis "Java development kit")
(description
@@ -1923,6 +1931,10 @@ new Date();"))
("unzip" ,unzip)
("which" ,which)
("zip" ,zip)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "JAVA_HOME")
+ (files '("jre")))))
(home-page "https://openjdk.java.net/projects/jdk9/")
(synopsis "Java development kit")
(description
--
2.25.1