Add emacs-beancount

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Ludovic Courtès
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 5 years ago
(address . guix-patches@gnu.org)
87sghncqt4.fsf@dustycloud.org
Hot on the heels of beancount!

Also is able to inherit the beancount package in a really elegant way,
since it's installing a .el file from that. Moments like this make me
say "I love Guix's delightful design!"
From 7fda36e4be1abc16a9855e13ee450927f0f0e25a Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 1 Apr 2020 08:48:25 -0400
Subject: [PATCH] gnu: Add emacs-beancount.

* gnu/packages/emacs-xyz.scm (emacs-beancount): New variable.
---
gnu/packages/emacs-xyz.scm | 21 ++++++++++++++++++++-
1 file changed, 20 insertions(+), 1 deletion(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3e6f15cd..f908a9f2a3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2019 Chris Marusich <cmmarusich@gmail.com>
-;;; Copyright © 2015, 2016, 2018 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2018, 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
@@ -106,6 +106,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages dictionaries)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages finance)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
@@ -22064,3 +22065,21 @@ conventions.")
(description "Haskell-Snippets is a collection of YASnippet Haskell
snippets for Emacs.")
(license license:expat))))
+
+;; The beancount source ships with elisp in a subdirectory
+(define-public emacs-beancount
+ (package
+ (inherit beancount)
+ (name "emacs-beancount")
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'chdir-emacs
+ (lambda _
+ (chdir "editors/emacs")
+ #t)))))
+ (synopsis "Emacs mode for beancount")
+ (description
+ "Emacs mode for the beancount accounting tool.")))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAl6EjkcACgkQS8Alkl/4
9NM9Wg//ZUoijukaHE25Qpah4dn68jepHqdKUJKevaXqXBA6M1BxvsxZMuWKN5JE
/ULvpfu5qPwCiDgplUI1/ZsGeRUAaZsTI+FCtK3VuVQfrN40w9IQcu9PmWsJtNqQ
aluXLHf8q2VmPGKrOwF9Q8Vk8GZBCQT8VoSLASnYwyXwEP2fFo7OWZNdO+8GtDpL
q1zo/87wRX2urNhwIT2vR2uFHRrSsac45gOe25M7uZQfwBYZu5Z+0OiXc0fJn58x
0mSL+nO9ZWDrTfOmsu37+DLEcUYHqPaofgomd1BAbBTX5r/SDdhq25fObM291tTX
ueYuipvghJbQqkt58+gufRMA+FyEJxT00vGzpY3i85jC5aAfHIZ4NJ6C6F2hX+Gf
Jo+8Z7AU44qubSgfjNF69W8288yUZ29CEohNZWQfS66TW/E9Kvc+cFQQ8Ns1Jcs8
4hoeBBIyxSrqBDqpCgDOpjQ54OqUIZEMUft+rEN4DlsOCWkaJeK1L9+jOhNf1se5
YyA7YbUGFFp1Mknswsr7Er2yPaqqNcQofjkm8LwKePOyuby1YfGK6Gsj80nejAq8
CZ1TbTETPqtcVMTwR8SJv4RGxkVFVJGxQz2Q736tiLzW2BOh7SbDoqZGhM7ob4uv
1Wr77jTvAFCOtjQLiEy2O9F8YmZ0l+yfge/EcH07CeR+e7gY6+c=
=Yanv
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 5 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 40372@debbugs.gnu.org)
87pncqnkdq.fsf@gnu.org
Hello Chris!

Christopher Lemmer Webber <cwebber@dustycloud.org> skribis:

Toggle quote (6 lines)
> Hot on the heels of beancount!
>
> Also is able to inherit the beancount package in a really elegant way,
> since it's installing a .el file from that. Moments like this make me
> say "I love Guix's delightful design!"

Heheh. :-)

Toggle quote (7 lines)
> From 7fda36e4be1abc16a9855e13ee450927f0f0e25a Mon Sep 17 00:00:00 2001
> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
> Date: Wed, 1 Apr 2020 08:48:25 -0400
> Subject: [PATCH] gnu: Add emacs-beancount.
>
> * gnu/packages/emacs-xyz.scm (emacs-beancount): New variable.

[...]

Toggle quote (4 lines)
> + (synopsis "Emacs mode for beancount")
> + (description
> + "Emacs mode for the beancount accounting tool.")))

Bonus points if you can turn that into a full sentence. :-)

Otherwise LGTM, thank you!

Ludo’.
Christopher Lemmer Webber wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 40372-done@debbugs.gnu.org)
87k12xdid7.fsf@dustycloud.org
Ludovic Courtès writes:

Toggle quote (31 lines)
> Hello Chris!
>
> Christopher Lemmer Webber <cwebber@dustycloud.org> skribis:
>
>> Hot on the heels of beancount!
>>
>> Also is able to inherit the beancount package in a really elegant way,
>> since it's installing a .el file from that. Moments like this make me
>> say "I love Guix's delightful design!"
>
> Heheh. :-)
>
>> From 7fda36e4be1abc16a9855e13ee450927f0f0e25a Mon Sep 17 00:00:00 2001
>> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
>> Date: Wed, 1 Apr 2020 08:48:25 -0400
>> Subject: [PATCH] gnu: Add emacs-beancount.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-beancount): New variable.
>
> [...]
>
>> + (synopsis "Emacs mode for beancount")
>> + (description
>> + "Emacs mode for the beancount accounting tool.")))
>
> Bonus points if you can turn that into a full sentence. :-)
>
> Otherwise LGTM, thank you!
>
> Ludo’.

Ok, done and pushed! Thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40372@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40372
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help