Add beancount

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Ludovic Courtès
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal
C
C
Christopher Lemmer Webber wrote on 31 Mar 2020 23:03
(address . guix-patches@gnu.org)
87tv24ck4k.fsf@dustycloud.org
Yet Another Plaintext Accounting System!
From 27274e0075f7215693cc4a51482c68ce00167d37 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 31 Mar 2020 16:57:15 -0400
Subject: [PATCH] gnu: Add beancount.

* gnu/packages/finance.scm (beancount): New variable.
* gnu/packages/patches/beancount-disable-googleapis-fonts.patch: New file.
---
gnu/packages/finance.scm | 42 +++++++++++++++++++
.../beancount-disable-googleapis-fonts.patch | 23 ++++++++++
2 files changed, 65 insertions(+)
create mode 100644 gnu/packages/patches/beancount-disable-googleapis-fonts.patch

Toggle diff (89 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7bf8f4fc6e..53bbbb2f84 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1398,3 +1399,44 @@ entity management.")
electronic cash system. This package provides a command line client and
a Qt GUI.")
(license license:expat)))
+
+(define-public beancount
+ (package
+ (name "beancount")
+ (version "2.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "beancount" version))
+ (sha256
+ (base32
+ "0pcfl2rx2ng06i4f9izdpnlnb1k0rdzsckbzzn4cn4ixfzyssm0m"))
+ (patches (search-patches "beancount-disable-googleapis-fonts.patch"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; Says test is missing, not sure why
+ #:phases
+ (modify-phases %standard-phases
+ ;; Not importing the googleapis package for now
+ (add-after 'unpack 'ignore-googleapis
+ (lambda _
+ (substitute* "setup.py"
+ (("'google-api-python-client',") ""))
+ #t)))))
+ (propagated-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-bottle" ,python-bottle)
+ ("python-chardet" ,python-chardet)
+ ("python-dateutil" ,python-dateutil)
+ ("python-lxml" ,python-lxml)
+ ("python-magic" ,python-magic)
+ ("python-ply" ,python-ply)
+ ("python-pytest" ,python-pytest)
+ ("python-requests" ,python-requests)))
+ (home-page "http://furius.ca/beancount")
+ (synopsis "Command-line Double-Entry Accounting")
+ (description
+ "A double-entry bookkeeping computer language that lets you define
+financial transaction records in a text file, read them in memory, generate
+a variety of reports from them, and provides a web interface.")
+ (license license:gpl2)))
diff --git a/gnu/packages/patches/beancount-disable-googleapis-fonts.patch b/gnu/packages/patches/beancount-disable-googleapis-fonts.patch
new file mode 100644
index 0000000000..f3ef574ddc
--- /dev/null
+++ b/gnu/packages/patches/beancount-disable-googleapis-fonts.patch
@@ -0,0 +1,23 @@
+From: Nicolas Dandrimont <nicolas@dandrimont.eu>
+Date: Tue, 1 May 2018 04:49:55 +0200
+Subject: Remove fonts.googleapis.com links for the bean-web template
+
+---
+ beancount/web/web.html | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/beancount/web/web.html b/beancount/web/web.html
+index 3995ce2..ec9e707 100644
+--- a/beancount/web/web.html
++++ b/beancount/web/web.html
+@@ -3,10 +3,6 @@
+ <head>
+ <meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
+
+- <link href="https://fonts.googleapis.com/css?family=Roboto+Condensed:400italic,700italic,700,400" rel="stylesheet" type="text/css" />
+- <link href="https://fonts.googleapis.com/css?family=Roboto:400italic,700italic,700,400" rel="stylesheet" type="text/css" />
+- <link href='https://fonts.googleapis.com/css?family=Droid+Sans+Mono' rel='stylesheet' type='text/css' />
+-
+ <link href="/resources/web.css" rel="stylesheet" type="text/css" />
+ <title>{{title}}: {{pagetitle}}</title>
+
\ No newline at end of file
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAl6DsBsACgkQS8Alkl/4
9NPQnw/+Lsoz9iyY9OkcSC11hn/ddnUKsCEPmVCd1ZsfYbFq7cm2k1ksiN4zR8k0
WKF+C2MCGldM2rRAr3YIJYUxNzyiTikSVaIVUcSArAuP5V9/SrO1UqeXurgLUPdj
i0XhD58+3HMOu/LqUGntORQVXA0YySTB08j1cohNXIVO9iUErD77cr7b9Pj87AfZ
tZQ5eRggungj62uB3BVlYG3FrM/CCCrZDXBWAkrlQOnF07HcIdYOmxI4IaGOkdSN
4Rn9KJnxkphrWkOmEpp7gRU15HLkmNOu48gtixOv+Kv66pf2bevV7+uhZGNHDSHc
t+h2g83NG55PLeyUFF804NVVkmVOzkpJ0EVkuQUNBNKstCw+6JV0/qvZHiNSyGbD
dDFdeG9zM7QCSr//8Cl7s6eSG1t3HEjGQHUHenbPbj/hyaS8agAzqI9R6Muk5aAc
PVw0bhTncdOa2/7bKON0JRLz/QmLzLaOTz3PnaKWafpw8+kgr/dwnWUU1cIQzZMD
2ZeuiuPaDK6km0cNDfBmeCyaCOxe+tc3C+BhUSB8cKFivaaB0Uo4bfsFZ3bfcllN
yTlyOMB5ScUgtvsp6hcOSRy1Q9I/p4UqOKDO+TKc+NAkrMlUllZfI7rnGnwQvkvs
9keJ1hfeBB+bWXoS0VakZc4atczbPRhK7x2ebIpBEhvZ9V6QGEo=
=a8rG
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 2 Apr 2020 15:44
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 40358@debbugs.gnu.org)
87lfnengta.fsf@gnu.org
Hello!

Christopher Lemmer Webber <cwebber@dustycloud.org> skribis:

Toggle quote (8 lines)
> From 27274e0075f7215693cc4a51482c68ce00167d37 Mon Sep 17 00:00:00 2001
> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
> Date: Tue, 31 Mar 2020 16:57:15 -0400
> Subject: [PATCH] gnu: Add beancount.
>
> * gnu/packages/finance.scm (beancount): New variable.
> * gnu/packages/patches/beancount-disable-googleapis-fonts.patch: New file.

Could you add the patch to gnu/local.mk?

Toggle quote (3 lines)
> + (synopsis "Command-line Double-Entry Accounting")

Nitpick: please remote capitals except for the first one, and…

Toggle quote (5 lines)
> + (description
> + "A double-entry bookkeeping computer language that lets you define
> +financial transaction records in a text file, read them in memory, generate
> +a variety of reports from them, and provides a web interface.")

… make it a full sentence.

Toggle quote (6 lines)
> +++ b/gnu/packages/patches/beancount-disable-googleapis-fonts.patch
> @@ -0,0 +1,23 @@
> +From: Nicolas Dandrimont <nicolas@dandrimont.eu>
> +Date: Tue, 1 May 2018 04:49:55 +0200
> +Subject: Remove fonts.googleapis.com links for the bean-web template

Could you add the URL of the upstream patch or discussion, if any?

OK with these changes!

Thanks,
Ludo’.
C
C
Christopher Lemmer Webber wrote on 2 Apr 2020 17:20
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 40358-done@debbugs.gnu.org)
87lfnddidn.fsf@dustycloud.org
Ludovic Courtès writes:

Toggle quote (14 lines)
> Hello!
>
> Christopher Lemmer Webber <cwebber@dustycloud.org> skribis:
>
>> From 27274e0075f7215693cc4a51482c68ce00167d37 Mon Sep 17 00:00:00 2001
>> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
>> Date: Tue, 31 Mar 2020 16:57:15 -0400
>> Subject: [PATCH] gnu: Add beancount.
>>
>> * gnu/packages/finance.scm (beancount): New variable.
>> * gnu/packages/patches/beancount-disable-googleapis-fonts.patch: New file.
>
> Could you add the patch to gnu/local.mk?

Good call. Done.

Toggle quote (5 lines)
>> + (synopsis "Command-line Double-Entry Accounting")
>
> Nitpick: please remote capitals except for the first one, and…

Done.

Toggle quote (7 lines)
>> + (description
>> + "A double-entry bookkeeping computer language that lets you define
>> +financial transaction records in a text file, read them in memory, generate
>> +a variety of reports from them, and provides a web interface.")
>
> … make it a full sentence.

Okay, done.

Toggle quote (13 lines)
>> +++ b/gnu/packages/patches/beancount-disable-googleapis-fonts.patch
>> @@ -0,0 +1,23 @@
>> +From: Nicolas Dandrimont <nicolas@dandrimont.eu>
>> +Date: Tue, 1 May 2018 04:49:55 +0200
>> +Subject: Remove fonts.googleapis.com links for the bean-web template
>
> Could you add the URL of the upstream patch or discussion, if any?
>
> OK with these changes!
>
> Thanks,
> Ludo’.

Pushed! Thanks for your review!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40358@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40358
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch