(address . guix-patches@gnu.org)
* guix/ui.scm (show-manifest-transaction)[upgrade-string]: Use the
package name in UI message.
---
guix/ui.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
Toggle diff (31 lines)
diff --git a/guix/ui.scm b/guix/ui.scm
index 1e24fe5dca..20b1e79ca9 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1162,11 +1163,13 @@ separator between subsequent columns."
name
(string-append name ":" output)))
names outputs)
- (map (lambda (old new)
+ (map (lambda (old new name)
(if (string=? old new)
- (G_ "(dependencies changed)")
+ (format
+ (G_ "(dependencies or ~a package recipe changed)")
+ name)
(string-append old " " → " " new)))
- old-version new-version))
+ old-version new-version names))
#:initial-indent 3))
(let-values (((remove install upgrade downgrade)
--
2.26.0