[PATCH] gnu: Add emacs-haskell-snippets.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
87k1342cl1.fsf@asu.edu
Hi Guix,

I find the haskell-snippets very helpful when writing haskell.

Thanks,

John
Nicolas Goaziou wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40300@debbugs.gnu.org)
871rp97ofd.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (2 lines)
> I find the haskell-snippets very helpful when writing haskell.

Thank you... but you forgot to send the patch.

Regards,

--
Nicolas Goaziou
John Soo wrote 5 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 40300@debbugs.gnu.org)
877dz1wxom.fsf@asu.edu
Hi Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (2 lines)
> Thank you... but you forgot to send the patch.

Oh, sorry. Here it is.

Thanks for the speedy review!

John
From 5ee54c3cfc32c26d8654502b05334cf0f2085764 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 07:21:35 -0700
Subject: [PATCH] gnu: Add emacs-haskell-snippets.

* gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): New variable.
---
gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..f1c0114662 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,39 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-haskell-snippets
+ (package
+ (name "emacs-haskell-snippets")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/haskell/haskell-snippets")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b3d7rvqvvcsp51aqfhl0zg9zg8j0p6vlfvga6jp9xc7626vh6f6"))))
+ (inputs
+ `(("emacs-yasnippet" ,emacs-yasnippet)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-snippets
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (snippets
+ (string-append
+ out "/share/emacs/site-lisp/snippets/haskell-mode")))
+ (mkdir-p snippets)
+ (copy-recursively "snippets/haskell-mode" snippets)
+ #t))))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/haskell/haskell-snippets")
+ (synopsis "Official collection of YASnippet Haskell snippets for Emacs")
+ (description "Haskell-Snippets is a collection of YASnippet Haskell
+snippets for Emacs.")
+ (license license:expat)))
--
2.26.0
Nicolas Goaziou wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40300@debbugs.gnu.org)
87sghp6882.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (5 lines)
> +(define-public emacs-haskell-snippets
> + (package
> + (name "emacs-haskell-snippets")
> + (version "0.1.0")

Would it make sense to package HEAD instead. I'm looking in particular
at upstream's commit 9e41a53f8388f2a2cf2a1bb3163bc6de764099d5.

Toggle quote (12 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/haskell/haskell-snippets")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0b3d7rvqvvcsp51aqfhl0zg9zg8j0p6vlfvga6jp9xc7626vh6f6"))))

Usual nitpick: please put string on the same line as `base32'.

Toggle quote (16 lines)
> + (inputs
> + `(("emacs-yasnippet" ,emacs-yasnippet)))
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'install 'install-snippets
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (snippets
> + (string-append
> + out "/share/emacs/site-lisp/snippets/haskell-mode")))
> + (mkdir-p snippets)
> + (copy-recursively "snippets/haskell-mode" snippets)
> + #t))))))
> + (build-system emacs-build-system)

Nitpick: could you move parts in this order: build-system ->
arguments -> inputs.

Regards,

--
Nicolas Goaziou
John Soo wrote 5 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 40300@debbugs.gnu.org)
87tv25vf5w.fsf@asu.edu
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (12 lines)
> Hello,
>
> John Soo <jsoo1@asu.edu> writes:
>
>> +(define-public emacs-haskell-snippets
>> + (package
>> + (name "emacs-haskell-snippets")
>> + (version "0.1.0")
>
> Would it make sense to package HEAD instead. I'm looking in particular
> at upstream's commit 9e41a53f8388f2a2cf2a1bb3163bc6de764099d5.

I think so. Done.

Toggle quote (14 lines)
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri
>> + (git-reference
>> + (url "https://github.com/haskell/haskell-snippets")
>> + (commit version)))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "0b3d7rvqvvcsp51aqfhl0zg9zg8j0p6vlfvga6jp9xc7626vh6f6"))))
>
> Usual nitpick: please put string on the same line as `base32'.

Done.

Toggle quote (19 lines)
>> + (inputs
>> + `(("emacs-yasnippet" ,emacs-yasnippet)))
>> + (arguments
>> + `(#:phases
>> + (modify-phases %standard-phases
>> + (add-after 'install 'install-snippets
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (let* ((out (assoc-ref outputs "out"))
>> + (snippets
>> + (string-append
>> + out "/share/emacs/site-lisp/snippets/haskell-mode")))
>> + (mkdir-p snippets)
>> + (copy-recursively "snippets/haskell-mode" snippets)
>> + #t))))))
>> + (build-system emacs-build-system)
>
> Nitpick: could you move parts in this order: build-system ->
> arguments -> inputs.

Yes I can. Done.

I also changed inputs -> propagated-inputs.

Thanks again,

John
From 1984fc60cc5045c50ae9f913b13ebbc93101f731 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 07:21:35 -0700
Subject: [PATCH] gnu: Add emacs-haskell-snippets.

* gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): New variable.
---
gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c029d1ed3d..1d46f540ad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21965,3 +21965,39 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-haskell-snippets
+ (let ((commit "07b0f460b946fd1be26c29652cb0468b47782f3a"))
+ (package
+ (name "emacs-haskell-snippets")
+ (version (git-version "0.1.0" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/haskell/haskell-snippets")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a7y3awi9hcyahggf0ghsdwvsmrhr9yq634wy9lkqjzrm2hqj0ci"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-snippets
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (snippets
+ (string-append
+ out "/share/emacs/site-lisp/snippets/haskell-mode")))
+ (mkdir-p snippets)
+ (copy-recursively "snippets/haskell-mode" snippets)
+ #t))))))
+ (propagated-inputs
+ `(("emacs-yasnippet" ,emacs-yasnippet)))
+ (home-page "https://github.com/haskell/haskell-snippets")
+ (synopsis "Official collection of YASnippet Haskell snippets for Emacs")
+ (description "Haskell-Snippets is a collection of YASnippet Haskell
+snippets for Emacs.")
+ (license license:expat))))
--
2.26.0
Nicolas Goaziou wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40300-done@debbugs.gnu.org)
87lfnh60hw.fsf@nicolasgoaziou.fr
John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-haskell-snippets.
>
> * gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): New variable.

Applied as 1c2f6d66ecf70637d92cb984d0c60433ba3e41e8. I added a comment
explaing why we don't provide a release.

Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40300@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40300
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help