John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
Hi Guix,
In preparation for the next emacs version I thought it would be good to
start adding "next" versions of some emacs packages. I added this for
proof-general, but there may be other needs for the minimal emacs for
version 27.
Thanks,
John
Toggle quote (1 lines)
>From 100e821af07716c463131acdb695bce630e2efa4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 10:38:15 -0700
Subject: [PATCH] gnu: Add emacs-next-minimal.
* gnu/packages/emacs.scm (emacs-next-minimal): New variable.
---
gnu/packages/emacs.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ec8de7373b..5d031b9695 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Valentin Ignatev <valentignatev@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -354,6 +355,34 @@ languages.")
(native-inputs
`(("pkg-config" ,pkg-config)))))
+(define-public emacs-next-minimal
+ (package
+ (inherit emacs-next)
+ (name "emacs-next-minimal")
+ (synopsis (package-synopsis emacs-minimal))
+ (build-system gnu-build-system)
+ (inputs
+ `(("jansson" ,jansson)
+ ("texinfo" ,texinfo)
+ ,@(package-inputs emacs-minimal)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ,@(package-native-inputs emacs-minimal)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments emacs-next)
+ ((#:modules _)
+ `((guix build emacs-utils)
+ ,@%gnu-build-system-modules))
+ ((#:imported-modules _)
+ `((guix build emacs-utils)
+ ,@%gnu-build-system-modules))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'install-site-start)
+ (delete 'restore-emacs-pdmp)))
+ ((#:configure-flags flags ''())
+ `(list "--with-gnutls=no" "--disable-build-details"))))))
+
(define-public emacs-xwidgets
(package
(inherit emacs)
--
2.26.0