[PATCH] gnu: cedille: Fix outputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Marius Bakke
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
87wo7444iz.fsf@asu.edu
Hi Guix,

Cedille's emacs-mode paths needed some slight adjustment.
This also installs the info page I missed when first submitting the
package.

Thanks,

John
Toggle quote (1 lines)
>From 472597a80f467a78600591c3b83b727e1bdd44a2 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 27 Mar 2020 07:46:32 -0700
Subject: [PATCH 1/2] gnu: cedille: Fix emacs outputs.

* gnu/packages/cedille.scm (cedille):[arguments] Add slashes to output paths.
---
gnu/packages/cedille.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cedille.scm b/gnu/packages/cedille.scm
index d9cf66c501..9f6c01ea80 100644
--- a/gnu/packages/cedille.scm
+++ b/gnu/packages/cedille.scm
@@ -56,12 +56,15 @@
(let ((out (assoc-ref outputs "out")))
(substitute* "cedille-mode.el"
(("/usr/share/emacs/site-lisp/cedille-mode")
- (string-append out "/share/emacs/site-lisp")))
+ (string-append
+ out "/share/emacs/site-lisp/cedille")))
#t)))
(add-after 'unpack 'copy-cedille-mode
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (lisp (string-append out "/share/emacs/site-lisp")))
+ (lisp
+ (string-append
+ out "/share/emacs/site-lisp/cedille/")))
(mkdir-p (string-append lisp "cedille-mode"))
(copy-recursively
"cedille-mode"
--
2.26.0
Toggle quote (1 lines)
>From 45f8563a1d0a32763b43966b214902571ec7c6cb Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sat, 28 Mar 2020 10:30:48 -0700
Subject: [PATCH 2/2] gnu: cedille: Install the info pages.

* gnu/packages/cedille.scm (cedille):[arguments] Install the info pages.
---
gnu/packages/cedille.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/cedille.scm b/gnu/packages/cedille.scm
index 9f6c01ea80..d3dd576323 100644
--- a/gnu/packages/cedille.scm
+++ b/gnu/packages/cedille.scm
@@ -51,15 +51,19 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-cedille-path-el
+ (add-after 'unpack 'patch-cedille-paths
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "cedille-mode.el"
(("/usr/share/emacs/site-lisp/cedille-mode")
(string-append
out "/share/emacs/site-lisp/cedille")))
+ (substitute* "cedille-mode/cedille-mode-info.el"
+ (("\\(concat cedille-path-el \"cedille-info-main.info\"\\)")
+ (string-append
+ "\"" out "/share/info/cedille-info-main.info.gz\"")))
#t)))
- (add-after 'unpack 'copy-cedille-mode
+ (add-after 'patch-cedille-paths 'copy-cedille-mode
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lisp
@@ -107,6 +111,8 @@
(install-file "cedille" (string-append out "/bin"))
(install-file "core/cedille-core"
(string-append out "/bin"))
+ (install-file "docs/info/cedille-info-main.info"
+ (string-append out "/share/info"))
#t))))))
(home-page "https://cedille.github.io/")
(synopsis
--
2.26.0
Marius Bakke wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40293-done@debbugs.gnu.org)
87zhbtrg5t.fsf@devup.no
John Soo <jsoo1@asu.edu> writes:

Toggle quote (6 lines)
> Hi Guix,
>
> Cedille's emacs-mode paths needed some slight adjustment.
> This also installs the info page I missed when first submitting the
> package.

Thanks! I rewrote the commit message of the second patch to more
accurately convey what the patch does in the GNU ChangeLog style.

Applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6GFm4ACgkQoqBt8qM6
VPqKFggAvSzQMUbr+hyYzNYimWRyGYhLnluiQdWpRGoXWZlRNfxrRu6yiPbqXn3n
vg1ajlahion4qFSfFXv7XCPF3Kwvz6QAlHLKqvwTf3CRlZhSWnhGhL8r+ei/Nsf8
FRDg4aHkWQeDjO/6S/SALeFpn1nl3IhdE0gvcEjnYjWJi1rHy8swbninvmp+LrMg
7+zPJLt82uH94i/n02o2ZfKCPKW2iq402KDSTJoMPHxqkkHGV07/HpzjYAgCRJxQ
Lcd58t7ui18JoyuKuRFCmlJsiJAFVusskUtUXkTpG4j1kQFE8oTngab+Im/8jsjJ
c6pWO5LSrVaRSgexY19U8AvZGYxYvg==
=3X4l
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40293@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40293
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help