I didn't realize we had so much of lxqt packaged.
Some comments inline:
On Sat, Mar 28, 2020 at 09:11:06PM +0430, Hamzeh Nasajpour wrote:
Toggle quote (18 lines)
> * gnu/packages/lxqt.scm (lxqt-organizer): New variable.
> ---
> gnu/packages/lxqt.scm | 34 ++++++++++++++++++++++++++++++++++
> 1 file changed, 34 insertions(+)
>
> diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
> index a440491633..7ef6ca51ce 100644
> --- a/gnu/packages/lxqt.scm
> +++ b/gnu/packages/lxqt.scm
> @@ -1269,6 +1269,40 @@ QTermWidget.")
> easily publishing them on internet image hosting services.")
> (license license:gpl2+)))
>
> +(define-public lxqt-organizer
> + (package
> + (name "lxqt-organizer")
> + (version "v0.003")
The author seems to be using this time to do some rapid development and
has already (at the time I checked) already bumped the version to
v0.6.0. Can you update to the most recent version?
Toggle quote (8 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url (string-append "https://github.com/lxqt/organizer.git"))
> + (commit "5aa556aa0f0409e00fac5b63d9118ff228d2e840")
> + (recursive? #t)))
I was going to mention using the version string for the commit but it
seems they haven't pushed any tags to the repo. Can you add a comment
saying they haven't tagged any releases in git? Also, it doesn't look
like there are any submodules so you don't need 'recursive? #t'
Toggle quote (13 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1czs9gca7aqsfcnxhi7nzq97pxbmhfgbfh00j7nl8cig0yxb6apv"))))
> + (build-system cmake-build-system)
> + (inputs
> + `(("kwindowsystem" ,kwindowsystem)
> + ("liblxqt" ,liblxqt)
> + ("libqtxdg" ,libqtxdg)
> + ("qtbase" ,qtbase)
> + ("qtsvg" ,qtsvg)
> + ;;("qtlinguist" ,qttools)
> + ("qtx11extras" ,qtx11extras)))
guix gc --references /path/to/item doesn't list all the inputs, so many
of them can actually be moved to native-inputs.
Toggle quote (7 lines)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("lxqt-build-tools" ,lxqt-build-tools)
> + ("qttools" ,qttools)))
> + (arguments
> + '(#:tests? #f))
I saw that there were no tests in the repo, please add a note.
Toggle quote (2 lines)
Is there a project-specific home-page? If not I'd recommend just using
the github repo as the home-page.
Toggle quote (1 lines)
> + (synopsis "LXQt Organizer is a lightweight organizer for personal information management.")
Perhaps: "LXQt desktop organizer" or "LXQt organizer for personal
information management" Actually the second sounds clunky. "LXQt
personal information management organizer"
Toggle quote (10 lines)
> + (description
> + "This package provides a Qt-based application for managing meetings, events and other personal information.")
> + (license license:lgpl2.1+)))
>
> (define-public lxqt-archiver
> (package
> --
> 2.25.1
>
In addition, in the desktop file (in %out/share/application/) there's a
second exec line which starts /usr/local/lxqt-organizer. Can you add a
phase to patch that?
Also, 'guix lint' complains about the length of two of the lines and
about the period in the synopsis.
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----
iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6BseMACgkQQarn3Mo9
g1HfbA/9FQQ9NZmz6qwuWQmFc7uuH/CuwP65hnFswDTXlZGYPl3wnZYQlW5gCIsD
8QSkoXJK4sDGw/tW+RQMlY1i1TVHDuPrCHH5W/EossgQ722DXdxD8IzNeKIa8cxX
xcIBWiStDBXNh6Yy/3CPpEh/ByaYMPACmAjvoBzXfN7kZ2D+ZQLbBBUOF4TRFGEi
G81PqxloCWC0Xog7gu22dAxQsV+d1W35Kwj6tQ+2ENoDli8jDD+VsSolxx3S+Sx/
2d5Ci16llFl5iJGaP0UdHCcLhAUgHrxkSqVFaXIgQL3kL8sj0ty++4GFMpPtUohM
oOkiF2S/jEHuEnHUKL7yoF3FQN1aA7qNxTEUuBcQPqgJ/PafxrEYUHt2/vzTaPGE
11b8fj5VooiJPT4r1JE7OBRzv0Q11cdP+xUW7rKLt84YeKBBMFC1xjNJZmq8kaez
9bKEeyIKHENb5YLJwmqduBUZYF2pS17nxqOwOluPtZuJ1by8Me8gDQL2KjX7cia9
0d6NAFnQoU2i8P784I56M3CK3jwcYHDL0YI86nqaz0vaQ8h2blVKvr0zBtm/ni8N
Nv4iBTvyDEn3sQWr70M8r1ujN4vf3X8d5z0fZVmpL5X9I0A0QaMOoGWQcah4Oa/L
lxd+7kpkHmJCj7zqPvNF/4hsrtIZTAaotdoSBksxluKQtuOXEhY=
=CJog
-----END PGP SIGNATURE-----