(address . guix-patches@gnu.org)
Mtpaint is a graphic editing program which uses the GTK+ toolkit.
Create pixel art and manipulate digital photos. It can create and
edit indexed pallete or 24bit RGB images, offers basic painting
and palette manipulation tools.
Signed-off-by: R Veera Kumar <vkor@vkten.in>
---
gnu/packages/image.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)
Toggle diff (66 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b665740ca2..c4b979a775 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -1983,3 +1984,51 @@ AOM, including with alpha.")
(home-page "https://github.com/AOMediaCodec/libavif")
(license (list license:bsd-2 ; libavif itself
license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+ (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+ (revision "1"))
+ (package
+ (name "mtpaint")
+ (version (git-version "3.49.25" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjaguar/mtPaint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("which" ,which)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libungif", libungif)
+ ("libjpeg", libjpeg)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
+ ("lcms" ,lcms)
+ ("zlib", zlib)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("gettext" ,gettext-minimal)))
+ (arguments
+ `(#:configure-flags
+ (list
+ "intl") ;; internationalized support
+ ;; no make check
+ #:tests? #f))
+ (home-page "http://mtpaint.sourceforge.net/")
+ (synopsis "Create pixel art and manipulate digital photos")
+ (description
+ "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed pallete or 24bit RGB images, offers basic
+painting and palette manipulation tools. It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM files.")
+ (license license:gpl3+))))
--
2.26.0