[PATCH] gnu: Add mtpaint

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Ricardo Wurmus
  • R Veera Kumar
Owner
unassigned
Submitted by
R Veera Kumar
Severity
normal
R
R
R Veera Kumar wrote on 29 Mar 2020 19:21
(address . guix-patches@gnu.org)
20200329172136.GA23111@tulip
Mtpaint is a graphic editing program which uses the GTK+ toolkit.
Create pixel art and manipulate digital photos. It can create and
edit indexed pallete or 24bit RGB images, offers basic painting
and palette manipulation tools.

Signed-off-by: R Veera Kumar <vkor@vkten.in>
---
gnu/packages/image.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b665740ca2..c4b979a775 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -1983,3 +1984,51 @@ AOM, including with alpha.")
(home-page "https://github.com/AOMediaCodec/libavif")
(license (list license:bsd-2 ; libavif itself
license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+ (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+ (revision "1"))
+ (package
+ (name "mtpaint")
+ (version (git-version "3.49.25" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjaguar/mtPaint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("which" ,which)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libungif", libungif)
+ ("libjpeg", libjpeg)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
+ ("lcms" ,lcms)
+ ("zlib", zlib)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("gettext" ,gettext-minimal)))
+ (arguments
+ `(#:configure-flags
+ (list
+ "intl") ;; internationalized support
+ ;; no make check
+ #:tests? #f))
+ (home-page "http://mtpaint.sourceforge.net/")
+ (synopsis "Create pixel art and manipulate digital photos")
+ (description
+ "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed pallete or 24bit RGB images, offers basic
+painting and palette manipulation tools. It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM files.")
+ (license license:gpl3+))))
--
2.26.0
R
R
R Veera Kumar wrote on 31 Mar 2020 11:39
[PATCH v2] gnu: Add mtpaint.
(address . 40281@debbugs.gnu.org)
20200331093956.GA8435@tulip
* gnu/packages/image.scm (mtpaint): New variable.

Signed-off-by: R Veera Kumar <vkor@vkten.in>
---
Changes in v2:
- Commit msg according to changelog format
- put gettext in native-inputs
---
gnu/packages/image.scm | 50 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index cc9cf8cd6a..4946f5a500 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -1979,3 +1981,51 @@ AOM, including with alpha.")
(home-page "https://github.com/AOMediaCodec/libavif")
(license (list license:bsd-2 ; libavif itself
license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+ (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+ (revision "1"))
+ (package
+ (name "mtpaint")
+ (version (git-version "3.49.25" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjaguar/mtPaint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libungif", libungif)
+ ("libjpeg", libjpeg)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
+ ("lcms" ,lcms)
+ ("zlib", zlib)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)))
+ (arguments
+ `(#:configure-flags
+ (list
+ "intl") ;; internationalized support
+ ;; no check target
+ #:tests? #f))
+ (home-page "http://mtpaint.sourceforge.net/")
+ (synopsis "Create pixel art and manipulate digital images")
+ (description
+ "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed pallete or 24bit RGB images, offers basic
+painting and palette manipulation tools. It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM files.")
+ (license license:gpl3+))))
--
2.26.0
R
R
Ricardo Wurmus wrote on 3 Apr 2020 06:15
(name . R Veera Kumar)(address . vkor@vkten.in)(address . 40281@debbugs.gnu.org)
87k12xw6f6.fsf@elephly.net
R Veera Kumar <vkor@vkten.in> writes:

Toggle quote (2 lines)
> * gnu/packages/image.scm (mtpaint): New variable.

Thank you for the patch!

Toggle quote (5 lines)
> +
> +(define-public mtpaint
> + (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
> + (revision "1"))

Why is this particular commit needed? Can’t we use the latest release?

Toggle quote (18 lines)
> + (package
> + (name "mtpaint")
> + (version (git-version "3.49.25" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/wjaguar/mtPaint/")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
> + (build-system gnu-build-system)
> + (native-inputs
> + `(("gettext" ,gettext-minimal)
> + ("pkg-config" ,pkg-config)
> + ("pkg-config" ,pkg-config)

You have this line twice.

Toggle quote (14 lines)
> + ("which" ,which)))
> + (inputs
> + `(("imlib2" ,imlib2)
> + ("libtiff" ,libtiff)
> + ("libpng" ,libpng)
> + ("libungif", libungif)
> + ("libjpeg", libjpeg)
> + ("libwebp" ,libwebp)
> + ("openjpeg" ,openjpeg)
> + ("lcms" ,lcms)
> + ("zlib", zlib)
> + ("glib" ,glib)
> + ("gtk+" ,gtk+-2)))

Could you please build with gtk+ (i.e. version 3). You probably need to
add “gtk3” to the configure flags.

Toggle quote (5 lines)
> + (arguments
> + `(#:configure-flags
> + (list
> + "intl") ;; internationalized support

Please remove the line break.
For margin comments (at the end of a line) use just one semicolon please.

Toggle quote (9 lines)
> + ;; no check target
> + #:tests? #f))
> + (home-page "http://mtpaint.sourceforge.net/")
> + (synopsis "Create pixel art and manipulate digital images")
> + (description
> + "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
> +It can create and edit indexed pallete or 24bit RGB images, offers
> basic

“pallete” –> “palette”

Toggle quote (2 lines)
> +painting and palette manipulation tools.

Same here.

--
Ricardo
R
R
R Veera Kumar wrote on 3 Apr 2020 06:42
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 40281@debbugs.gnu.org)
20200403044251.GA1591@tulip
On Fri, Apr 03, 2020 at 06:15:57AM +0200, Ricardo Wurmus wrote:
Toggle quote (15 lines)
>
> R Veera Kumar <vkor@vkten.in> writes:
>
> > * gnu/packages/image.scm (mtpaint): New variable.
>
> Thank you for the patch!
>
> > +
> > +(define-public mtpaint
> > + (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
> > + (revision "1"))
>
> Why is this particular commit needed? Can’t we use the latest release?
>

The author does not make release tarballs or even make git release tags.
He only puts package version in git commit title.
Toggle quote (21 lines)
> > + (package
> > + (name "mtpaint")
> > + (version (git-version "3.49.25" revision commit))
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/wjaguar/mtPaint/")
> > + (commit commit)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
> > + (build-system gnu-build-system)
> > + (native-inputs
> > + `(("gettext" ,gettext-minimal)
> > + ("pkg-config" ,pkg-config)
> > + ("pkg-config" ,pkg-config)
>
> You have this line twice.
>

Will correct this.

Toggle quote (18 lines)
> > + ("which" ,which)))
> > + (inputs
> > + `(("imlib2" ,imlib2)
> > + ("libtiff" ,libtiff)
> > + ("libpng" ,libpng)
> > + ("libungif", libungif)
> > + ("libjpeg", libjpeg)
> > + ("libwebp" ,libwebp)
> > + ("openjpeg" ,openjpeg)
> > + ("lcms" ,lcms)
> > + ("zlib", zlib)
> > + ("glib" ,glib)
> > + ("gtk+" ,gtk+-2)))
>
> Could you please build with gtk+ (i.e. version 3). You probably need to
> add “gtk3” to the configure flags.
>

Currently gtk2 support is stable. gtk3 is testing stage.

Toggle quote (9 lines)
> > + (arguments
> > + `(#:configure-flags
> > + (list
> > + "intl") ;; internationalized support
>
> Please remove the line break.
> For margin comments (at the end of a line) use just one semicolon please.
>

Will correct.

Toggle quote (12 lines)
> > + ;; no check target
> > + #:tests? #f))
> > + (home-page "http://mtpaint.sourceforge.net/")
> > + (synopsis "Create pixel art and manipulate digital images")
> > + (description
> > + "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
> > +It can create and edit indexed pallete or 24bit RGB images, offers
> > basic
>
> “pallete” –> “palette”
>

Will correct.

Toggle quote (5 lines)
> > +painting and palette manipulation tools.
>
> Same here.
>

Will correct.

R Veera Kumar

Toggle quote (2 lines)
> --
> Ricardo
R
R
R Veera Kumar wrote on 3 Apr 2020 18:33
[PATCH v3] gnu: Add mtpaint.
(address . 40281@debbugs.gnu.org)(name . R Veera Kumar)(address . vkor@vkten.in)
20200403163347.4219-1-vkor@vkten.in
* gnu/packages/image.scm (mtpaint): New variable.
---
Changes in v3:
- Remove duplicate native-inputs entry
- Proper use of comments
- add installation of man page.
- Correct a spelling mistake in description
Changes in v2:
- Commit msg according to changelog format
- put gettext in native-inputs
---
gnu/packages/image.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 99fa1e05e6..c3b55dd918 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -1979,3 +1981,53 @@ AOM, including with alpha.")
(home-page "https://github.com/AOMediaCodec/libavif")
(license (list license:bsd-2 ; libavif itself
license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+ (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+ (revision "1"))
+ (package
+ (name "mtpaint")
+ (version (git-version "3.49.25" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjaguar/mtPaint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libungif", libungif)
+ ("libjpeg", libjpeg)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
+ ("lcms" ,lcms)
+ ("zlib", zlib)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)))
+ (arguments
+ `(#:configure-flags
+ (list
+ ;; internationalized version
+ "intl"
+ ;; install man page
+ "man")
+ ;; no check target
+ #:tests? #f))
+ (home-page "http://mtpaint.sourceforge.net/")
+ (synopsis "Create pixel art and manipulate digital images")
+ (description
+ "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed palette or 24bit RGB images, offers basic
+painting and palette manipulation tools. It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM formats.")
+ (license license:gpl3+))))
--
2.26.0
R
R
R Veera Kumar wrote on 4 Apr 2020 19:33
[PATCH v4] gnu: Add mtpaint.
(address . 40281@debbugs.gnu.org)(name . R Veera Kumar)(address . vkor@vkten.in)
20200404173325.2853-1-vkor@vkten.in
* gnu/packages/image.scm (mtpaint): New variable.
---
Changes in v4:
- Add comment explaining author git commit versioning
- Add comment for using gtk2 instead of gtk3
Changes in v3:
- Remove duplicate native-inputs entry
- Proper use of comments
- add installation of man page.
- Correct a spelling mistake in description
Changes in v2:
- Commit msg according to changelog format
- put gettext in native-inputs
---
gnu/packages/image.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 861c6cd8e7..79dee20c48 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -1979,3 +1981,56 @@ AOM, including with alpha.")
(home-page "https://github.com/AOMediaCodec/libavif")
(license (list license:bsd-2 ; libavif itself
license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+ (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+ (revision "1"))
+ (package
+ (name "mtpaint")
+ ;; author does not releases tarball neither uses git version tags
+ ;; instead author puts version in git commit title
+ (version (git-version "3.49.25" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjaguar/mtPaint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libungif", libungif)
+ ("libjpeg", libjpeg)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
+ ("lcms" ,lcms)
+ ("zlib", zlib)
+ ("glib" ,glib)
+ ;; support for gtk3 is in testing stage
+ ("gtk+" ,gtk+-2)))
+ (arguments
+ `(#:configure-flags
+ (list
+ ;; internationalized version
+ "intl"
+ ;; install man page
+ "man")
+ ;; no check target
+ #:tests? #f))
+ (home-page "http://mtpaint.sourceforge.net/")
+ (synopsis "Create pixel art and manipulate digital images")
+ (description
+ "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed palette or 24bit RGB images, offers basic
+painting and palette manipulation tools. It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM formats.")
+ (license license:gpl3+))))
--
2.26.0
D
D
Danny Milosavljevic wrote on 5 Apr 2020 19:48
(name . R Veera Kumar)(address . vkor@vkten.in)(address . 40281-done@debbugs.gnu.org)
20200405194820.0aada57a@scratchpost.org
Hi Veera,

pushed to guix master as commit 95b800e67ca9b6ca6be4f7afd74ddd70286ac852.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl6KGeQACgkQ5xo1VCww
uqVBQAf+N9is78FgWKk8APYyq/4l00iTaOc2uWLxO4pom4mZC/Pulo61QH1a/43P
SDv4PjNnb9wJ9WoicZbOTaB3flFkb8fS//F9CQgqkVGpvBpt5++aJAGTWqUiH6pm
pHpRcw89SL1uYPdYmH1OODnvsNurO16bSKIdmfHTQtM6ChUQwADcLmhSnWtmxD4d
WtqKQrV1Aw/BmqKmJUs4Yaa8O9kpBAAT57c1kWnV5sXkm+PRkbJX8FFFEI2GADcu
jECRjdyttyLqZRd1BR58Bi7fI3xB288IwKt0djx9Jm45US2mRhB4UTw7IqeV5tLf
H70W0xbDCoRs46SCiaVR40MbOP7d7A==
=hIwC
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40281@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40281
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch