murmur-configuration missing newline in config file

  • Done
  • quality assurance status badge
Details
2 participants
  • Simon Mages
  • Marius Bakke
Owner
unassigned
Submitted by
Simon Mages
Severity
normal

Debbugs page

Simon Mages wrote 5 years ago
(address . bug-guix@gnu.org)
CACxPiz296gy1-UOCESneOKmxvivTMkHZMM675Y7uUNLe0jSGLg@mail.gmail.com
Hi,

i am using guix on my server and i want to use mumble.
I found that it is working fine so far, but there is this one bug.
The config file generated is missing a newline.

The following patch fixes the issue:

Toggle diff (16 lines)
diff --git a/gnu/services/telephony.scm b/gnu/services/telephony.scm
index 0a735315b4..572fd1a051 100644
--- a/gnu/services/telephony.scm
+++ b/gnu/services/telephony.scm
@@ -182,7 +182,7 @@
"welcometext=" welcome-text "\n"
"port=" (number->string port) "\n"
(if server-password (list "serverpassword="
server-password "\n") '())
- (if max-user-bandwidth (list "bandwidth=" (number->string
max-user-bandwidth)) '())
+ (if max-user-bandwidth (list "bandwidth=" (number->string
max-user-bandwidth) "\n") '())
"users=" (number->string max-users) "\n"
"uname=" user "\n"
"database=" database-file "\n"
Marius Bakke wrote 5 years ago
87k12xrexu.fsf@devup.no
Simon Mages via Bug reports for GNU Guix <bug-guix@gnu.org> writes:

Toggle quote (8 lines)
> Hi,
>
> i am using guix on my server and i want to use mumble.
> I found that it is working fine so far, but there is this one bug.
> The config file generated is missing a newline.
>
> The following patch fixes the issue:

Nice find, applied!

PS: In the future, please send git-style patches created with 'git
format-patch' to make merging easier.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6GHJ0ACgkQoqBt8qM6
VPrcdggAgF7NDsFeg7rOZNjasApv/Dft0duxLaPqvFqN3w2J6n11v0m9Q3diovft
rdImwZO1M5yIrRFJEKjl+OgGNDgaVJqN91q1hDyfjScoJz1UMt1j7Vau5tO+6MLW
qJQhm5NyipghJ2jdh1jt+RiiFBVNG76isEgbMDkx0Ev6ndvgXDVI0KItOtL0IMTd
2AsT7XT9aa0C5Yt5p78+lQS1Hk2DYl7mvZjMlwTEXhBxkHfYz+xO9oVbq6XKPXds
WWqWWw1hxubFh9ULQKpZ24B6s8Ur6HypgAORgJExpNSA1KepT+dr1Y1IxjU0VN8s
lS9Dxsp9ePsGPGIk0akDEtJ+2u467Q==
=uhtK
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40277@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40277
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help