Simon Mages wrote 5 years ago
(address . bug-guix@gnu.org)
Hi,
i am using guix on my server and i want to use mumble.
I found that it is working fine so far, but there is this one bug.
The config file generated is missing a newline.
The following patch fixes the issue:
Toggle diff (16 lines)
diff --git a/gnu/services/telephony.scm b/gnu/services/telephony.scm
index 0a735315b4..572fd1a051 100644
--- a/gnu/services/telephony.scm
+++ b/gnu/services/telephony.scm
@@ -182,7 +182,7 @@
"welcometext=" welcome-text "\n"
"port=" (number->string port) "\n"
(if server-password (list "serverpassword="
server-password "\n") '())
- (if max-user-bandwidth (list "bandwidth=" (number->string
max-user-bandwidth)) '())
+ (if max-user-bandwidth (list "bandwidth=" (number->string
max-user-bandwidth) "\n") '())
"users=" (number->string max-users) "\n"
"uname=" user "\n"
"database=" database-file "\n"