[PATCH] gnu: Add imenu-list.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
87o8shii4m.fsf@asu.edu
Hi Guix!

Imenu-list mode provides an overview of the imenu listings for a buffer
in a split pane with configurable rules and linking built in.

Thanks,

John
From 82639ceb6aa28c9bbbdb921e27bfd9a58c358ecd Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:35:26 -0700
Subject: [PATCH] gnu: Add emacs-imenu-list.

* gnu/packages/emacs-xyz.scm (emacs-imenu-list): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5cc3334aab..fea4f6dc49 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21865,3 +21865,29 @@ conventions.")
"Use C-h, C-j, C-k and C-l to navigate between emacs windows and tmux
panes.")
(license license:expat)))
+
+(define-public emacs-imenu-list
+ (package
+ (name "emacs-imenu-list")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bmag/imenu-list")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13xh9bdl3k6ccfq83wjmkpi4269qahv4davki4wq18dr4amrzhlx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bmag/imenu-list")
+ (synopsis
+ "Automatically tracks the current buffer's imenu entries")
+ (description
+ "This Emacs minor-mode creates an automatically updated buffer called
+*Ilist* that is populated with the current buffer's imenu entries. The
+*Ilist* buffer is typically shown as a sidebar (Emacs vertically splits the
+window).")
+ (license license:gpl3+)))
--
2.26.0
John Soo wrote 5 years ago
[PATCH] gnu: Add emacs-imenu-list.
(address . 40260@debbugs.gnu.org)
87blog42n7.fsf@asu.edu
Hi Guix,

I realized my previous patch was based on previous work.

This one is cherry-picked onto master.

Thanks,

John
Toggle quote (1 lines)
>From 76cbc9f72908ebfef2d0cd00c8d8bbfe928afc06 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:35:26 -0700
Subject: [PATCH] gnu: Add emacs-imenu-list.

* gnu/packages/emacs-xyz.scm (emacs-imenu-list): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86033fd200..e2ee5029c7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21774,3 +21775,29 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-imenu-list
+ (package
+ (name "emacs-imenu-list")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bmag/imenu-list")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13xh9bdl3k6ccfq83wjmkpi4269qahv4davki4wq18dr4amrzhlx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bmag/imenu-list")
+ (synopsis
+ "Automatically tracks the current buffer's imenu entries")
+ (description
+ "This Emacs minor-mode creates an automatically updated buffer called
+*Ilist* that is populated with the current buffer's imenu entries. The
+*Ilist* buffer is typically shown as a sidebar (Emacs vertically splits the
+window).")
+ (license license:gpl3+)))
--
2.26.0
Nicolas Goaziou wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 40260-done@debbugs.gnu.org)
87zhbv38l9.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-imenu-list.
>
> * gnu/packages/emacs-xyz.scm (emacs-imenu-list): New variable.

Applied. Thank you.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40260@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40260
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help