John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
Hi Guix!
Imenu-list mode provides an overview of the imenu listings for a buffer
in a split pane with configurable rules and linking built in.
Thanks,
John
From 82639ceb6aa28c9bbbdb921e27bfd9a58c358ecd Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:35:26 -0700
Subject: [PATCH] gnu: Add emacs-imenu-list.
* gnu/packages/emacs-xyz.scm (emacs-imenu-list): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5cc3334aab..fea4f6dc49 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21865,3 +21865,29 @@ conventions.")
"Use C-h, C-j, C-k and C-l to navigate between emacs windows and tmux
panes.")
(license license:expat)))
+
+(define-public emacs-imenu-list
+ (package
+ (name "emacs-imenu-list")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bmag/imenu-list")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13xh9bdl3k6ccfq83wjmkpi4269qahv4davki4wq18dr4amrzhlx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bmag/imenu-list")
+ (synopsis
+ "Automatically tracks the current buffer's imenu entries")
+ (description
+ "This Emacs minor-mode creates an automatically updated buffer called
+*Ilist* that is populated with the current buffer's imenu entries. The
+*Ilist* buffer is typically shown as a sidebar (Emacs vertically splits the
+window).")
+ (license license:gpl3+)))
--
2.26.0