[PATCH] gnu: Add emacs-flycheck-elm.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 27 Mar 2020 22:42
(address . guix-patches@gnu.org)
87tv29iieh.fsf@asu.edu
Hi Guix,

flycheck-elm provides flycheck support for Elm.

Thanks,

John
From e8f2507b8cd298538be864604f38bbbb05d174be Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad986f1f20..b2ee94bc91 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21814,3 +21814,28 @@ conventions.")
@item Integration with elm-test
@end itemize")
(license license:gpl3+)))
+
+(define-public emacs-flycheck-elm
+ (package
+ (name "emacs-flycheck-elm")
+ (version "debd0af")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bsermons/flycheck-elm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vl0lss2n50pz5wscqj6vhjwb4hbg8xx2chh5vafsrnn0a3fryrd"))))
+ (inputs
+ `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-let-alist" ,emacs-let-alist)
+ ("emacs-seq" ,emacs-seq)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bsermons/flycheck-elm")
+ (synopsis "Flycheck support for the elm language")
+ (description "Flycheck support for the elm language.")
+ (license license:gpl2+)))
--
2.26.0
J
J
John Soo wrote on 28 Mar 2020 21:35
(address . 40258@debbugs.gnu.org)
87pncw43rc.fsf@asu.edu
Hi Guix,

I forgot my patch was applied on some other work.

This cherry-picks it on to master.

Thanks,

John
Toggle quote (1 lines)
>From 64341a1ae6717f3e178d56197cceb5022815992b Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86033fd200..f56cc16970 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21774,3 +21775,28 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-flycheck-elm
+ (package
+ (name "emacs-flycheck-elm")
+ (version "debd0af")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bsermons/flycheck-elm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vl0lss2n50pz5wscqj6vhjwb4hbg8xx2chh5vafsrnn0a3fryrd"))))
+ (inputs
+ `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-let-alist" ,emacs-let-alist)
+ ("emacs-seq" ,emacs-seq)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bsermons/flycheck-elm")
+ (synopsis "Flycheck support for the elm language")
+ (description "Flycheck support for the elm language.")
+ (license license:gpl2+)))
--
2.26.0
N
N
Nicolas Goaziou wrote on 30 Mar 2020 15:10
(name . John Soo)(address . jsoo1@asu.edu)(address . 40258@debbugs.gnu.org)
87d08u7zv5.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-flycheck-elm.
>
> * gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.

Thank you.

Toggle quote (2 lines)
> +;;; Copyright © 2020 John Soo <jsoo1@asu.edu>

You can remove this line, already applied in a previous patch.


Toggle quote (5 lines)
> +(define-public emacs-flycheck-elm
> + (package
> + (name "emacs-flycheck-elm")
> + (version "debd0af")

This is not a proper version string (not monotonic). You should bind
`commit' to "debd0af563cb6c2944367a691c7fa3021d9378c1" and `revision' to
"O" at the top of your package definition, and use

(version (git-version "0" revision commit))

Toggle quote (2 lines)
> + (commit version)))

In the case above, this should be:

(commit commit)

Toggle quote (5 lines)
> + (inputs
> + `(("emacs-flycheck" ,emacs-flycheck)
> + ("emacs-let-alist" ,emacs-let-alist)
> + ("emacs-seq" ,emacs-seq)))

I don't think you need "emacs-seq" since we build packages with Emacs
26.3, which includes "seq.el" already.

Toggle quote (5 lines)
> + (build-system emacs-build-system)
> + (home-page "https://github.com/bsermons/flycheck-elm")
> + (synopsis "Flycheck support for the elm language")
> + (description "Flycheck support for the elm language.")

Nitpick: I would use Elm.

The description needs to be a full sentence.

Toggle quote (2 lines)
> + (license license:gpl2+)))

All source code files are GPL3+, so this probably makes the project
GPL3+ licensed. LICENSE file is GPL2 (not 2+), but I would trust source
code in this case.

You may want to tell upstream about this discrepancy.

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
J
J
John Soo wrote on 30 Mar 2020 20:28
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 40258@debbugs.gnu.org)
87369pwvd6.fsf@asu.edu
Hi Nicolas,

Thanks again!

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (4 lines)
>> +;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
>
> You can remove this line, already applied in a previous patch.

I rebased on master so that should not be in this patch.


Toggle quote (17 lines)
>> +(define-public emacs-flycheck-elm
>> + (package
>> + (name "emacs-flycheck-elm")
>> + (version "debd0af")
>
> This is not a proper version string (not monotonic). You should bind
> `commit' to "debd0af563cb6c2944367a691c7fa3021d9378c1" and `revision' to
> "O" at the top of your package definition, and use
>
> (version (git-version "0" revision commit))
>
>> + (commit version)))
>
> In the case above, this should be:
>
> (commit commit)

Done, thank you! I was confused what version to use there.

Toggle quote (8 lines)
>> + (inputs
>> + `(("emacs-flycheck" ,emacs-flycheck)
>> + ("emacs-let-alist" ,emacs-let-alist)
>> + ("emacs-seq" ,emacs-seq)))
>
> I don't think you need "emacs-seq" since we build packages with Emacs
> 26.3, which includes "seq.el" already.

It builds just fine without seq, so I removed it.

Toggle quote (7 lines)
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/bsermons/flycheck-elm")
>> + (synopsis "Flycheck support for the elm language")
>> + (description "Flycheck support for the elm language.")
>
> Nitpick: I would use Elm.

Done.

Toggle quote (2 lines)
> The description needs to be a full sentence.

Done. Though there really is not much there. It might need revision.

Toggle quote (8 lines)
>> + (license license:gpl2+)))
>
> All source code files are GPL3+, so this probably makes the project
> GPL3+ licensed. LICENSE file is GPL2 (not 2+), but I would trust source
> code in this case.
>
> You may want to tell upstream about this discrepancy.

I reported the issue and put a comment over the license field.

Toggle quote (2 lines)
> Could you send an updated patch?

Updated patch attached.

Thanks so much,

John
From b3a7da54b71adaf0323a73b77c5c36983c80ada4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c029d1ed3d..f62e075e76 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21965,3 +21965,31 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-flycheck-elm
+ (let ((revision "0")
+ (commit "debd0af563cb6c2944367a691c7fa3021d9378c1"))
+ (package
+ (name "emacs-flycheck-elm")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bsermons/flycheck-elm")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vl0lss2n50pz5wscqj6vhjwb4hbg8xx2chh5vafsrnn0a3fryrd"))))
+ (inputs
+ `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-let-alist" ,emacs-let-alist)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bsermons/flycheck-elm")
+ (synopsis "Flycheck support for the Elm")
+ (description "Flycheck-elm adds flycheck support for Elm.")
+ ;; License file out of sync with source
+ ;; See https://github.com/bsermons/flycheck-elm/issues/18
+ (license license:gpl3+))))
--
2.26.0
J
J
John Soo wrote on 30 Mar 2020 23:41
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 40258@debbugs.gnu.org)
87lfnhv7v3.fsf@asu.edu
Hi Nicolas,

They fixed the license upstream already. Here I rebased on master and
changed inputs -> propagated inputs. Also I updated the commit to the
one with the correct license.

Thanks again,

John
From d1ff6af2826f0057a5e3c74b9dafcf91ea7b9524 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 74136e7efa..f97c806aab 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22039,3 +22039,28 @@ conventions.")
(description "Haskell-Snippets is a collection of YASnippet Haskell
snippets for Emacs.")
(license license:expat))))
+
+(define-public emacs-flycheck-elm
+ (let ((revision "0")
+ (commit "1b60050efd4729bfba548f3e5adbcb58436667cb"))
+ (package
+ (name "emacs-flycheck-elm")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bsermons/flycheck-elm")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kjms9d2c98ffd1qxs879qhg0n4jzic0r5kni9y4gz3v09ww8zms"))))
+ (propagated-inputs
+ `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-let-alist" ,emacs-let-alist)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bsermons/flycheck-elm")
+ (synopsis "Flycheck support for the Elm")
+ (description "Flycheck-elm adds flycheck support for Elm.")
+ (license license:gpl3+))))
--
2.26.0
N
N
Nicolas Goaziou wrote on 31 Mar 2020 00:31
(name . John Soo)(address . jsoo1@asu.edu)(address . 40258-done@debbugs.gnu.org)
87blod5vbo.fsf@nicolasgoaziou.fr
John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> They fixed the license upstream already. Here I rebased on master and
> changed inputs -> propagated inputs. Also I updated the commit to the
> one with the correct license.

Applied as 2330ef9427599315644bd316bb8169bd9f3d1664. I also moved
`build-system' part up in the package definition.

Thank you!
Closed
?