(address . guix-patches@gnu.org)
Hi
I had a discussion with rekado and guix-vits on IRC regarding which GUI
can be done and upon their suggestions i have chosen 7kaa game.
guix-vits have helped a lot with most of the package description and
with the manual provided by rekado i was able to write this package
description.
I have written sepearately as 7kaa.scm and
guix environment --ad-hoc 7kaa -L ./
and later 7kaa have run the game.
Hence i added to games.scm(assuming thats the actual location. Please
correct me) and done with the patch.
Lint have given me couple of corrections. I need your suggestions before
making the commit.
--
Regards
NagaMalli
From 09cb4f4acef66ee90f444655c8aca83b09a4a161 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Wed, 25 Mar 2020 18:59:34 +0530
Subject: [PATCH] gnu: Add 7kaa.
* gnu/packages/games.scm (7kaa): New variable.
---
gnu/packages/games.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2b03a36c43..bb24a8a653 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10319,3 +10319,39 @@ range with the objective to hit as many dummy targets as possible within
soldiers, jeeps and tanks. The gameplay is simple but it is not that easy to
get high scores.")
(license license:gpl2+)))
+
+(define-public 7kaa
+ (package
+ (name "7kaa")
+ (version "2.15.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/the3dfxdude/7kaa/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0bf90v1bm4zazwalfl9vd5dfbdcxwhi02rmggn5xc0yq0zkxwlqv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("enet" ,enet)
+ ("openal" ,openal)
+ ("gettext" ,gettext-minimal)
+ ("curl" ,curl)))
+ (home-page "https://7kfans.com/")
+ (synopsis "Seven Kingdoms Ancient Adversaries: real-time strategy game")
+ (description
+ "Seven Kingdoms, designed by Trevor Chan, brings a unique blend of
+Real-Time Strategy with the addition of trade, diplomacy, and espionage.
+The game enables players to compete against up to six other kingdoms
+allowing players to conquer opponents by defeating them in war (with
+troops or machines), capturing their buildings with spies, or offering
+opponents money for their kingdom. In 2009, Enlight Software released the
+game under the GPL license. 7kfans project is updating the game and
+provides a community for fans. A free Seven Kingdoms will help continue
+the legacy.")
+ (license license:gpl2+)))
--
2.25.1