Submission of GUI Package Description for 7kaa

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Naga Malleswari
Owner
unassigned
Submitted by
Naga Malleswari
Severity
normal
N
N
Naga Malleswari wrote on 25 Mar 2020 14:33
(address . guix-patches@gnu.org)
9b3a381f-3177-b8b2-5924-f8c05137c67b@riseup.net
Hi

I had a discussion with rekado and guix-vits on IRC regarding which GUI
can be done and upon their suggestions i have chosen 7kaa game.

guix-vits have helped a lot with most of the package description and
with the manual provided by rekado i was able to write this package
description.


I have written sepearately as 7kaa.scm and

guix environment --ad-hoc 7kaa -L ./

and later 7kaa have run the game.


Hence i added to games.scm(assuming thats the actual location. Please
correct me) and done with the patch.

Lint have given me couple of corrections. I need your suggestions before
making the commit.


--
Regards
NagaMalli
From 09cb4f4acef66ee90f444655c8aca83b09a4a161 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Wed, 25 Mar 2020 18:59:34 +0530
Subject: [PATCH] gnu: Add 7kaa.

* gnu/packages/games.scm (7kaa): New variable.
---
gnu/packages/games.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2b03a36c43..bb24a8a653 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10319,3 +10319,39 @@ range with the objective to hit as many dummy targets as possible within
soldiers, jeeps and tanks. The gameplay is simple but it is not that easy to
get high scores.")
(license license:gpl2+)))
+
+(define-public 7kaa
+ (package
+ (name "7kaa")
+ (version "2.15.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/the3dfxdude/7kaa/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0bf90v1bm4zazwalfl9vd5dfbdcxwhi02rmggn5xc0yq0zkxwlqv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("enet" ,enet)
+ ("openal" ,openal)
+ ("gettext" ,gettext-minimal)
+ ("curl" ,curl)))
+ (home-page "https://7kfans.com/")
+ (synopsis "Seven Kingdoms Ancient Adversaries: real-time strategy game")
+ (description
+ "Seven Kingdoms, designed by Trevor Chan, brings a unique blend of
+Real-Time Strategy with the addition of trade, diplomacy, and espionage.
+The game enables players to compete against up to six other kingdoms
+allowing players to conquer opponents by defeating them in war (with
+troops or machines), capturing their buildings with spies, or offering
+opponents money for their kingdom. In 2009, Enlight Software released the
+game under the GPL license. 7kfans project is updating the game and
+provides a community for fans. A free Seven Kingdoms will help continue
+the legacy.")
+ (license license:gpl2+)))
--
2.25.1
N
N
Nicolas Goaziou wrote on 25 Mar 2020 15:00
(name . Naga Malleswari)(address . nagamalli@riseup.net)
87zhc4h6vy.fsf@nicolasgoaziou.fr
Hello,

Naga Malleswari <nagamalli@riseup.net> writes:

Toggle quote (3 lines)
> Hence i added to games.scm(assuming thats the actual location. Please
> correct me) and done with the patch.

Thank you!

Toggle quote (6 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/the3dfxdude/7kaa/archive/v"
> + version ".tar.gz"))

This URL is not stable. Home page provides a stable release at:


I suggest to use this one, replacing 2.5.13 with `version', like you did.

Toggle quote (8 lines)
> + (sha256
> + (base32 "0bf90v1bm4zazwalfl9vd5dfbdcxwhi02rmggn5xc0yq0zkxwlqv"))))
> + (build-system gnu-build-system)
> + (native-inputs
> + `(("automake" ,automake)
> + ("autoconf" ,autoconf)
> + ("pkg-config" ,pkg-config)))

Could you re-order inputs alphabetically?

Toggle quote (7 lines)
> + (inputs
> + `(("sdl2" ,sdl2)
> + ("enet" ,enet)
> + ("openal" ,openal)
> + ("gettext" ,gettext-minimal)
> + ("curl" ,curl)))

Ditto.

Toggle quote (6 lines)
> + (home-page "https://7kfans.com/")
> + (synopsis "Seven Kingdoms Ancient Adversaries: real-time strategy game")
> + (description
> + "Seven Kingdoms, designed by Trevor Chan, brings a unique blend of
> +Real-Time Strategy with the addition of trade, diplomacy, and espionage.

We try to avoid adding "marketing" words or idioms in descriptions, like
"unique blend". I think "blend" is enough.

Toggle quote (4 lines)
> +7kfans project is updating the game and
> +provides a community for fans. A free Seven Kingdoms will help continue
> +the legacy.")

I suggest to drop this part, which is not informative in the
description. Besides, everything is Free in Guix.

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 25 Mar 2020 17:06
(name . Naga Malleswari)(address . nagamalli@riseup.net)
87d090h11t.fsf@nicolasgoaziou.fr
Completing myself,

Toggle quote (6 lines)
>> + (inputs
>> + `(("sdl2" ,sdl2)
>> + ("enet" ,enet)
>> + ("openal" ,openal)
>> + ("gettext" ,gettext-minimal)

gettext is a native input, you should move it in the appropriate
section.
N
N
Naga Malleswari wrote on 25 Mar 2020 21:03
Re: [bug#40221] Submission of GUI Package Description for 7kaa v2
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
82a06722-d927-b277-bff0-69c80b009089@riseup.net
Hi

I have made all the changes suggested by you in the trailing mail as
well. I had to change the hash. Please review the patch and suggest any
changes.

On 25/03/20 9:36 pm, Nicolas Goaziou wrote:
Toggle quote (10 lines)
> Completing myself,
>
>>> + (inputs
>>> + `(("sdl2" ,sdl2)
>>> + ("enet" ,enet)
>>> + ("openal" ,openal)
>>> + ("gettext" ,gettext-minimal)
> gettext is a native input, you should move it in the appropriate
> section.
>
--
Regards
NagaMalli
From ca08e2306f39655c957b9ce5081c6ec01427d95d Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Thu, 26 Mar 2020 01:30:43 +0530
Subject: [PATCH] gnu: Add 7kaa.

* gnu/packages/games.scm (7kaa): New variable.
---
gnu/packages/games.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2b03a36c43..35b362a76f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
+;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10319,3 +10320,37 @@ range with the objective to hit as many dummy targets as possible within
soldiers, jeeps and tanks. The gameplay is simple but it is not that easy to
get high scores.")
(license license:gpl2+)))
+
+(define-public 7kaa
+ (package
+ (name "7kaa")
+ (version "2.15.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/the3dfxdude/7kaa/releases/download/v"
+ version "/7kaa-" version ".tar.xz"))
+ (sha256
+ (base32 "0blj47mcsfw1sn3465j6iham8m6ki07iggnq4q8nnaqnryx710jc"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("enet" ,enet)
+ ("openal" ,openal)
+ ("sdl2" ,sdl2)))
+ (home-page "https://7kfans.com/")
+ (synopsis "Seven Kingdoms Ancient Adversaries: real-time strategy game")
+ (description
+ "Seven Kingdoms, designed by Trevor Chan, brings a blend of
+Real-Time Strategy with the addition of trade, diplomacy, and espionage.
+The game enables players to compete against up to six other kingdoms
+allowing players to conquer opponents by defeating them in war (with
+troops or machines), capturing their buildings with spies, or offering
+opponents money for their kingdom. In 2009, Enlight Software released the
+game under the GPL license.")
+ (license license:gpl2+)))
--
2.25.1
N
N
Nicolas Goaziou wrote on 26 Mar 2020 18:22
(name . Naga Malleswari)(address . nagamalli@riseup.net)
877dz7f2u9.fsf@nicolasgoaziou.fr
Hello,

Naga Malleswari <nagamalli@riseup.net> writes:
Toggle quote (5 lines)
>
> I have made all the changes suggested by you in the trailing mail as
> well. I had to change the hash. Please review the patch and suggest any
> changes.

Thank you.

I applied your patch (as db47adb0c767c373958d892411da2c89fe5503a3) with
the following changes:

- I removed dependency on autoconf and automake since, as a release, the
code is already boostrapped.

- I removed the last sentence in the description.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40221@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40221
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch