mount point is not created if mount? is #f

  • Done
  • quality assurance status badge
Details
One participant
  • maxim.cournoyer
Owner
unassigned
Submitted by
maxim.cournoyer
Severity
normal

Debbugs page

maxim.cournoyer wrote 5 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
87tv2i1uxr.fsf@raisin.i-did-not-set--mail-host-address--so-tickle-me
Consider the following file system record:

(file-system
(device "some-server:/mnt/scratch/yocto-sstate")"
(mount-point "/mnt/scratch/yocto-sstate")
(create-mount-point? #t)
(type "nfs")
(mount? #f)
(options "soft")
(flags '(no-exec)))

Even though a user would think the mount point would be created, it is
not, I'm guessing because mount? is #f.

Maxim
Maxim Cournoyer wrote 4 years ago
(address . 40158@debbugs.gnu.org)
87o8ab7li2.fsf@gmail.com
Hello,

maxim.cournoyer@gmail.com writes:

Toggle quote (16 lines)
> Consider the following file system record:
>
> (file-system
> (device "some-server:/mnt/scratch/yocto-sstate")"
> (mount-point "/mnt/scratch/yocto-sstate")
> (create-mount-point? #t)
> (type "nfs")
> (mount? #f)
> (options "soft")
> (flags '(no-exec)))
>
> Even though a user would think the mount point would be created, it is
> not, I'm guessing because mount? is #f.
>
> Maxim

I had the "chance" again today to meet this issue, so I took it by the
horns and came up with the attached patch, which fixes it:
Thanks,

Maxim
Maxim Cournoyer wrote 4 years ago
control message for bug #40158
(address . control@debbugs.gnu.org)
87tujy1wt3.fsf@gmail.com
tags 40158 + patch
quit
Maxim Cournoyer wrote 3 years ago
Re: bug#40158: mount point is not created if mount? is #f
(address . 40158-done@debbugs.gnu.org)
87mtp0rdek.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (29 lines)
> Hello,
>
> maxim.cournoyer@gmail.com writes:
>
>> Consider the following file system record:
>>
>> (file-system
>> (device "some-server:/mnt/scratch/yocto-sstate")"
>> (mount-point "/mnt/scratch/yocto-sstate")
>> (create-mount-point? #t)
>> (type "nfs")
>> (mount? #f)
>> (options "soft")
>> (flags '(no-exec)))
>>
>> Even though a user would think the mount point would be created, it is
>> not, I'm guessing because mount? is #f.
>>
>> Maxim
>
> I had the "chance" again today to meet this issue, so I took it by the
> horns and came up with the attached patch, which fixes it:
>
>
>
> Thanks,
>
> Maxim

Pushed with 8ad6624b96. Closing!

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40158@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40158
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help