mount point is not created if mount? is #f

  • Done
  • quality assurance status badge
Details
One participant
  • maxim.cournoyer
Owner
unassigned
Submitted by
maxim.cournoyer
Severity
normal
M
M
maxim.cournoyer wrote on 21 Mar 2020 00:13
(name . bug-guix)(address . bug-guix@gnu.org)
87tv2i1uxr.fsf@raisin.i-did-not-set--mail-host-address--so-tickle-me
Consider the following file system record:

(file-system
(device "some-server:/mnt/scratch/yocto-sstate")"
(mount-point "/mnt/scratch/yocto-sstate")
(create-mount-point? #t)
(type "nfs")
(mount? #f)
(options "soft")
(flags '(no-exec)))

Even though a user would think the mount point would be created, it is
not, I'm guessing because mount? is #f.

Maxim
M
M
Maxim Cournoyer wrote on 5 Aug 2021 21:13
(address . 40158@debbugs.gnu.org)
87o8ab7li2.fsf@gmail.com
Hello,

maxim.cournoyer@gmail.com writes:

Toggle quote (16 lines)
> Consider the following file system record:
>
> (file-system
> (device "some-server:/mnt/scratch/yocto-sstate")"
> (mount-point "/mnt/scratch/yocto-sstate")
> (create-mount-point? #t)
> (type "nfs")
> (mount? #f)
> (options "soft")
> (flags '(no-exec)))
>
> Even though a user would think the mount point would be created, it is
> not, I'm guessing because mount? is #f.
>
> Maxim

I had the "chance" again today to meet this issue, so I took it by the
horns and came up with the attached patch, which fixes it:
Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 9 Aug 2021 17:07
control message for bug #40158
(address . control@debbugs.gnu.org)
87tujy1wt3.fsf@gmail.com
tags 40158 + patch
quit
M
M
Maxim Cournoyer wrote on 29 Aug 2021 08:08
Re: bug#40158: mount point is not created if mount? is #f
(address . 40158-done@debbugs.gnu.org)
87mtp0rdek.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (29 lines)
> Hello,
>
> maxim.cournoyer@gmail.com writes:
>
>> Consider the following file system record:
>>
>> (file-system
>> (device "some-server:/mnt/scratch/yocto-sstate")"
>> (mount-point "/mnt/scratch/yocto-sstate")
>> (create-mount-point? #t)
>> (type "nfs")
>> (mount? #f)
>> (options "soft")
>> (flags '(no-exec)))
>>
>> Even though a user would think the mount point would be created, it is
>> not, I'm guessing because mount? is #f.
>>
>> Maxim
>
> I had the "chance" again today to meet this issue, so I took it by the
> horns and came up with the attached patch, which fixes it:
>
>
>
> Thanks,
>
> Maxim

Pushed with 8ad6624b96. Closing!

Maxim
Closed
?