[PATCH] gnu: make-libiberty: use install-file.

  • Done
  • quality assurance status badge
Details
2 participants
  • guy fleury iteriteka
  • Marius Bakke
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal

Debbugs page

guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)(name . guy fleury iteriteka)(address . gfleury@disroot.org)
20200318075457.11259-1-gfleury@disroot.org
* gnu/packages/gcc.scm(make-libiberty): In phase install use
install-file helper function to install file.
---
gnu/packages/gcc.scm | 28 ++++++++++++----------------
1 file changed, 12 insertions(+), 16 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 08afd80358..d170ae9175 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -578,22 +579,17 @@ using compilers other than GCC."
#:phases
(modify-phases %standard-phases
(add-before 'configure 'chdir
- (lambda _
- (chdir "libiberty")
- #t))
- (replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/"))
- (include (string-append out "/include/")))
- (mkdir-p lib)
- (mkdir-p include)
- (copy-file "libiberty.a"
- (string-append lib "libiberty.a"))
- (copy-file "../include/libiberty.h"
- (string-append include "libiberty.h"))
- #t))))))
+ (lambda _
+ (chdir "libiberty")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/"))
+ (include (string-append out "/include/")))
+ (install-file "libiberty.a" lib)
+ (install-file "../include/libiberty.h" include))
+ #t)))))
(inputs '())
(outputs '("out"))
(native-inputs '())
--
2.25.1
Marius Bakke wrote 5 years ago
(name . guy fleury iteriteka)(address . gfleury@disroot.org)(address . 40117-done@debbugs.gnu.org)(name . guy fleury iteriteka)(address . gfleury@disroot.org)
87imiy9axf.fsf@devup.no
guy fleury iteriteka <gfleury@disroot.org> writes:

Toggle quote (3 lines)
> * gnu/packages/gcc.scm(make-libiberty): In phase install use
> install-file helper function to install file.

Applied, thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl51AWwACgkQoqBt8qM6
VPondQf/aPmdw+oPLNqhaBtl1OsfmOyNHuf6C5XLh28gVdNhDOeq3Y8B5YYo2ppz
fjK9kKJCuQ95oXTUQHzZkXDAeKDmxxXeZAUBpC7SB8y344jh5eHRt2qYNCVL1GeT
DIkG13O2CPyVHYVV2ZLi/Ao4roC0CG+T4SCQsM3wlqBrAKlbaz+HJXFEiwGTSdC4
/WUlslu7lTZwoWMD3j/z9eiLVjFAh3nUwPFX3pFA0Cb8HRP4wfxDu+dAL5U559Jf
cqW9To/LZ+vc7CKbhmotB10x7estJLw886yye/NOgGcHmdyL5nQX0W/Da+TMG99O
QdfnZJk82UTsjnFrrO7Wm8QoK+SKlg==
=vTHA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40117@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40117
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help