Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
Hello,
I don't know if having multiple packages doing the same is OK or not.
Nor do I know if there are differences between this "wol" and the
already packaged "wakelan"...
I initially put it in networking whereas wakelen is in admin...
Anyways, I did the work, I tested it works by waking a suspended
odroidn2 SBC with it...
So here it is, tell me if it is redundant to the point of not being useful.
FTR, I packaged this because my initial guix search was with the words
wol and wakeonlan, which did not find anything relevant, whereas
searching with "wake" would have found it...
There are a few packages with WoL capability:
etherwake,
you can do it with netcat, etc...
--
Vincent Legoll
From d31a1ec3deb2ae39b5700af4592399d8a6430932 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 19:27:07 +0100
Subject: [PATCH] gnu: Add wol.
* gnu/packages/networking.scm (wol): New public variable.
---
gnu/packages/networking.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Toggle diff (32 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 48b2570d9d..a22edd634b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2866,6 +2866,25 @@ Such interfaces are useful for VPN software, virtualization, emulation,
simulation, and a number of other applications.")
(license license:gpl2)))
+(define-public wol
+ (package
+ (name "wol")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/wake-on-lan/" name "/"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08i6l5lr14mh4n3qbmx6kyx7vjqvzdnh3j9yfvgjppqik2dnq270"))))
+ (build-system gnu-build-system)
+ (home-page "https://sourceforge.net/projects/wake-on-lan/")
+ (synopsis "Implements Wake On LAN functionality in a small program")
+ (description "Tool to send a @code{magic} packet to wake another host
+on the network. This must be enabled on the target host, usually in the
+BIOS.")
+ (license license:gpl2)))
+
(define-public vde2
(package
(name "vde2")
--
2.25.1