[PATCH] gnu: Add wol.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub Kądziołka
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
CAEwRq=qY8Qgz97Y_ivHb6qrUPieD95Jw-AUqoFnwOMUQ56sVUw@mail.gmail.com
Hello,

I don't know if having multiple packages doing the same is OK or not.
Nor do I know if there are differences between this "wol" and the
already packaged "wakelan"...

I initially put it in networking whereas wakelen is in admin...

Anyways, I did the work, I tested it works by waking a suspended
odroidn2 SBC with it...

So here it is, tell me if it is redundant to the point of not being useful.

FTR, I packaged this because my initial guix search was with the words
wol and wakeonlan, which did not find anything relevant, whereas
searching with "wake" would have found it...

There are a few packages with WoL capability:

etherwake,

you can do it with netcat, etc...

--
Vincent Legoll
From d31a1ec3deb2ae39b5700af4592399d8a6430932 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 19:27:07 +0100
Subject: [PATCH] gnu: Add wol.

* gnu/packages/networking.scm (wol): New public variable.
---
gnu/packages/networking.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 48b2570d9d..a22edd634b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2866,6 +2866,25 @@ Such interfaces are useful for VPN software, virtualization, emulation,
simulation, and a number of other applications.")
(license license:gpl2)))
+(define-public wol
+ (package
+ (name "wol")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/wake-on-lan/" name "/"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08i6l5lr14mh4n3qbmx6kyx7vjqvzdnh3j9yfvgjppqik2dnq270"))))
+ (build-system gnu-build-system)
+ (home-page "https://sourceforge.net/projects/wake-on-lan/")
+ (synopsis "Implements Wake On LAN functionality in a small program")
+ (description "Tool to send a @code{magic} packet to wake another host
+on the network. This must be enabled on the target host, usually in the
+BIOS.")
+ (license license:gpl2)))
+
(define-public vde2
(package
(name "vde2")
--
2.25.1
Jakub Kądziołka wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . guix-patches@gnu.org)
20200319125527.diyj7squla4jfhv2@gravity
On Tue, Mar 17, 2020 at 04:04:51PM +0100, Vincent Legoll wrote:
Toggle quote (4 lines)
> I don't know if having multiple packages doing the same is OK or not.
> Nor do I know if there are differences between this "wol" and the
> already packaged "wakelan"...

I don't think having multiple packages for doing something is
necessarily bad.

Toggle quote (4 lines)
> + (description "Tool to send a @code{magic} packet to wake another host
> +on the network. This must be enabled on the target host, usually in the
> +BIOS.")

If I may ask, what's the rationale behind putting "magic" in a @code tag
here?

Apart from that, LGTM.

Regards,
Jakub Kądziołka
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl5za7kACgkQ4xWnWEYT
FWTe1g/8DE342g7uML0CPcHjeoM80xzc2VZdKwaUMJfEA4rO2D0eD7qkTEl23cK7
BwP5h3FmC0hWU8OyEGi926nkqOcry3oP/wCiI945Yrq8MA915+MwDAwwcwrmi2/T
ffPnQ2d9nyaedK1e0SSJRtZZkeyLqXiJrAPHr3KGwbqflJenhCbfmdY+/Gr1HKTD
dgu1aERsd5PUFat2fSwxdPaYV9oSVlCD3PaOKZlas6a5AdsH1igU5iI+bkj2vpLD
yo9AJDVnHKE2ng/I4RQqiq3L7n7Kc7E3UX9IkEVFfdNjYA44B7H0jpx8KoaBYCAB
1aZtL2U/wC3EhedXCyQbPs8Dae+gXE4Hi0faYND6fHB8J9guCTk2c2lS5Ut2LXkH
WQgr5MfCHVPPPk3JPTrCWI9hKySF+GwTdcPAJfgS2oRn3mvtp62qllzc56/mJOg4
9I3ry8ZnudB/9JEsbe2BBfFn6L7B4YbINLrbn/uuYH8t26nKdyuTiTXydK182tod
XrQf6fEivu4lmOffgw68Vj6zQr7H8ysiyEWRMDQ2VIHrCD4fYNAmOrccVPCx4Jcr
7ZDxuEhNcHl0aku6cym0PFdmVdl5GHh8Q15grfRgHuR2vK+fQnaQT+44t2uoIok7
k0F07YUq+D7zRqaZlhr4AQXvdBDFgzG4J/Hu2kWSVieC4YYr4PA=
=lLFR
-----END PGP SIGNATURE-----


Vincent Legoll wrote 5 years ago
(name . Jakub Kądziołka)(address . kuba@kadziolka.net)(address . guix-patches@gnu.org)
CAEwRq=rtcoaKA5PYNyiZrMKdLhOGc3SWUwCjKWvD-oo=sQqqWg@mail.gmail.com
hello,

On Thu, Mar 19, 2020 at 1:55 PM Jakub Kądziołka <kuba@kadziolka.net> wrote:
Toggle quote (8 lines)
> On Tue, Mar 17, 2020 at 04:04:51PM +0100, Vincent Legoll wrote:
> > I don't know if having multiple packages doing the same is OK or not.
> > Nor do I know if there are differences between this "wol" and the
> > already packaged "wakelan"...
>
> I don't think having multiple packages for doing something is
> necessarily bad.

Yep, me too, but I think I'll refrain from doing the other WoL packages...

Toggle quote (7 lines)
> > + (description "Tool to send a @code{magic} packet to wake another host
> > +on the network. This must be enabled on the target host, usually in the
> > +BIOS.")
>
> If I may ask, what's the rationale behind putting "magic" in a @code tag
> here?

I think I copied that desc from somewhere else (maybe nixos) and it had quoting
around, and then guix lint told me to use @code instead, I probably should just
have removed the quotes... Nothing more than that, you can remove them if
you want to commit, or if you want I can resubmit without...

--
Vincent Legoll
Jakub Kądziołka wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 40105-done@debbugs.gnu.org)
20200328230935.7tqjyjazm55pv3fr@gravity
On Thu, Mar 19, 2020 at 03:57:42PM +0100, Vincent Legoll wrote:
Toggle quote (12 lines)
> > > + (description "Tool to send a @code{magic} packet to wake another host
> > > +on the network. This must be enabled on the target host, usually in the
> > > +BIOS.")
> >
> > If I may ask, what's the rationale behind putting "magic" in a @code tag
> > here?
>
> I think I copied that desc from somewhere else (maybe nixos) and it had quoting
> around, and then guix lint told me to use @code instead, I probably should just
> have removed the quotes... Nothing more than that, you can remove them if
> you want to commit, or if you want I can resubmit without...

Sorry for taking a while to respond on this, but I pushed your patch as
commit 62b9ad19e3a6638f8e077753454fdf08ba586146 with two changes:
Firstly, I removed the @code tag as you suggested. Secondly, I removed
the references to `name' in the URL, since, as the contributing
guidelines suggest, the URL likely won't be valid if the name gets
changed.

Cheers!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl5/2S8ACgkQ4xWnWEYT
FWS3sxAA3gKo63wWJq5O8Cgm4Pfak3U3VmDzmSPt1bZywnfjcckMmrf79MQQbEap
NDqbP2qU0u3VrK4NyghiaDLuJ3oeTO/G8WQZZ2KyyuaxYsG2vPRBPpx4Sn+SDjnp
MOuvSJtBFbWE+X6W+Mq1EdqhcsOWQWVoqlYoxyvQplSjNQFogBq1T+9BOrBZa405
nQPlpVNWyyi8UtLMG6cx9cUdkGPMz/qsWVo3Y/wKu4k3YtlLTvdXTHuUyNGibC6k
WNxiZjws4FbH336jG1AO3ixBTQ3jhgU1l1npwU40YL/YSgeDcn4Z/0VUjVimQHDS
CBR+1z2dpghWqZMo07vlJwcQhDsWakLzxWXptB7D93mL6TO/iY0YsyVmyLjn1R/v
vARMOA2VHFumi9RTOzVnJ0WUqVlBR3x7ztcuSbNnV0O8N0ayWDOpTC1WXstXtHzH
WiA5x9SLGW9qZV+bsSeIV8zPq5V4y0VzQeMi/qCAu0T30IIqHiwWs3TR7tL7TwHq
g80kU1q18x7mfOwMeihK8PD12xll0tj2+NQoNgEg9X+rnlI59cGHm5lNtgHa/btL
DvIwnILvJDQKHDxQsy3FQ9V6QADi/m7awSL3uJqXON1dl7fKoYZOhJbJy9bPZUZF
6y1psWd8RYet4idy7BO3RQEWbXq+tibhe2tPiZf53HMUnsl1aGo=
=Lt+m
-----END PGP SIGNATURE-----


Closed
Vincent Legoll wrote 5 years ago
(name . Jakub Kądziołka)(address . kuba@kadziolka.net)(address . 40105-done@debbugs.gnu.org)
CAEwRq=pmbvDpHR7d2oV-WF26aAP3VVbfF2zNpX26Pw-W3SDG5Q@mail.gmail.com
Hello Jakub,

On Sun, Mar 29, 2020 at 12:09 AM Jakub Kądziołka <kuba@kadziolka.net> wrote:
Toggle quote (7 lines)
> Sorry for taking a while to respond on this, but I pushed your patch as
> commit 62b9ad19e3a6638f8e077753454fdf08ba586146 with two changes:
> Firstly, I removed the @code tag as you suggested. Secondly, I removed
> the references to `name' in the URL, since, as the contributing
> guidelines suggest, the URL likely won't be valid if the name gets
> changed.

OK, no problem with taking time, and thanks for the fixes, I'll try to remember
doing those myself for the next patches.

Tchuss

--
Vincent Legoll
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40105@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40105
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help