[PATCH 1/1] gnu: Add emacs-org-static-blog.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Jack Hill
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
Merged with
B
B
Brice Waegeneire wrote on 17 Mar 2020 15:12
(address . guix-patches@gnu.org)
20200317141253.25851-2-brice@waegenei.re
* gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d45814379b..dfcf283283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21806,3 +21807,28 @@ All entries in a specified TODO state will be carried over to the next day.")
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
conversion program}, a Japanese input method on Emacs.")
(license license:gpl2+))))
+
+(define-public emacs-org-static-blog
+ (package
+ (name "emacs-org-static-blog")
+ (version "20200117.800")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/org-static-blog-"
+ version ".el"))
+ (sha256
+ (base32
+ "0k1p43pvjvfzgqigybizg9pr8r7sqapbv18vhfg9smik09sjh0gd"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/bastibe/org-static-blog")
+ (synopsis
+ "Simple org-mode based static blog generator")
+ (description
+ "Org-static-blog is one more static blog generator, it focuses on being
+simple. All files are simple org-mode files in a directory. The only
+requirement is that every org file must have a #+TITLE and a #+DATE, and
+optionally, #+FILETAGS.")
+ (license license:bsd-3)))
--
2.25.0
B
B
Brice Waegeneire wrote on 17 Mar 2020 15:16
merge 40103 40104
(address . control@debbugs.gnu.org)
e1e7e6a2bf9a605d6770afb13c03a28d@waegenei.re
merge 40103 40104
N
N
Nicolas Goaziou wrote on 17 Mar 2020 16:07
Re: [bug#40104] [PATCH 1/1] gnu: Add emacs-org-static-blog.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 40104@debbugs.gnu.org)
87sgi7t3xt.fsf@nicolasgoaziou.fr
Hello,

Brice Waegeneire <brice@waegenei.re> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.

Thank you.

Toggle quote (5 lines)
> +(define-public emacs-org-static-blog
> + (package
> + (name "emacs-org-static-blog")
> + (version "20200117.800")

Could you explain in a comment why using an unstable release is
required?

Toggle quote (7 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://melpa.org/packages/org-static-blog-"
> + version ".el"))

It seems upstream is at Github, not MELPA. Could you use Github instead?

Toggle quote (5 lines)
> + (home-page
> + "https://github.com/bastibe/org-static-blog")
> + (synopsis
> + "Simple org-mode based static blog generator")

Nitpick: Simple Org mode based static blog generator

Toggle quote (4 lines)
> + (description
> + "Org-static-blog is one more static blog generator, it focuses on being
> +simple. All files are simple org-mode files in a directory.

Nitpick: All file are simple Org files in a directory.

Toggle quote (4 lines)
> The only
> +requirement is that every org file must have a #+TITLE and a #+DATE, and
> +optionally, #+FILETAGS.")

Nitpick: every Org file must have a @samp{title} and a @samp{date}
keywords, and optionally, a @samp{filetags} keyword.

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
B
B
Brice Waegeneire wrote on 18 Mar 2020 09:24
[PATCH v2] gnu: Add emacs-org-static-blog.
(address . 40104@debbugs.gnu.org)
20200318082443.25193-1-brice@waegenei.re
* gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d45814379b..e09eb4a19f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21806,3 +21807,30 @@ All entries in a specified TODO state will be carried over to the next day.")
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
conversion program}, a Japanese input method on Emacs.")
(license license:gpl2+))))
+
+(define-public emacs-org-static-blog
+ ;; Use the latest commit as the last release only contains half of the
+ ;; current total commits.
+ (package
+ (name "emacs-org-static-blog")
+ (version "20200117")
+ (home-page "https://github.com/bastibe/org-static-blog")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "5c19300d7634e94ae813b1b66abc716fbb1e5fc9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m7vmibjc6yk2npfrnnqd3g2099300r0q8mr8cvyivmk5ailbfrh"))))
+ (build-system emacs-build-system)
+ (synopsis
+ "Simple Org mode based static blog generator")
+ (description
+ "@code{emacs-org-static-blog} is one more static blog generator, it focuses on being
+simple. All file are simple Org files in a directory. The only requirement
+is that every Org file must have a @samp{title} and a @samp{date} keywords,
+and optionally, a @samp{filetags} keyword.")
+ (license license:bsd-3)))
--
2.25.0
B
B
Brice Waegeneire wrote on 18 Mar 2020 09:26
Re: [bug#40104] [PATCH 1/1] gnu: Add emacs-org-static-blog.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
64c029ab13977fff2c527f1aec183746@waegenei.re
On 2020-03-17 15:07, Nicolas Goaziou wrote:
Toggle quote (51 lines)
> Hello,
>
> Brice Waegeneire <brice@waegenei.re> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
>
> Thank you.
>
>> +(define-public emacs-org-static-blog
>> + (package
>> + (name "emacs-org-static-blog")
>> + (version "20200117.800")
>
> Could you explain in a comment why using an unstable release is
> required?
>
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://melpa.org/packages/org-static-blog-"
>> + version ".el"))
>
> It seems upstream is at Github, not MELPA. Could you use Github
> instead?
>
>> + (home-page
>> + "https://github.com/bastibe/org-static-blog")
>> + (synopsis
>> + "Simple org-mode based static blog generator")
>
> Nitpick: Simple Org mode based static blog generator
>
>> + (description
>> + "Org-static-blog is one more static blog generator, it focuses on
>> being
>> +simple. All files are simple org-mode files in a directory.
>
> Nitpick: All file are simple Org files in a directory.
>
>> The only
>> +requirement is that every org file must have a #+TITLE and a #+DATE,
>> and
>> +optionally, #+FILETAGS.")
>
> Nitpick: every Org file must have a @samp{title} and a @samp{date}
> keywords, and optionally, a @samp{filetags} keyword.
>
> Could you send an updated patch?
>
> Regards,
V2 send with all your suggestions added. And I have requested a new
N
N
Nicolas Goaziou wrote on 18 Mar 2020 12:28
(name . Brice Waegeneire)(address . brice@waegenei.re)
87o8stgawt.fsf@nicolasgoaziou.fr
Hello,

Brice Waegeneire <brice@waegenei.re> writes:

Toggle quote (3 lines)
> V2 send with all your suggestions added. And I have requested a new
> release upstream: https://github.com/bastibe/org-static-blog/issues/50

Great! Applied as 382ba7bad59ec7205cd883bb93b5e6cf33329d66.

Thank you.

Regards,

--
Nicolas Goaziou
Closed
J
J
Jack Hill wrote on 18 Mar 2020 18:15
Re: [bug#40104] [PATCH v2] gnu: Add emacs-org-static-blog.
(name . Brice Waegeneire)(address . brice@waegenei.re)
alpine.DEB.2.20.2003181313020.19733@marsh.hcoop.net
I know this was already merged, but I found an additional nit-pick/typo:

On Wed, 18 Mar 2020, Brice Waegeneire wrote:

Toggle quote (4 lines)
> + (description
> + "@code{emacs-org-static-blog} is one more static blog generator, it focuses on being
> +simple. All file are simple Org files in a directory. The only requirement

I believe it should read, "All files are simple Org files…". Note the lack
of s on the first instance of file.

Hopefully you don't mind me pointing out such a small thing.

All the best,
Jack
N
N
Nicolas Goaziou wrote on 18 Mar 2020 21:51
(name . Jack Hill)(address . jackhill@jackhill.us)
87h7yle69y.fsf@nicolasgoaziou.fr
Hello,

Jack Hill <jackhill@jackhill.us> writes:

Toggle quote (5 lines)
> I believe it should read, "All files are simple Org files…". Note the
> lack of s on the first instance of file.
>
> Hopefully you don't mind me pointing out such a small thing.

Not at all!

Fixed. Thank you.

Regards,

--
Nicolas Goaziou
?