Ekaitz Zarraga wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hi,
Added TopiconsRedux because it's the only System Tray Icon
Manager I managed to work in our current GNOME version.
gnome-shell-extension-appindicator doesn't support clicks
or menus on the System Tray, TopiconsRedux does.
Best,
Ekaitz
From c0d51f07042aca537d4f550e2c5e9ed2fcbb6292 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 17 Mar 2020 13:54:24 +0100
Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux
---
gnu/packages/gnome-xyz.scm | 48 ++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)
Toggle diff (73 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..3c8b1f667b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (guix build-system copy)
#:use-module (guix build-system meson)
#:use-module (guix git-download)
+ #:use-module (guix download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages base)
@@ -146,6 +148,52 @@ GNOME Shell.")
(home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
(license license:gpl2+)))
+(define-public gnome-shell-extension-topicons-redux
+ (package
+ (name "gnome-shell-extension-topicons-redux")
+ (version "6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://gitlab.com/pop-planet/TopIcons-Redux/-/archive/"
+ version "/TopIcons-Redux-" version ".tar.gz"))
+ (sha256
+ (base32 "0diwb6l4wy4dwpwkls4cq8v0dbi99q194jfl39sv7f7mnbjjgi82"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make"
+ "install"
+ (string-append
+ "INSTALL_PATH="
+ out
+ "/share/gnome-shell/extensions"))))))))
+
+ (home-page
+ "https://gitlab.com/pop-planet/TopIcons-Redux/-/tree/master")
+ (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
+Rewritten fork of TopIcons Plus.")
+ (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the
+backround.")
+ (license license:gpl2)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")
--
2.25.1