[PATCH] gnu packages gnome-xyz: Add topicons-redux

  • Done
  • quality assurance status badge
Details
3 participants
  • Ekaitz Zarraga
  • Leo Prikler
  • Marius Bakke
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal

Debbugs page

Ekaitz Zarraga wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
WNl-uAnWv9HyoL-xUnV0R1ZU3zoY1F-w-OPkdYIOeXx4ULUDqP2iK-X5iMMjX0MdSLBLqOr0GZEamO2wVoWmWzU0OaQzdH8DP7Xg9h1G-as=@elenq.tech
Hi,
Added TopiconsRedux because it's the only System Tray Icon
Manager I managed to work in our current GNOME version.

gnome-shell-extension-appindicator doesn't support clicks
or menus on the System Tray, TopiconsRedux does.

Best,
Ekaitz


From c0d51f07042aca537d4f550e2c5e9ed2fcbb6292 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 17 Mar 2020 13:54:24 +0100
Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

---
gnu/packages/gnome-xyz.scm | 48 ++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..3c8b1f667b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (guix build-system copy)
#:use-module (guix build-system meson)
#:use-module (guix git-download)
+ #:use-module (guix download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages base)
@@ -146,6 +148,52 @@ GNOME Shell.")
(home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
(license license:gpl2+)))

+(define-public gnome-shell-extension-topicons-redux
+ (package
+ (name "gnome-shell-extension-topicons-redux")
+ (version "6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://gitlab.com/pop-planet/TopIcons-Redux/-/archive/"
+ version "/TopIcons-Redux-" version ".tar.gz"))
+ (sha256
+ (base32 "0diwb6l4wy4dwpwkls4cq8v0dbi99q194jfl39sv7f7mnbjjgi82"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make"
+ "install"
+ (string-append
+ "INSTALL_PATH="
+ out
+ "/share/gnome-shell/extensions"))))))))
+
+ (home-page
+ "https://gitlab.com/pop-planet/TopIcons-Redux/-/tree/master")
+ (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
+Rewritten fork of TopIcons Plus.")
+ (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the
+backround.")
+ (license license:gpl2)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")
--
2.25.1
Leo Prikler wrote 5 years ago
(address . ekaitz@elenq.tech)(address . 40102@debbugs.gnu.org)
c874c96768e6c1a8b814e3e63771cd35dbebd961.camel@student.tugraz.at
Hi Ekaitz,
Toggle quote (2 lines)
> + (home-page
> + "https://gitlab.com/pop-planet/TopIcons-Redux/-/tree/master";)
You should probably drop "-/tree/master" and uncomment the bracket.
Otherwise LGTM.

Regards,
Leo
Ekaitz Zarraga wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(name . 40102@debbugs.gnu.org)(address . 40102@debbugs.gnu.org)
jxwfI4XONO2CyyrY3UJHHq8_WLo74QEA_j4O2AqjC-dTnXe6ViWiIJctAJjvMY8n_doI8hoDerTJ98kip7GyJ47tXi_XMEdtegymVZfGlSc=@elenq.tech
Toggle quote (13 lines)
> Hi Ekaitz,
>
> > - (home-page
> > - "https://gitlab.com/pop-planet/TopIcons-Redux/-/tree/master";)
> >
> >
>
> You should probably drop "-/tree/master" and uncomment the bracket.
> Otherwise LGTM.
>
> Regards,
> Leo

The comment was accidentally introduced in the email. I don't really know how tbh.

Thanks for the comment, here's the updated patch:



From 4bbe7c5061a04d07ad9b85ff63d32379f34f8dc8 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 17 Mar 2020 13:54:24 +0100
Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

---
gnu/packages/gnome-xyz.scm | 48 ++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..abb8dab4f7 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (guix build-system copy)
#:use-module (guix build-system meson)
#:use-module (guix git-download)
+ #:use-module (guix download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages base)
@@ -146,6 +148,52 @@ GNOME Shell.")
(home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
(license license:gpl2+)))

+(define-public gnome-shell-extension-topicons-redux
+ (package
+ (name "gnome-shell-extension-topicons-redux")
+ (version "6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://gitlab.com/pop-planet/TopIcons-Redux/-/archive/"
+ version "/TopIcons-Redux-" version ".tar.gz"))
+ (sha256
+ (base32 "0diwb6l4wy4dwpwkls4cq8v0dbi99q194jfl39sv7f7mnbjjgi82"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make"
+ "install"
+ (string-append
+ "INSTALL_PATH="
+ out
+ "/share/gnome-shell/extensions"))))))))
+
+ (home-page
+ "https://gitlab.com/pop-planet/TopIcons-Redux/")
+ (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
+Rewritten fork of TopIcons Plus.")
+ (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the
+backround.")
+ (license license:gpl2)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")
--
2.25.1
Marius Bakke wrote 5 years ago
(name . 40102@debbugs.gnu.org)(address . 40102@debbugs.gnu.org)
87fte29al1.fsf@devup.no
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Toggle quote (5 lines)
> From 4bbe7c5061a04d07ad9b85ff63d32379f34f8dc8 Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Tue, 17 Mar 2020 13:54:24 +0100
> Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

[...]

Toggle quote (12 lines)
> +(define-public gnome-shell-extension-topicons-redux
> + (package
> + (name "gnome-shell-extension-topicons-redux")
> + (version "6")
> + (source
> + (origin
> + (method url-fetch)
> + (uri
> + (string-append
> + "https://gitlab.com/pop-planet/TopIcons-Redux/-/archive/"
> + version "/TopIcons-Redux-" version ".tar.gz"))

Such "autogenerated" tarballs from GitLab and GitHub are prone to
getting re-created with different time stamps, breaking the checksum.
Can you adjust this package to use git-fetch instead of url-fetch?

[...]

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f

Why are tests disabled? Please leave a comment.

Toggle quote (15 lines)
> + #:phases
> + (modify-phases
> + %standard-phases
> + (delete 'configure)
> + (delete 'build)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + (invoke "make"
> + "install"
> + (string-append
> + "INSTALL_PATH="
> + out
> + "/share/gnome-shell/extensions"))))))))

Indentation is off here. If you are not using Emacs there is a script
that can help with indentation, see "Formatting Code" in the Guix manual.

Toggle quote (4 lines)
> +
> + (home-page
> + "https://gitlab.com/pop-planet/TopIcons-Redux/")

The line break here is not necessary.

Toggle quote (3 lines)
> + (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
> +Rewritten fork of TopIcons Plus.")

Please keep synopsis to single sentences. The second sentence can be
removed IMO.

Toggle quote (8 lines)
> + (description "Many applications, such as chat clients, downloaders, and
> +some media players, are meant to run long-term in the background even after you
> +close their window. These applications remain accessible by adding an icon to
> +the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
> +3.26. TopIcons Redux brings those icons back into the top panel so that it's
> +easier to keep track of apps running in the
> +backround.")

'guix lint gnome-shell-extension-topicons-redux' will warn that
sentences should be separated by two spaces. Can you adjust accordingly?

Toggle quote (2 lines)
> + (license license:gpl2)))

Is the license really GPL2 only? Unless the source code says explicitly
"GPL2 only", this should probably be "gpl2+", i.e. "GPL2 or any later
version".

Can you send an updated patch?

TIA!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl51AyoACgkQoqBt8qM6
VPoqlwgAjT5FYe67FuxcA5308hVSLv2kyN2G7wwIrhl/E6wxBQNlmcoGKUSR1Ydn
52mxp/Rt5iLXfZeHMM2uv+GbtaelV62Xww+2GKhaynqzOn1SA6WdrFMkIN4nV/84
dZHBxKfz4joGJENGttn8/QHzYSacEbcjLlqcp3u4ag6eiBlqVrIkWiPvFIDUFJP9
IE/SYTZbPjQrQ8acGZIN7LPVcnn5ETSSFE8PGawaqTyLaSqLCqSC1zO4WU7wxHKS
VWhcx7CTAOitvutMJVMTdmgB4vzzddC5+znpS0fTcimawAH3Vrhiop4Q9ubrVtDe
0FqRQwmNQ+Fs3lSxV8U+asxo0887fA==
=ap6b
-----END PGP SIGNATURE-----

Ekaitz Zarraga wrote 5 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
AfbWxtOJaB86st91o0f6zA6uMBnHbUrirJKdjFVApSxoTaCVAkcmXNpB7rA1ChnAJ-3cC59q9xvWwVgrXxKao3onz-iE8wPzOSbOOhy1imc=@elenq.tech
Hi all,

Thanks Marius for the feedback.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Friday, March 20, 2020 5:53 PM, Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (4 lines)
> Such "autogenerated" tarballs from GitLab and GitHub are prone to
> getting re-created with different time stamps, breaking the checksum.
> Can you adjust this package to use git-fetch instead of url-fetch?

I wasn't aware of that! Thank you very much.


Toggle quote (2 lines)
> Why are tests disabled? Please leave a comment.

Project doesn't have any test.


Toggle quote (3 lines)
> Indentation is off here. If you are not using Emacs there is a script
> that can help with indentation, see "Formatting Code" in the Guix manual.

I'm using Vim with Vim paredit and it's own Sheme filetype, but it doesn't
work very well sometimes.


Toggle quote (3 lines)
>
> The line break here is not necessary.

Solved

Toggle quote (7 lines)
> > - (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
> > +Rewritten fork of TopIcons Plus.")
> >
>
> Please keep synopsis to single sentences. The second sentence can be
> removed IMO.

Done.

Toggle quote (3 lines)
> 'guix lint gnome-shell-extension-topicons-redux' will warn that
> sentences should be separated by two spaces. Can you adjust accordingly?

Done.

Toggle quote (6 lines)
> > - (license license:gpl2)))
>
> Is the license really GPL2 only? Unless the source code says explicitly
> "GPL2 only", this should probably be "gpl2+", i.e. "GPL2 or any later
> version".

Done.

Toggle quote (4 lines)
>
> Can you send an updated patch?
>

Here it comes:


From e62251601732587409c18dfe3af0cd56ecf39d5f Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 17 Mar 2020 13:54:24 +0100
Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

---
gnu/packages/gnome-xyz.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..39579bbea4 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -146,6 +147,48 @@ GNOME Shell.")
(home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
(license license:gpl2+)))

+(define-public gnome-shell-extension-topicons-redux
+ (package
+ (name "gnome-shell-extension-topicons-redux")
+ (version "6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/pop-planet/TopIcons-Redux.git")
+ (commit version)))
+ (sha256
+ (base32 "1dli9xb545n3xlj6q4wl0y5gzkm903zs47p8fiq71pdvbr6v38rj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")))
+ (arguments
+ `(#:tests? #f ; No test defined in the project
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make"
+ "install"
+ (string-append
+ "INSTALL_PATH="
+ out
+ "/share/gnome-shell/extensions"))))))))
+
+ (home-page "https://gitlab.com/pop-planet/TopIcons-Redux/")
+ (synopsis "Displays legacy tray icons in the GNOME Shell top panel.")
+ (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the backround.")
+ (license license:gpl2+)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")
--
2.25.1
Marius Bakke wrote 5 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87y2rt5x7b.fsf@devup.no
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Toggle quote (6 lines)
>> Indentation is off here. If you are not using Emacs there is a script
>> that can help with indentation, see "Formatting Code" in the Guix manual.
>
> I'm using Vim with Vim paredit and it's own Sheme filetype, but it doesn't
> work very well sometimes.

In that case, please run ./etc/indent-code.el before submitting
patches to lessen the burden on committers. I've fixed the indentation
locally by running C-M-q in Emacs.

Toggle quote (6 lines)
>>
>> Can you send an updated patch?
>>
>
> Here it comes:

Thanks! Please add it as an attachment next time so the commit message
is preserved (or send the whole patch directly with 'git send-email').

Also, './pre-inst-env guix lint gnome-shell-extension-topicons-redux'
reported these issues:

gnu/packages/gnome-xyz.scm:155:5: gnome-shell-extension-topicons-redux@6: the source file name should contain the package name
gnu/packages/gnome-xyz.scm:181:14: gnome-shell-extension-topicons-redux@6: no period allowed at the end of the synopsis

I've fixed these locally too, sorry for missing them in the first
review.

Finally I edited the commit message so it follows our conventions.
Pushed in e7c7912573111d5e86f3e3012a6edab948f7b302.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl52aakACgkQoqBt8qM6
VPrerAgArH0SVw+wCQOo+OUbieRcPuzcIXsHJlhcBZR1aPCVF4D9dB3kGJhYkq1Q
m7SHr2syQo33UYUiP2LMmeDAenFK+WCITTkWdKihQ8xc9t+morT3IcM9NK1RSP7C
e5sdzgZAkZ4Fasu7h9Ja6fCQG8bnOj2F4sjKtXWti0lj0s9LsnvDKvLSHUhbrY3F
9krw8VsNzCgQSzdoYjl8Suq0BTzJMAY9J+GEFeTjrU4fPgIJ2zURnJOZ02azCFgy
ndM7GlSQ4/mSYmHWho4rGpaAcweuXH3NRj1M0rZdYC5NwPCgZf/MBO29rg/Gt3wv
ocPe0cQvK28uiEiHmz/+bxD/j6Q4iQ==
=VO69
-----END PGP SIGNATURE-----

Closed
Ekaitz Zarraga wrote 5 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
RQ3FX1HxfCGM5mJMU4vEBpiWlVprthT02Aas4i0qnq0XdizAtN0nlH95Z3fHiceMf2gz_NS3kIMWWEORXcv08MviZGd13LTk2BwhQI3lhj0=@elenq.tech
Toggle quote (4 lines)
> I've fixed these locally too, sorry for missing them in the first
> review.
> ...

Sorry for all the work I gave you.
I'll do it better next time. Promise!

Thanks for your time.

Best,
Ekaitz
Closed
Marius Bakke wrote 5 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87v9mx5whu.fsf@devup.no
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Toggle quote (7 lines)
>> I've fixed these locally too, sorry for missing them in the first
>> review.
>> ...
>
> Sorry for all the work I gave you.
> I'll do it better next time. Promise!

No worries! It takes a while to get the hang of these things. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl52bT0ACgkQoqBt8qM6
VPrPygf/Q3inc6Ci2cR1zfbLSN8sgDEo7w3/zOi2DWXWec81s0EF5GqzNzxdiamD
rqj6jChWOkISrjlzV2nCpKbis7j2DEKZjPSLGwEmw4wNyf0LBCtS7fTJ9PLnY1+Q
bGA9+6UdllHxaV7TRzFjux8qOLH9niaryOAeuKPxYBkQ6/Q+4ZJ0ubOeb3uk85/q
72J+UtAt07X1CTqbI8lD+a4mu+SZw55ojwkh70pM6ye3iO3zm/3ctzb4jWPMEUPU
f/QC7dSi2ZvMx5ItwB/4wYPXkycuj8AQYPfoqtMpSju9q7E4u2fh2PIYWWoCNMXo
2v2lIjo2f79LrEwR2yGerTnUN15pJg==
=wKGH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40102@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40102
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help