[PATCH] gnu: Add ghcid.

  • Done
  • quality assurance status badge
Details
2 participants
  • brown121407
  • Marius Bakke
Owner
unassigned
Submitted by
brown121407
Severity
normal
B
B
brown121407 wrote on 13 Mar 2020 07:17
(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@member.fsf.org)
20200313061755.1853-1-brown121407@posteo.ro
From: Alexandru-Sergiu Marton <brown121407@member.fsf.org>

* gnu/packages/haskell-apps.scm (ghcid): New variable.
---
gnu/packages/haskell-apps.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 6005816260..58552666f1 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -266,6 +266,40 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
@end enumerate")
(license license:gpl2)))
+(define-public ghcid
+ (package
+ (name "ghcid")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/ghcid/" ;
+ "ghcid-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b8a8mx6z2ridw79gijjv90b2jgk0qrncvg0sjbmvyyyajx1h5f7"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-extra" ,ghc-extra)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-cmdargs" ,ghc-cmdargs)
+ ("ghc-fsnotify" ,ghc-fsnotify)
+ ("ghc-terminal-size" ,ghc-terminal-size)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page
+ "https://github.com/ndmitchell/ghcid#readme")
+ (synopsis "GHCi based bare bones IDE")
+ (description
+ "Either \"GHCi as a daemon\" or \"GHC + a bit of an IDE\". A very simple Haskell
+development tool which shows you the errors in your project and updates them whenever
+you save. Run @code{ghcid --topmost --command=ghci}, where @code{--topmost} makes the
+window on top of all others (Windows only) and @code{--command} is the command to start
+GHCi on your project (defaults to @code{ghci} if you have a @file{.ghci} file, or else
+to @code{cabal repl}).")
+ (license license:bsd-3)))
+
(define-public git-annex
(package
(name "git-annex")
--
2.25.1
M
M
Marius Bakke wrote on 20 Mar 2020 19:41
(name . Alexandru-Sergiu Marton)(address . brown121407@member.fsf.org)
87sgi27ttb.fsf@devup.no
brown121407@posteo.ro writes:

Toggle quote (2 lines)
> * gnu/packages/haskell-apps.scm (ghcid): New variable.

This was pushed in eea58169fb519c392ff3ba4a1ad5730e3be9ff39, closing!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl51DlEACgkQoqBt8qM6
VPpwYQgAsIZs6CzNVx0qDoAZEsMMaBNDVkFM3wC4kI/ppzDlcBujuADeU8YM14CV
CYTLBBlmQTE9EEwNW33ll994/CvDuaKpa2o81lEW6ZsSo2iDGtYPIwdL00ULCm+M
q+QHwfqXw6/0v00gqZjPAbDUquUJBBFIzPm9Uk2iNeaK5fZVKUULCx1vUqFCXStL
xzQ3+H6MuQk+tWNdb2s9/Jb0KwGS8r+vSgp216z74eYZcwUduNuRxJfOXnv3jGCG
SCd8zIAE9ywpeqiwzpzypwEG/eXRSBxZx3iXiUKMin+SqposUuuxzHv/EYBCG9hm
Z0ZSOXWV+jUCDhLflzWBUbXeVhNYgw==
=vUkd
-----END PGP SIGNATURE-----

Closed
?