Add barrage game

  • Done
  • quality assurance status badge
Details
3 participants
  • Alberto EFG
  • Nicolas Goaziou
  • Vincent Legoll
Owner
unassigned
Submitted by
Alberto EFG
Severity
normal

Debbugs page

Alberto EFG wrote 5 years ago
Add barrage game
(address . guix-patches@gnu.org)
87r1xwj1ft.fsf@posteo.mx
Hello.

My second patch, I tried to avoid the same mistakes of the last one.
Everything seems to work.
guix size is around 800 MB

Please let me know of any mistakes I made :)
From 74e954b5ef5caee3634be2067f32541a0f05c294 Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Wed, 11 Mar 2020 21:50:14 -0600
Subject: [PATCH] gnu: Add barrage.

* gnu/packages/games.scm (barrage): New variable.
---
gnu/packages/games.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 322e309591..7581a429f8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10157,3 +10158,34 @@ best human chess grandmasters. It can be used with UCI-compatible GUIs like
ChessX.")
(home-page "https://stockfishchess.org/")
(license license:gpl3+)))
+
+(define-public barrage
+ (package
+ (name "barrage")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/lgames/barrage/"
+ "barrage-" version ".tar.gz"))
+ (sha256
+ (base32 "0139wxyrir10cbkvkjn548xgmp84wax8mfwk80yxbxlcdamrg257"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("sdl" ,sdl)
+ ("sdl-mixer" ,sdl-mixer)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)))
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "CFLAGS="
+ "-I" (assoc-ref %build-inputs "sdl-mixer")
+ "/include/SDL"))))
+ (home-page "http://lgames.sourceforge.net/Barrage/")
+ (synopsis "Violent point-and-click shooting game with nice effects")
+ (description "Barrage is a rather destructive action game that
+ puts you on a shooting range with the objective to hit as many dummy
+ targets as possible within 3 minutes. You control a gun that may either
+ fire small or large grenades at soldiers, jeeps and tanks.
+ Targets are fast pace.")
+ (license license:gpl2+)))
--
2.25.1
Nicolas Goaziou wrote 5 years ago
Re: [bug#40048] Add barrage game
(name . Alberto EFG)(address . albertoefg@posteo.mx)(address . 40048@debbugs.gnu.org)
871rpwyod7.fsf@nicolasgoaziou.fr
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

Toggle quote (4 lines)
> My second patch, I tried to avoid the same mistakes of the last one.
> Everything seems to work.
> guix size is around 800 MB

I applied the patch with the changes below:

Toggle quote (5 lines)
> + (inputs
> + `(("sdl" ,sdl)
> + ("sdl-mixer" ,sdl-mixer)
> + ("hicolor-icon-theme" ,hicolor-icon-theme)))

I re-ordered inputs alphabetically.

Toggle quote (7 lines)
> + (synopsis "Violent point-and-click shooting game with nice effects")
> + (description "Barrage is a rather destructive action game that
> + puts you on a shooting range with the objective to hit as many dummy
> + targets as possible within 3 minutes. You control a gun that may either
> + fire small or large grenades at soldiers, jeeps and tanks.
> + Targets are fast pace.")

The last sentence seemed to be cut off. I changed the ending according
to upstream REAMDE.

Thank you!

Regards,

--
Nicolas Goaziou
Vincent Legoll wrote 5 years ago
(address . 40048@debbugs.gnu.org)
1e0dd382-412f-1a04-837f-0b4478233a75@gmail.com
Hello,

I think this issue should be closed

WDYT ?
Nicolas Goaziou wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
875ze3xr9b.fsf@nicolasgoaziou.fr
Hello,

Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (4 lines)
> I think this issue should be closed
>
> WDYT ?

You are right. I forgot to do it. Thanks for the heads up.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40048@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40048
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help