[PATCH] gnu: Add r-hrbrthemes.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 5 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20200311165317.16647-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-hrbrthemes): New variable.
---
gnu/packages/cran.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8cc904612d..80df37121e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2020 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
@@ -20752,3 +20752,38 @@ containing elevation data.")
calculate the higher-order partial and semi-partial correlations but also with
statistics and p-values of the correlation coefficients.")
(license license:gpl2)))
+
+(define-public r-hrbrthemes
+ (package
+ (name "r-hrbrthemes")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hrbrthemes" version))
+ (sha256
+ (base32 "057h60b5p53dcyjyfwlgjc1ry968s9s64dw78p443w8717zk7zpc"))))
+ (properties `((upstream-name . "hrbrthemes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-extrafont" ,r-extrafont)
+ ("r-gdtools" ,r-gdtools)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-scales" ,r-scales)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/hrbrmstr/hrbrthemes/")
+ (synopsis
+ "Additional themes, theme components and utilities for @code{r-ggplot2}")
+ (description
+ "This package provides a compilation of extra @code{r-ggplot2} themes,
+ scales and utilities, including a spell check function for plot label fields
+ and an overall emphasis on typography.")
+ (license license:expat)))
+ ;;MIT + separated license file
+ ;;https://github.com/hrbrmstr/hrbrthemes/blob/master/LICENSE
--
2.24.1
Ricardo Wurmus wrote 5 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 40027-done@debbugs.gnu.org)
87zhcmn7dl.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-hrbrthemes): New variable.

Pushed with commit 10c2ca9e4a.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40027@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40027
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help