Add "xa" assembler

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Leo Famulari
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 5 years ago
(address . guix-patches@gnu.org)
87mu8mswg8.fsf@dustycloud.org
Hello! New patch, new patch. It's been a while for me.

This is for the 6502 "xa" assembler. It's necessary for use with the
"vice" emulator, which I've been also trying to package, but is also
useful standalone.
From f9a241faa405bb695b4e13175722014f8a291410 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 11 Mar 2020 11:14:59 -0400
Subject: [PATCH] gnu: Add xa.

* gnu/packages/assembly.scm (xa): New variable.
---
gnu/packages/assembly.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 1ad49baf8e..ec1ed50b2d 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2019 Andy Tai <atai@atai.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,3 +343,32 @@ Supported architectures are:
@item spc700
@end itemize")
(license license:gpl2)))
+
+(define-public xa
+ (package
+ (name "xa")
+ (version "2.3.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.floodgap.com/retrotech/xa"
+ "/dists/xa-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y5sd247g11jfk5msxy91hz2nhpy7smj125dzfyfhjsjnqk5nyw6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; TODO: custom test harness, not sure how it works
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no "configure" script
+ #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (native-inputs `(("perl" ,perl)))
+ (home-page "https://www.floodgap.com/retrotech/xa/")
+ (synopsis "High-speed, two-pass portable cross-assembler")
+ (description
+ "xa is a high-speed, two-pass portable cross-assembler.
+It understands mnemonics and generates code for NMOS 6502s (such
+as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...),
+ CMOS 6502s (65C02 and Rockwell R65C02) and the 65816.")
+ (license license:gpl2)))
--
2.25.1
Leo Famulari wrote 5 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 40026@debbugs.gnu.org)
20200311184240.GA26593@jasmine.lan
On Wed, Mar 11, 2020 at 12:11:35PM -0400, Christopher Lemmer Webber wrote:
Toggle quote (2 lines)
> Hello! New patch, new patch. It's been a while for me.

Good to see you around again!

Toggle quote (4 lines)
> This is for the 6502 "xa" assembler. It's necessary for use with the
> "vice" emulator, which I've been also trying to package, but is also
> useful standalone.

Cool!
Toggle quote (4 lines)
> + "/dists/xa-" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))

I don't think this file-name procedure is necessary. The tarball should
be named properly without it, right?

Toggle quote (4 lines)
> + (synopsis "High-speed, two-pass portable cross-assembler")
> + (description
> + "xa is a high-speed, two-pass portable cross-assembler.

We can omit "high-speed" here; it's basically "marketing language" which
is discouraged in our packaging guidelines.

Otherwise, please push!
Christopher Lemmer Webber wrote 5 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 40026@debbugs.gnu.org)
87lfo6so0q.fsf@dustycloud.org
Leo Famulari writes:

Toggle quote (17 lines)
> On Wed, Mar 11, 2020 at 12:11:35PM -0400, Christopher Lemmer Webber wrote:
>> Hello! New patch, new patch. It's been a while for me.
>
> Good to see you around again!
>
>> This is for the 6502 "xa" assembler. It's necessary for use with the
>> "vice" emulator, which I've been also trying to package, but is also
>> useful standalone.
>
> Cool!
>> + (uri (string-append "https://www.floodgap.com/retrotech/xa"
>> + "/dists/xa-" version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>
> I don't think this file-name procedure is necessary. The tarball should
> be named properly without it, right?

Oh you're right. Can you tell I'm brushing off the rust with some
copy-pasta? :)

Toggle quote (7 lines)
>> + (synopsis "High-speed, two-pass portable cross-assembler")
>> + (description
>> + "xa is a high-speed, two-pass portable cross-assembler.
>
> We can omit "high-speed" here; it's basically "marketing language" which
> is discouraged in our packaging guidelines.

Good call.

Toggle quote (2 lines)
> Otherwise, please push!

Done! It's good to be back!
Christopher Lemmer Webber wrote 5 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 40026-done@debbugs.gnu.org)
87imjasmmd.fsf@dustycloud.org
Forgot to send to close it out!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40026@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40026
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help