[PATCH] gnu: ppp: Update to 2.4.8-1.8d45443bb

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
CAEwRq=og0b7zPVVxxLAuhtt8JN329-F7HC7Zy22S+WK37Emwog@mail.gmail.com
This is an update of ppp, following the release of patches for CVE-2020-8597.


--
Vincent Legoll
From da876e04f6ff2f423131e2c8a7f5f7993c4b13c8 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 7 Mar 2020 14:01:34 +0100
Subject: [PATCH] gnu: ppp: Update to 2.4.8-1.8d45443bb

gnu/packages/samba.scm (ppp): Update to 2.4.8-1.8d45443bb
---
gnu/packages/samba.scm | 87 ++++++++++++++++++++++--------------------
1 file changed, 45 insertions(+), 42 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 4eef7de5d7..fbf63c58b9 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -421,47 +421,50 @@ key-value pair databases and a real LDAP database.")
(license lgpl3+)))
(define-public ppp
- (package
- (name "ppp")
- (version "2.4.8")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/paulusmack/ppp")
- (commit (string-append "ppp-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1i88m79h6g3fzsb4yw3k8bq1grsx3hsyawm7id2vcaab0gfqzjjv"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no check target
- #:make-flags '("CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-Makefile
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))
- (openssl (assoc-ref inputs "openssl"))
- (libpcap (assoc-ref inputs "libpcap")))
- (substitute* "pppd/Makefile.linux"
- (("/usr/include/crypt\\.h")
- (string-append libc "/include/crypt.h"))
- (("/usr/include/openssl")
- (string-append openssl "/include/openssl"))
- (("/usr/include/pcap-bpf.h")
- (string-append libpcap "/include/pcap-bpf.h")))
- #t))))))
- (inputs
- `(("libpcap" ,libpcap)
- ("openssl" ,(@ (gnu packages tls) openssl))))
- (synopsis "Implementation of the Point-to-Point Protocol")
- (home-page "https://ppp.samba.org/")
- (description
- "The Point-to-Point Protocol (PPP) provides a standard way to establish
+ (let ((revision "1")
+ (commit "8d45443bb5c9372b4c6a362ba2f443d41c5636af"))
+ (package
+ (name "ppp")
+ (version (string-append "2.4.8-" revision "." (string-take commit 9)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/paulusmack/ppp")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "06cf8fb84l3h2zy5da4j7k2j1qjv2gfqn986sf43xgj75605aks2"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-Makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc"))
+ (openssl (assoc-ref inputs "openssl"))
+ (libpcap (assoc-ref inputs "libpcap")))
+ (substitute* "pppd/Makefile.linux"
+ (("/usr/include/crypt\\.h")
+ (string-append libc "/include/crypt.h"))
+ (("/usr/include/openssl")
+ (string-append openssl "/include/openssl"))
+ (("/usr/include/pcap-bpf.h")
+ (string-append libpcap "/include/pcap-bpf.h")))
+ #t))))))
+ (inputs
+ `(("libpcap" ,libpcap)
+ ("openssl" ,(@ (gnu packages tls) openssl))))
+ (synopsis "Implementation of the Point-to-Point Protocol")
+ (home-page "https://ppp.samba.org/")
+ (description
+ "The Point-to-Point Protocol (PPP) provides a standard way to establish
a network connection over a serial link. At present, this package supports IP
and IPV6 and the protocols layered above them, such as TCP and UDP.")
- ;; pppd, pppstats and pppdump are under BSD-style notices.
- ;; some of the pppd plugins are GPL'd.
- ;; chat is public domain.
- (license (list bsd-3 bsd-4 gpl2+ public-domain))))
+ ;; pppd, pppstats and pppdump are under BSD-style notices.
+ ;; some of the pppd plugins are GPL'd.
+ ;; chat is public domain.
+ (license (list bsd-3 bsd-4 gpl2+ public-domain)))))
+
--
2.25.1
Tobias Geerinckx-Rice wrote 5 years ago
(address . 39973-done@debbugs.gnu.org)
87y2sc70g5.fsf@nckx
Vincent Legoll 写道:
Toggle quote (5 lines)
> This is an update of ppp, following the release of patches for
> CVE-2020-8597.
>
> https://www.kb.cert.org/vuls/id/782301/

Adapted to use GIT-VERSION & -FILE-NAME and pushed as
4c8b874f95b4de2648bb9adee64bf002772321f2.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl5jovoACgkQ2Imw8BjF
STzIWA//XSD49668vuC1yacsb8uLIAha2b99+z1o4rFRBeObZoAGqWvOVT+2IX6q
zE4C/owP9bffyLnhJGsvbcxs5ym4NdXdJq/J2Z0VpwSjNE3rGtsA0th06uTMwllT
hvx+cQfhUWN+SBJeGdY0ZqEnnFvMMurr9ZYPufGyu7Kt2XYaDVkaZ6lkfJUvSwLW
ZEHHKXzAT2xruAw561XdCZ0y2IPV5BG9kOm57qqt++ZSAWhVUO5iqdnYF5Ehk99s
RgyPnXh+OhdgLzEs7F/ooGdNaxkNiCdInRBmqGdF54sUutdJVw7WYY0BpP7dSqT7
Qj4kLUKrFizCy7k7CparVjsGQxz9zPW7tBAEnWr9gu5O0HhA1e463wQmAY4fnNPl
SCOFZrOSZs9x49sfLLbGZrL2Xb8O6yBSsw+ZIrSBbezxmiXLGbVkD0OtQg2dt1JE
GyAwXRfHsYHwKkYbabWZd6MiA6Z5RxrpA/rPXBLm8wEX+tUYArC164R0wfdq5VPC
0Pg0nJl4EI55uTncJHuZozewfyuBBwBK/Bn7UUwgPD0vRTbEP90csP0gqoVfK8gB
GUnxMTNOO2c/lzzVeOqolLSt9q+ZnL343jqHWyyr99lz8PjcMDVsj/C6TGuZhgRG
vi44jVTw75DfPQ8/ft+g3VqcI6Edo0RYbZha5+JAgacjAVWf3ng=
=ug1q
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39973@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39973
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help