[Common Lisp] asdf-build-system/source should refer to dependencies in the store

  • Open
  • quality assurance status badge
Details
One participant
  • Pierre Neidhardt
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 4 Mar 2020 09:12
(address . bug-guix@gnu.org)
8736aoczdq.fsf@ambrevar.xyz
The sbcl build system generates a new .asd that refers to all the
required input explicitly in the store.

The asdf-build-system/source does not do that. Because of this,
installing the source packages in a profile does not work as expected:
loading the source in a Common Lisp REPL will fail, complaining about
missing dependencies.

I suggest we use an .asd generation similar to that of the SBCL build system.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl5fYuEACgkQm9z0l6S7
zH9T2gf+I3kdjNdxBYcZJaPfzlFM3EVvZinECyiFLbeoNC50dUe3Jgro612qfpKc
+BLRLWlXlfYGX1nERGGTse75/UUPpjPVjcD2lQ/LtJ2exlk6W+RohKRMhkTgvbWg
2+2jGo0MFvrs4LeqRjiguBjEfE6QcOpZyqnTLfejKRvnsKpc6ss626v9s810G6Lc
AlDvghIb42KTW+rvcUbVPWF+FGXjHqBhH0fpO4a1zVfsI48nYh3IO6L0NIz+qPRI
zZrZPwuPB/mVScrFzZLeNq+73DTG8nREaoNQ7vm/quOXCZppUIQIIgpi/nah2mTJ
d17rRy/eLkpJC3lSs8YDH7fkKXr4NQ==
=Ku23
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 7 May 2020 19:11
(address . 39894@debbugs.gnu.org)
871rnvvff3.fsf@ambrevar.xyz
I made a mistaken in the original post: the cl-* (source) packages do
propagate their input. So source packages _do_ work as expected.

What we'd like to do improve here is _not_ propagate the inputs and
instead refer directly to them in the store.

I tried generating and .asd which would do the following

Toggle snippet (6 lines)
(asdf:load-asd ORIGINAL-ASD)

(push INPUT-PATH-TO-SOURCE asdf:*central-registry*)
; more push of all inputs here.

The problem is that we can't name the .asd like the original or ASDF
will complain about circular dependencies.

The only way I can think about is to add the "push" lines to the
original .asd itself (at the end should be fine). Not sure how I feel
about modifying the original .asd, seems brittle.

There may be a better way.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl60QTAACgkQm9z0l6S7
zH8yEAf/TK/6Y2BBBPpb6DDWJubncS3NqRCTtXruz6CjcYeK/b/C+KILk8jpB5jl
WrUxI76bZJuG7jYcY7bnZOhMZjH5nFZwKIUGh5mGgRGKgc958BMPd4bonTZIUv51
V/1n9VsvTu03SKmWQmOhGtsqOSXy4BnycVbcPgs85v8Sh2su5OyYTrH+6zvopIyO
W51CGEM7JLnrdM64K00oBBYr5+5nNXYhh2y0mtr4bnIsl6WvtMHcQ7rHO1N2Ca8x
A6vtGF6y1UeRQg9ZX7r4BqN08oDAavSEomIGl3SKEZ1vf34rUJboiCWyNS+q4LbW
DWsqBobH68nnIQ0tE3rWAbjD4OCXDQ==
=uzf9
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 39894@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39894
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch