[PATCH 0/2] Update the Guix Data Service package, and tweak the service

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
87k143eqm7.fsf@cbaines.net
Bump the revision used for the guix-data-service, and move to using
Guile 3 rather than 2. Also make it possible to pass options more easily
through the service.

Christopher Baines (2):
gnu: guix-data-service: Update to 0.0.1-18.18eb9df.
services: guix-data-service: Allow passing extra options.

doc/guix.texi | 6 ++++++
gnu/packages/web.scm | 18 +++++++++---------
gnu/services/guix.scm | 15 +++++++++++----
3 files changed, 26 insertions(+), 13 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl5cIsBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xecbg/+NMSNc/e3gjkMrKormqSsGsEiE9uXhIGFGrehBPlOx9/3XOta/9fKsCJ2
gfggnudmijtYgysiFv2ROXSPB4Om6N8O8Z5sq0KvRY3Gi+TnyCwkL/c79fYsek6j
9d04cv2T52Uu3KdEKcp6NjQ1bTL42rvTWfQsWvMZjzcPcd5l2IfFwXU1A45xrB03
j+hE9FIOGBLD89wX3G8wm7YMbZjfEZV6VrisW8upI6KoSvyhboZ8EnnmYeYA9mHg
3EZxldFvSrvlQM8uz8WQd1hBd9Sumqqaz2XTEUqI8GSWjwDLpoCncg/oT796xCaM
9GwqgtXJZsLRuYKNT6RA5MGndQhTrbktyN+IvW8W7y+DwAC18lIm/TzH4pzfpJyw
/h5Zz9NgJF0mxFIflMR1jHom/YLUuwGi1ypLWuczplvjZh9G7+u+VrU7ENxBPSxM
fu3nG1gNKkQ+Crrb3EV/eDTiazC9QCh6l7hFHQubfcjzpyDW08y/7ZTGGkUyf/0S
ZWpfsWDEdbhvpWsiNKlXdKNW9t00M8wdVrEA4ZAQoDAeQvAhkmfzprywx5YY6Tbq
/8reyrJXgKJPO8yfsAFykEyuy4QjyQlvA87LSl2ARxS55lWhH8LF4e4I3IQ4TZIz
YpbM7lxgKbgNHX5uSaRmsBWrLlE4ZqaHRX2bxI0T7z9zFviI3LU=
=96BM
-----END PGP SIGNATURE-----

Christopher Baines wrote 5 years ago
[PATCH 2/2] services: guix-data-service: Allow passing extra options.
(address . 39864@debbugs.gnu.org)
20200301211331.21163-2-mail@cbaines.net
This is so that the options supported by the service configuration don't have
to always be changed. Generally though all options should be explicitly
supported and documented, so this is mostly to facilitate experimentation.

* gnu/services/guix.scm (<guix-data-service-configuration>): Add extra-options
and extra-process-jobs-options to the record type.
(guix-data-service-shepherd-services): Handle these new configuration record
fields.
* doc/guix.texi (Guix Data Service): Document these new options.
---
doc/guix.texi | 6 ++++++
gnu/services/guix.scm | 15 +++++++++++----
2 files changed, 17 insertions(+), 4 deletions(-)

Toggle diff (66 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index fab9159530..80ba8a488e 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -25245,6 +25245,12 @@ If set, this is the @code{getmail-retriever-configuration} object with
which to configure getmail to fetch mail from the guix-commits mailing
list.
+@item @code{extra-options} (default: @var{'()})
+Extra command line options for @code{guix-data-service}.
+
+@item @code{extra-process-jobs-options} (default: @var{'()})
+Extra command line options for @code{guix-data-service-process-jobs}.
+
@end table
@end deftp
diff --git a/gnu/services/guix.scm b/gnu/services/guix.scm
index 0f0fad39b0..10a8581a62 100644
--- a/gnu/services/guix.scm
+++ b/gnu/services/guix.scm
@@ -68,7 +68,12 @@
(default #f))
(commits-getmail-retriever-configuration
guix-data-service-commits-getmail-retriever-configuration
- (default #f)))
+ (default #f))
+ (extra-options guix-data-service-extra-options
+ (default '()))
+ (extra-process-jobs-options
+ guix-data-service-extra-process-jobs-options
+ (default '())))
(define (guix-data-service-profile-packages config)
"Return the guix-data-service package, this will populate the
@@ -78,7 +83,7 @@ ca-certificates.crt file in the system profile."
(define (guix-data-service-shepherd-services config)
(match-record config <guix-data-service-configuration>
- (package user group port host)
+ (package user group port host extra-options extra-process-jobs-options)
(list
(shepherd-service
(documentation "Guix Data Service web server")
@@ -92,7 +97,8 @@ ca-certificates.crt file in the system profile."
#$(string-append "--host=" host)
;; Perform any database migrations when the
;; service is started
- "--update-database")
+ "--update-database"
+ #$@extra-options)
#:user #$user
#:group #$group
@@ -117,7 +123,8 @@ ca-certificates.crt file in the system profile."
(start #~(make-forkexec-constructor
(list
#$(file-append package
- "/bin/guix-data-service-process-jobs"))
+ "/bin/guix-data-service-process-jobs")
+ #$@extra-process-jobs-options)
#:user #$user
#:group #$group
#:environment-variables
--
2.25.0
Christopher Baines wrote 5 years ago
[PATCH 1/2] gnu: guix-data-service: Update to 0.0.1-18.18eb9df.
(address . 39864@debbugs.gnu.org)
20200301211331.21163-1-mail@cbaines.net
* gnu/packages/web.scm (guix-data-service): Update to 0.0.1-18.18eb9df.
(inputs, native-inputs): Switch to using the Guile 3 package variants where
applicable.
---
gnu/packages/web.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c6e59cff44..6a9cdc79b8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4390,8 +4390,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "bf25a8db0278b49ef2149c69ef5d6dd2201fd413")
- (revision "17"))
+ (let ((commit "18eb9dfdcb3174bfd4bab5b9089acffa13aa1214")
+ (revision "18"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4403,7 +4403,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "0s6faybczdn10zwrkn22nfq5lvf538513hbmjfaqlkhfmwc4s1qd"))))
+ "0lb78cqzqaz0r4sspg272w2a3yhzhqah30j0kxf0z182b0qpmp37"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -4452,15 +4452,15 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
#t)))
(delete 'strip)))) ; As the .go files aren't compatible
(inputs
- `(("guix" ,guix)
- ("guile-fibers" ,guile-fibers)
- ("guile-json" ,guile-json-3)
- ("guile-email" ,guile-email)
- ("guile-squee" ,guile-squee)
+ `(("guix" ,guile3.0-guix)
+ ("guile-fibers" ,guile3.0-fibers)
+ ("guile-json" ,guile3.0-json)
+ ("guile-email" ,guile3.0-email)
+ ("guile-squee" ,guile3.0-squee)
("postgresql" ,postgresql)
("sqitch" ,sqitch)))
(native-inputs
- `(("guile" ,guile-2.2)
+ `(("guile" ,guile-3.0)
("autoconf" ,autoconf)
("automake" ,automake)
("ephemeralpg" ,ephemeralpg)
--
2.25.0
Ludovic Courtès wrote 5 years ago
Re: [bug#39864] [PATCH 0/2] Update the Guix Data Service package, and tweak the service
(name . Christopher Baines)(address . mail@cbaines.net)(address . 39864@debbugs.gnu.org)
87h7yzeua7.fsf@gnu.org
Hullo,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (8 lines)
> Bump the revision used for the guix-data-service, and move to using
> Guile 3 rather than 2. Also make it possible to pass options more easily
> through the service.
>
> Christopher Baines (2):
> gnu: guix-data-service: Update to 0.0.1-18.18eb9df.
> services: guix-data-service: Allow passing extra options.

Both LGTM. Thank you!

Ludo’.
Christopher Baines wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 39864-done@debbugs.gnu.org)
87a74qe7l1.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Hullo,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Bump the revision used for the guix-data-service, and move to using
>> Guile 3 rather than 2. Also make it possible to pass options more easily
>> through the service.
>>
>> Christopher Baines (2):
>> gnu: guix-data-service: Update to 0.0.1-18.18eb9df.
>> services: guix-data-service: Allow passing extra options.
>
> Both LGTM. Thank you!

Great, I've pushed these changes now :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl5lgxpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeyIRAAsTKUE0PKADt7tjMKF0IsL78zZRp98UCbeXw8qyOWn7fqMb7gOFq10FjH
g2DHyS9Urig22F9QXSBnp3XQcRa93gL9NaMFGOV7ysiRYJ5Dbc5GpKPBlngi2GD8
aerWqMXDzT+1xtQCVEbPH7FX6An7jHVUOiDQsHulokzYAzLxZdy4N1XoVYkcEGKb
03pAxvCaavdS9xufcTnGMiLY7a48q8cKd1Hje16viLnZXc+oHPNyKpjkuVI+Nqka
PtymAh7TpvQ6GiFFCXwWWG3Ajd44c0HoAZJcl4dDxFDnmT+3EDdZpn9sA5q44BAN
GMhld/WpLmErhtAyGdpIq/8gwUeyWySM28+PrjI0tewtgB5+CTJAqoC2ArSIrtJs
FpajwBSCwlvGrV+5ts4lumUk2ncysnHP0m0FW7MGqyYCHGQL1UdUfY/V6qXmyMxh
kSaP1a0p3mCIseNi/qB8bJFeX18BLUKpQEQ5byDAyv9e4RZTcUL5zCM+5FdvQjur
6YBMaRCTmv/UHRjlO+J4f+NIOMm1SPAxLSB9ASUyDV43v62ueOpulvLfcEyWCLzo
Ign0xshaGc+nh8uqtJA/5Rz6jjdpC29MXt1aio9Icd12vwTpFIOnV4xOh527hiZG
MYu9xVLRWweSIfkneQz5Cdti50Yw1yrVKXpRiqgovFVrWN4jeFg=
=sDS5
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39864@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39864
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help