[PATCH] gnu: ccache: Update to 3.7.7.

  • Done
  • quality assurance status badge
Details
3 participants
  • Eric Bavier
  • Ludovic Courtès
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
CAEwRq=peNMiFf5rzKPUDhNFnz27Uko-0t2f=Wmc33qxaPree2w@mail.gmail.com
lightly tested: cache hits on trivial .c file compilation

Additions to native inputs: asciidoc autoconf gperf
Trivial ./etc/indent-code.el housekeeping

More infos from ccache news:
2016-06-06: Source code and bug tracker moved to github
2019-04-03: Web site moved to ccache.dev

--
Vincent Legoll
From 9718baa06727eb515030cf7b617a10e9fab8052a Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 1 Mar 2020 17:59:10 +0100
Subject: [PATCH] gnu: ccache: Update to 3.7.7.

* gnu/packages/ccache.scm (ccache): Update to 3.7.7.
* gnu/packages/ccache.scm (ccache): Update source to github
* gnu/packages/ccache.scm (ccache): Update home-page to ccache.dev
* gnu/packages/ccache.scm (ccache): Add native inputs: asciidoc autoconf gperf
* gnu/packages/ccache.scm (ccache): Reindent arguments
---
gnu/packages/ccache.scm | 33 +++++++++++++++++++++------------
1 file changed, 21 insertions(+), 12 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index b3f0cbbd95..55d03daf21 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,35 +22,43 @@
(define-module (gnu packages ccache)
#:use-module (guix packages)
#:use-module ((guix licenses) #:select (gpl3+))
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages gperf)
#:use-module (gnu packages perl)
#:use-module (gnu packages compression))
(define-public ccache
(package
(name "ccache")
- (version "3.6")
+ (version "3.7.7")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
- version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccache/ccache.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "07wv75xdcxpdkfsz9h5ffrm8pjbvr1dh6wnb02nyzz18cdbjkcd6"))))
+ (base32 "1s8mq832chk95wa5qwaalralwv3ln1m931nrgd9a4gi19lg55zln"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
+ ("asciidoc" ,asciidoc)
+ ("autoconf" ,autoconf)
+ ("gperf" ,gperf)
("which" ,(@ (gnu packages base) which))))
(inputs `(("zlib" ,zlib)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'setup-tests
- (lambda _
- (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
- (("#!/bin/sh") (string-append "#!" (which "sh"))))
- #t)))))
- (home-page "https://ccache.samba.org/")
+ (add-before 'check 'setup-tests
+ (lambda _
+ (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ #t)))))
+ (home-page "https://ccache.dev/")
(synopsis "Compiler cache")
(description
"Ccache is a compiler cache. It speeds up recompilation by caching
--
2.25.1
Eric Bavier wrote 5 years ago
(address . 39858@debbugs.gnu.org)
4651422f198af7325b5621b4402eb875@posteo.net
Hi Vincent, thanks for the patch, some comments below:

On 01.03.2020 11:48, Vincent Legoll wrote:
Toggle quote (2 lines)
> lightly tested: cache hits on trivial .c file compilation

And the tests still pass ;)

Toggle quote (2 lines)
> Trivial ./etc/indent-code.el housekeeping

Could you move this to a separate patch, please?

Toggle quote (12 lines)
> From 9718baa06727eb515030cf7b617a10e9fab8052a Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@gmail.com>
> Date: Sun, 1 Mar 2020 17:59:10 +0100
> Subject: [PATCH] gnu: ccache: Update to 3.7.7.
>
> * gnu/packages/ccache.scm (ccache): Update to 3.7.7.
> * gnu/packages/ccache.scm (ccache): Update source to github
> * gnu/packages/ccache.scm (ccache): Update home-page to ccache.dev
> * gnu/packages/ccache.scm (ccache): Add native inputs: asciidoc
> autoconf gperf
> * gnu/packages/ccache.scm (ccache): Reindent arguments

Check the manual and other commit messages for formatting. In
particular, the file name only needs to be mentioned once, and the
affected sections are mentioned in square brackets before the comment.

Toggle quote (17 lines)
> ---
> gnu/packages/ccache.scm | 33 +++++++++++++++++++++------------
> 1 file changed, 21 insertions(+), 12 deletions(-)
> ...
> - (method url-fetch)
> - (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
> - version ".tar.xz"))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ccache/ccache.git")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> (sha256
> - (base32 "07wv75xdcxpdkfsz9h5ffrm8pjbvr1dh6wnb02nyzz18cdbjkcd6"))))
> + (base32 "1s8mq832chk95wa5qwaalralwv3ln1m931nrgd9a4gi19lg55zln"))))
> (build-system gnu-build-system)

I think we can actually stick with the tarball available on the github
release page:
which is already bootstrapped.

Toggle quote (5 lines)
> (native-inputs `(("perl" ,perl) ; for test/run
> + ("asciidoc" ,asciidoc)
> + ("autoconf" ,autoconf)
> + ("gperf" ,gperf)

Using the distribution tarball should prevent needing to add these
inputs.

Toggle quote (3 lines)
> (description
> "Ccache is a compiler cache. It speeds up recompilation by caching

It seems based on the release notes that we also need to remove the
mention of Fortran 77 support in the description.

Could you send updated patches?

Cheers,
`~Eric
Vincent Legoll wrote 5 years ago
(name . Eric Bavier)(address . bavier@posteo.net)
CAEwRq=pFkq_J+7GNRFNaGp3msYS4NsHjqLYJKhyRFPAeepzN9g@mail.gmail.com
Hello

On Mon, Mar 2, 2020 at 7:24 AM Eric Bavier <bavier@posteo.net> wrote:
Toggle quote (6 lines)
> Hi Vincent, thanks for the patch, some comments below:
> On 01.03.2020 11:48, Vincent Legoll wrote:
> > lightly tested: cache hits on trivial .c file compilation
>
> And the tests still pass ;)

Yes, I should have mentionned it

Toggle quote (2 lines)
> Could you send updated patches?

Yes, I will, thanks for the review

--
Vincent Legoll
Vincent Legoll wrote 5 years ago
[PATCH, v2, 1/2] gnu: ccache: Update to 3.7.7.
(address . 39858@debbugs.gnu.org)
CAEwRq=oAe-_geQGjnAS02ks+8XJb9CgiKPzEEkFiYtLe0Y8knQ@mail.gmail.com
Here is the updated version:

split the reindent, use source tarball,
remove f77

Hope it's better...

--
Vincent Legoll
From 814563411dd26d76e79a94f535d989095d9a00dd Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Wed, 4 Mar 2020 18:29:00 +0100
Subject: [PATCH 1/2] gnu: ccache: Update to 3.7.7.

gnu/packages/ccache.scm (ccache): Update to 3.7.7, update homepage
to ccache.dev, get source code from github, remove fortran 77 from
description.
---
gnu/packages/ccache.scm | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index b3f0cbbd95..c0aafad1fd 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -30,14 +30,14 @@
(define-public ccache
(package
(name "ccache")
- (version "3.6")
+ (version "3.7.7")
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
- version ".tar.xz"))
+ (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
+ version "/ccache-" version ".tar.xz"))
(sha256
- (base32 "07wv75xdcxpdkfsz9h5ffrm8pjbvr1dh6wnb02nyzz18cdbjkcd6"))))
+ (base32 "1kcqii3hr1008gj6jgfsjibwh2ryhsplc9z99m18xwa2zvbddhdp"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
("which" ,(@ (gnu packages base) which))))
@@ -49,11 +49,10 @@
(substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
(("#!/bin/sh") (string-append "#!" (which "sh"))))
#t)))))
- (home-page "https://ccache.samba.org/")
+ (home-page "https://ccache.dev/")
(synopsis "Compiler cache")
(description
"Ccache is a compiler cache. It speeds up recompilation by caching
previous compilations and detecting when the same compilation is being done
-again. Supported languages are C, C++, Objective-C, Objective-C++, and
-Fortran 77.")
+again. Supported languages are C, C++, Objective-C and Objective-C++.")
(license gpl3+)))
--
2.25.1
Vincent Legoll wrote 5 years ago
[PATCH, v2, 2/2] gnu: ccache: Fix indentation
(address . 39858@debbugs.gnu.org)
CAEwRq=rubXKJMS3569e+9=h_KBYpT4nreK43pZZiGt2pdxUZ3w@mail.gmail.com
here the split indentation fix

--
Vincent Legoll
From 65d1ba85b1d9437a929d41dd96ebd86b4f0086f8 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Wed, 4 Mar 2020 18:38:59 +0100
Subject: [PATCH 2/2] gnu: ccache: Fix indentation

* gnu/packages/ccache.scm (ccache): Fix indentation
---
gnu/packages/ccache.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index c0aafad1fd..529742403e 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -44,11 +44,11 @@
(inputs `(("zlib" ,zlib)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'setup-tests
- (lambda _
- (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
- (("#!/bin/sh") (string-append "#!" (which "sh"))))
- #t)))))
+ (add-before 'check 'setup-tests
+ (lambda _
+ (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ #t)))))
(home-page "https://ccache.dev/")
(synopsis "Compiler cache")
(description
--
2.25.1
Ludovic Courtès wrote 5 years ago
Re: [bug#39858] [PATCH, v2, 1/2] gnu: ccache: Update to 3.7.7.
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 39858-done@debbugs.gnu.org)
87lfobeucq.fsf@gnu.org
Hi Vincent,

Applied both patches, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39858@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39858
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help