Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
lightly tested: cache hits on trivial .c file compilation
Additions to native inputs: asciidoc autoconf gperf
Trivial ./etc/indent-code.el housekeeping
More infos from ccache news:
2016-06-06: Source code and bug tracker moved to github
2019-04-03: Web site moved to ccache.dev
--
Vincent Legoll
From 9718baa06727eb515030cf7b617a10e9fab8052a Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 1 Mar 2020 17:59:10 +0100
Subject: [PATCH] gnu: ccache: Update to 3.7.7.
* gnu/packages/ccache.scm (ccache): Update to 3.7.7.
* gnu/packages/ccache.scm (ccache): Update source to github
* gnu/packages/ccache.scm (ccache): Update home-page to ccache.dev
* gnu/packages/ccache.scm (ccache): Add native inputs: asciidoc autoconf gperf
* gnu/packages/ccache.scm (ccache): Reindent arguments
---
gnu/packages/ccache.scm | 33 +++++++++++++++++++++------------
1 file changed, 21 insertions(+), 12 deletions(-)
Toggle diff (70 lines)
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index b3f0cbbd95..55d03daf21 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,35 +22,43 @@
(define-module (gnu packages ccache)
#:use-module (guix packages)
#:use-module ((guix licenses) #:select (gpl3+))
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages gperf)
#:use-module (gnu packages perl)
#:use-module (gnu packages compression))
(define-public ccache
(package
(name "ccache")
- (version "3.6")
+ (version "3.7.7")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
- version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccache/ccache.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "07wv75xdcxpdkfsz9h5ffrm8pjbvr1dh6wnb02nyzz18cdbjkcd6"))))
+ (base32 "1s8mq832chk95wa5qwaalralwv3ln1m931nrgd9a4gi19lg55zln"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
+ ("asciidoc" ,asciidoc)
+ ("autoconf" ,autoconf)
+ ("gperf" ,gperf)
("which" ,(@ (gnu packages base) which))))
(inputs `(("zlib" ,zlib)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'setup-tests
- (lambda _
- (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
- (("#!/bin/sh") (string-append "#!" (which "sh"))))
- #t)))))
- (home-page "https://ccache.samba.org/")
+ (add-before 'check 'setup-tests
+ (lambda _
+ (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ #t)))))
+ (home-page "https://ccache.dev/")
(synopsis "Compiler cache")
(description
"Ccache is a compiler cache. It speeds up recompilation by caching
--
2.25.1