[PATCH] Add lv2lint.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Leo Famulari
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
3bc6eaeec9c24165f641bb89532707125f48ec4c.camel@zrythm.org
Hi,

This patch adds lv2lint, an LV2 plugin lint tool used by plugin authors
during development/tests.

Thanks,
Alex
From a31f4f7e9ce1cdbc1cde5cc6da9859e1027680eb Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:11:29 +0000
Subject: [PATCH] gnu: Add lv2lint.

* gnu/packages/audio.scm (lv2lint): New variable.
---
gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5b8c610882..5be14f3859 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4036,3 +4036,37 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
@code{audio_decoder} code.")
(home-page "https://git.zrythm.org/cgit/libaudec")
(license license:agpl3+)))
+
+(define-public lv2lint
+ (package
+ (name "lv2lint")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.open-music-kontrollers.ch/lv2/lv2lint")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pspwqpzl2dw1hd9ra9yr53arqbbqjn7d7j0f7p9g3iqa76vblpi"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ `("-Delf-tests=true" ; for checking symbol visibility
+ "-Donline-tests=true"))) ; for checking URI existence
+ (inputs
+ `(("curl", curl)
+ ("libelf", libelf)
+ ("lilv", lilv)))
+ (native-inputs
+ `(("pkg-config", pkg-config)
+ ("git", git)
+ ("lv2", lv2)))
+ (synopsis "LV2 plugin lint tool")
+ (description "lv2lint is an LV2 lint-like tool that checks whether a
+given plugin and its UI(s) match up with the provided metadata and adhere
+to well-known best practices.")
+ (home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
+ (license license:artistic2.0)))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl5VOdcACgkQAi6uQjE9
cPNgSgf8DNrg4kWKEoOcckGfL61D2vgpnJh+3CjBE+86gKGBvIbzuXAxnSB6QDJi
68sulciFVE54Ambr9GTFqbkRx/EhDEUKp0Xv7APZhSG3UGiakypNxaWQlxYeH431
WOx73KH92Ya1xmjJmvNAGf9mJuBT1p768CPMLMn+cnlOMAhxlGfzxkbHRvS8rP+w
7ImY56iMh32BAyHtNvwL//DmFzIhdpQs3KKDobLPOd8UxClYVYuFgTNPVTya0GoF
EBEJMBBniUZaZo/Xsc3HI8tRpLtSSFhlR9emrRXCMWeZqCl3IIJs2SEXEd48nrar
iFhQ4GakBfNMKA1nc2DdRfDC+CEpdw==
=YBYQ
-----END PGP SIGNATURE-----


Leo Famulari wrote 5 years ago
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 39785-done@debbugs.gnu.org)
20200315191526.GI5561@jasmine.lan
Toggle quote (7 lines)
> From a31f4f7e9ce1cdbc1cde5cc6da9859e1027680eb Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Tue, 25 Feb 2020 15:11:29 +0000
> Subject: [PATCH] gnu: Add lv2lint.
>
> * gnu/packages/audio.scm (lv2lint): New variable.

Thanks! Pushed as 70d9ef51392e9f8b33af4a7dea459eedd2ca738b after
importing the elf module (required for libelf) and removing git and lv2
from native-inputs, since they did not seem to be used.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl5ufs4ACgkQJkb6MLrK
fwj/ARAAvU8e6zYjvTb9xfhtLboSQLkb2SgfMv7W+K1oSbifCKxAPkW6hK3KY71s
DRNaMYC2Hdabx9PI4rcaFPtoCcPEFCwAzRNy8hABONoun9XA8EA6GRfYZ+D72pfc
zyelTRsoynUjjhy/4PIAbr4CK2jufLbf8lewKeBmnfw+UAl4iz5HxyelrzFTAvUw
LJJBLNnxeWUbbNe2JnTBGMGWU5RL7U0Y/3lEOEzML20cANWIc9VBub9Bi7swJQy+
Eqtu/THdp2Sd0Mu+ZlSJCSKCVVvA3ZdgjNcQX6RB1UCZ0UrgdMQMKfIfD9kZDbWq
F+AMciXy72vzdejhgEXJ6L5tyYUnGF+lYN1ULTostJgvGWSVOLzMw3FMk5F5ntZ6
IcZ/PjgcP4xcNeyv8Raen9SKouGLiORECyN1K78qm5zQVkhAm4CTxd6cp2h7oI8Q
qfRDTccyv05uloY0wu95cmKlBmUkHEqEQNU2WuS798z6srl6CMDA9dG7w4MW/GP5
VwVqrkh6aLslpdRWpCY96WoqtBNv0xymnN1YwjTTrZYTkwccLhz8eJcUMem7t5oY
jSETFuAsoYE7iaoOOwRJ+qUGmOq48QDTkuV5lZK49hRF8KCYEEgQG4F5kGoOsIow
3FdYUEbIDNNck2OBIk4/b0IilZ0O1LD2Zzd2Lp25MrL+Oj14Ek8=
=gm2E
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39785@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39785
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help