Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
This patch adds lv2lint, an LV2 plugin lint tool used by plugin authors
during development/tests.
Thanks,
Alex
From a31f4f7e9ce1cdbc1cde5cc6da9859e1027680eb Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:11:29 +0000
Subject: [PATCH] gnu: Add lv2lint.
* gnu/packages/audio.scm (lv2lint): New variable.
---
gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5b8c610882..5be14f3859 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4036,3 +4036,37 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
@code{audio_decoder} code.")
(home-page "https://git.zrythm.org/cgit/libaudec")
(license license:agpl3+)))
+
+(define-public lv2lint
+ (package
+ (name "lv2lint")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.open-music-kontrollers.ch/lv2/lv2lint")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pspwqpzl2dw1hd9ra9yr53arqbbqjn7d7j0f7p9g3iqa76vblpi"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ `("-Delf-tests=true" ; for checking symbol visibility
+ "-Donline-tests=true"))) ; for checking URI existence
+ (inputs
+ `(("curl", curl)
+ ("libelf", libelf)
+ ("lilv", lilv)))
+ (native-inputs
+ `(("pkg-config", pkg-config)
+ ("git", git)
+ ("lv2", lv2)))
+ (synopsis "LV2 plugin lint tool")
+ (description "lv2lint is an LV2 lint-like tool that checks whether a
+given plugin and its UI(s) match up with the provided metadata and adhere
+to well-known best practices.")
+ (home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
+ (license license:artistic2.0)))
--
2.25.1
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl5VOdcACgkQAi6uQjE9
cPNgSgf8DNrg4kWKEoOcckGfL61D2vgpnJh+3CjBE+86gKGBvIbzuXAxnSB6QDJi
68sulciFVE54Ambr9GTFqbkRx/EhDEUKp0Xv7APZhSG3UGiakypNxaWQlxYeH431
WOx73KH92Ya1xmjJmvNAGf9mJuBT1p768CPMLMn+cnlOMAhxlGfzxkbHRvS8rP+w
7ImY56iMh32BAyHtNvwL//DmFzIhdpQs3KKDobLPOd8UxClYVYuFgTNPVTya0GoF
EBEJMBBniUZaZo/Xsc3HI8tRpLtSSFhlR9emrRXCMWeZqCl3IIJs2SEXEd48nrar
iFhQ4GakBfNMKA1nc2DdRfDC+CEpdw==
=YBYQ
-----END PGP SIGNATURE-----